Results 1 to 3 of 3

Thread: Compile of PDCurses fails on Leap 15.1

  1. #1
    Join Date
    Feb 2009
    Location
    Concordia, MO, USA
    Posts
    159

    Default Compile of PDCurses fails on Leap 15.1

    I'm trying to compile PDCurses
    HTML Code:
    https://github.com/wmcbrine/PDCurses/
    for use in building The Hessling Editor on my Leap 15.1 system. ./configure --enable-force-utf8 fails with this message:
    Code:
    which: no dpkg-architecture in (/home/leslie/bin/rexx:/home/leslie/bin/NetRexx:/home/leslie/bin:/home/leslie/.local/bin:/usr/local/bin:/opt/trinity/bin:/opt/trinity/lib64:/bin:/usr/bin:/usr/local/sbin:/sbin:/usr/sbin:/usr/local/lib64:/usr/local/lib)
    from which I conclude that PDCurses thinks my system is Debian based!

    The first line of output from ./configure is

    Code:
    configure: loading site script /usr/share/site/x86_64-unknown-linux-gnu
    which surprises me; I would expect to see something about OpenSuSE in there instead of 'unknown'.

    How can I get PDCurses to recognize my system as RPM-based?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,149
    Blog Entries
    15

    Default Re: Compile of PDCurses fails on Leap 15.1

    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Feb 2009
    Location
    Concordia, MO, USA
    Posts
    159

    Default Re: Compile of PDCurses fails on Leap 15.1 - solved

    Quote Originally Posted by malcolmlewis View Post
    Thanks, but I think I've gotten past this, by installing dpkg.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •