Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Firefox scrollbar doesn't work

  1. #11
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,817
    Blog Entries
    15

    Default Re: Firefox scrollbar doesn't work

    Hi
    One thought, are you running Wayland or Xorg?

    Code:
    echo $XDG_SESSION_TYPE
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  2. #12

    Default Re: Firefox scrollbar doesn't work

    Quote Originally Posted by malcolmlewis View Post
    Hi
    One thought, are you running Wayland or Xorg?

    Code:
    echo $XDG_SESSION_TYPE

    Wayland,
    - on both this workstation and on the mentioned hidpi ultrabook (XPS13/9370)

    I thought also about this yesterday, but couldn't remember how to verify Wayland or X11 after logon.
    Looking on the GDM session setting menu, it doesn't tell clearly what is selected, just the GNOME entry on top, so obviously Wayland is the default for Gnome on Leap (?). (I remember I also tried both Wayland and X11 during a previous Leap beta, due to other hidpi scaling issues on the ultrabook).

    But most important, when I now enable "Gnome on Xorg" at GDM logon on my workstation, the FF demaximized window's scrollbar works correctly!
    One thought about why Firefox on the workstation and on the ultrabook behave differently with Wayland, may be some different scale settings.

  3. #13
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,817
    Blog Entries
    15

    Default Re: Firefox scrollbar doesn't work

    Quote Originally Posted by terjejh View Post
    Wayland,
    - on both this workstation and on the mentioned hidpi ultrabook (XPS13/9370)

    I thought also about this yesterday, but couldn't remember how to verify Wayland or X11 after logon.
    Looking on the GDM session setting menu, it doesn't tell clearly what is selected, just the GNOME entry on top, so obviously Wayland is the default for Gnome on Leap (?). (I remember I also tried both Wayland and X11 during a previous Leap beta, due to other hidpi scaling issues on the ultrabook).

    But most important, when I now enable "Gnome on Xorg" at GDM logon on my workstation, the FF demaximized window's scrollbar works correctly!
    One thought about why Firefox on the workstation and on the ultrabook behave differently with Wayland, may be some different scale settings.
    Hi
    So how did you enable scaling, via gsettings command and then adjust via device settings?

    I use;
    Code:
    gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #14

    Default Re: Firefox scrollbar doesn't work

    Quote Originally Posted by malcolmlewis View Post
    Hi
    So how did you enable scaling, via gsettings command and then adjust via device settings?
    I use the following scale settings with Gnome gui tools:

    fonts:
    gnome-control-center: Universal Access > Large text enabled
    gnome-tweak-tool (tweaks): Text > 1,25 scale factor

    screen (generic):
    gnome-control-center: Units > Screens: 100% (my workstation w/24" 1920x1080 screen)
    (gnome-control-center: Units > Screens: 200% (my xps13 ultrabook w/ hidpi 3840x2160))

  5. #15
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,817
    Blog Entries
    15

    Default Re: Firefox scrollbar doesn't work

    Hi
    I would suggest the gsetting command I use and see if that helps, set the laptop one to 125% via device settings.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #16

    Default Re: Firefox scrollbar doesn't work

    Quote Originally Posted by malcolmlewis View Post
    Hi
    I would suggest the gsetting command I use and see if that helps, set the laptop one to 125% via device settings.
    Hi, I tested the gsetting command on my workstation, and disabled the Universal Large Text.
    This unhappily had no effect on the FF demaximized window scrollbar issue.

    Because the text fonts became smaller than I prefere, I also tried the device screen scale factor 125% on the workstation, which was not a good combination for its 1920 resolution screen (yes, I noticed you suggested it for the laptop) as the app icons became blurry. I re-enabled therefore the Universal Access Large Text, which in effect upscales the fonts 1,25 (noticed that with Tweaks opened) and possibly also increase the boldness/sharpness (contrast).

  7. #17
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,817
    Blog Entries
    15

    Default Re: Firefox scrollbar doesn't work

    Hi
    I only have Tumbleweed running wayland (DELL Venue 11), Leap 15.1 is Nvidia on Xorg (qemu machine). I'm assuming on the defaults (even small) work fine in wayland, just when you scale it plays up?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #18

    Default Re: Firefox scrollbar doesn't work

    Well, I think it's time to thank for the help to troubleshoot this and leave this FF scrollbare issue on Leap 15.1 for the present time. The workaround is Gnome/Xorg or Gnome/Wayland session using the mouse scroll button only or a FF maximized window where scroll bar is working.
    This workstation is a Supermicro X10SAE, Intel Xeon E3-1241 cpu, NVIDIA GM206 [GeForce GTX 960] using nouveau driver.

    I had also Thumbleweed in a dual-boot setup on this machine (root with embedded /home), upgraded it to the current 20200124 version (kernel 5.4.13, Gnome shell 3.34.3, FF 72.0.2 (not esr)). Tested a Gnome/Wayland session here which confirmed that also the demaximized FF window had a normal working scrollbar.

  9. #19

    Default Re: Firefox scrollbar doesn't work

    Quote Originally Posted by terjejh View Post
    This workstation is a Supermicro X10SAE, Intel Xeon E3-1241 cpu, NVIDIA GM206 [GeForce GTX 960] using nouveau driver.
    I had a similar problem with a missing scrollbar in the Firefox window quite some time ago.
    That occurred under Leap 42.2 or 42.3 with KDE on a laptop with as well NVIDIA graphics.

    A workaround that I then found by chance for that configuration was to start Thunderbird first, and then additionally start Firefox afterwards.
    Then I did get a scrollbar for the Firefox window.

  10. #20

    Default Re: Firefox scrollbar doesn't work

    I tried that order and started Thunderbird first and then Firefox next. While Thunderbird's scrollbar works perfectly, this didn't help regards the non-working Firefox scrollbar.

    If someone tells me which Firefox environment profile to try and rename, I could try to copy a corresponding and working Firefox profile from another machine and test if this fix the scrollbar issue? (I expect scaling etc has to customized, because the other machine is on a hdpi ultra-book).

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •