Results 1 to 3 of 3

Thread: https mod rewrite problem

  1. #1

    Default https mod rewrite problem

    I am building a Drupal 8.8.1 new site on my home machine. It works perfectly if I use an address like http://192.168.1.5/bpc/bpc/web

    But if I use https://192.168.1.5/bpc/bpc/web/ The home page works, but all others require "?=" to work. E.g.,
    https://192.168.1.5/bpc/bpc/web/?=contact instead of https://192.168.1.5/bpc/bpc/web/contact

    So clearly, mod_rewrite is not working for https. I don't think the .htaccess files distinguish between http and https, so I think this must be somewhere on my apache2 server. Any ideas?

  2. #2

    Default Re: https mod rewrite problem

    I fixed this. ssl.conf needed a <directory> entry for the host.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,316
    Blog Entries
    14

    Default Re: https mod rewrite problem

    Quote Originally Posted by jarome View Post
    I fixed this. ssl.conf needed a <directory> entry for the host.
    A tip: always create seperate vhosts for http and https, where the http only needs the minimal and a redirect to https,
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •