Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Yast programs

Hybrid View

  1. #1
    Join Date
    Apr 2009
    Location
    South Africa
    Posts
    11

    Default Yast programs

    Hello,
    When I start Yast2 on the command line :: /sbin/yast2
    I get this ::

    frik@localhost:~> /sbin/yast2
    Run command: /sbin/yast2 inst_release_notes &
    terminate called after throwing an instance of 'YUIPluginException'
    what(): Couldn't load plug-in qt
    /sbin/yast2: line 468: 4985 Aborted (core dumped) $ybindir/y2start $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

    This was after a update about an hour ago ??

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,814

    Default Re: Yast programs

    Note 15.2 is still very much beta.So maybe just broken at the moment. If so should get a fix soon

    Most problems with Yast are caused by mixed repos. So check that all repos are 15.2

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,324
    Blog Entries
    3

    Default Re: Yast programs

    Working fine here.

    It isn't clear what you are doing. In my case, I am running KDE. I opened a "konsole", and then used "su" to become root. And from there "yast2" worked fine.

    Using "sudo" won't work, because "sudo" does not pass $DISPLAY . And you do need a GUI session to be running.

    If you want the command line version of "yast" then use "yast" rather than "yast2". Or use "yast2 --ncurses".
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Apr 2009
    Location
    South Africa
    Posts
    11

    Default Re: Yast programs

    Quote Originally Posted by nrickert View Post
    Working fine here.

    It isn't clear what you are doing. In my case, I am running KDE. I opened a "konsole", and then used "su" to become root. And from there "yast2" worked fine.

    Using "sudo" won't work, because "sudo" does not pass $DISPLAY . And you do need a GUI session to be running.

    If you want the command line version of "yast" then use "yast" rather than "yast2". Or use "yast2 --ncurses".
    -----------------------------------------------------

    It seems better but if I select "software management" I get a red box that says :

    │ UI Syntax Error │
    │Couldn't load plug-in ncurses-pkg│
    │ Check the log file!

    however the ncurses is installed.

    Regards
    Frik Brits.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,324
    Blog Entries
    3

    Default Re: Yast programs

    There must be something missing in your install. It works fine here.

    What's the output from
    Code:
    zypper lr -d
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6
    Join Date
    Apr 2009
    Location
    South Africa
    Posts
    11

    Default Re: Yast programs

    Quote Originally Posted by nrickert View Post
    There must be something missing in your install. It works fine here.

    What's the output from
    Code:
    zypper lr -d
    localhost:~ # zypper lr -d
    # | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
    ---+-------------------------------------+------------------------------------+---------+-----------+---------+----------+----------+---------------------------------------------------------------------------------------+--------
    1 | http-download.opensuse.org-86ecedf4 | Virtualization | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...15.2_standard/ |
    2 | openSUSE-Leap-15.2-1 | openSUSE-Leap-15.2-1 | No | ---- | ---- | 99 | rpm-md | cd:/?devices=/dev/disk/by-id/ata-HL-DT-STDVD-RAM_GH22LS30 |
    3 | repo-debug | Debug Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/debug/d...15.2/repo/oss/ |
    4 | repo-debug-non-oss | Debug Repository (Non-OSS) | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/debug/d.../repo/non-oss/ |
    5 | repo-debug-update | Update Repository (Debug) | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/u...leap/15.2/oss/ |
    6 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS) | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/u.../15.2/non-oss/ |
    7 | repo-non-oss | Non-OSS Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/distrib.../repo/non-oss/ |
    8 | repo-oss | Main Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/distrib...15.2/repo/oss/ |
    9 | repo-source | Source Repository | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/...15.2/repo/oss/ |
    10 | repo-source-non-oss | Source Repository (Non-OSS) | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/.../repo/non-oss/ |
    11 | repo-update | Main Update Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/15.2/oss |
    12 | repo-update-non-oss | Update Repository (Non-Oss) | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/leap/15.2/non-oss/ |
    13 | rpms | PC | Yes | ( p) Yes | Yes | 99 | plaindir | dir:/bigdisk/downloads/rpms |
    localhost:~ #

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,324
    Blog Entries
    3

    Default Re: Yast programs

    Repos look okay.

    Run:
    Code:
    zypper dup
    at the terminal (as root).

    For Leap 15.2, you need to use "zypper dup" for updating, until the final release. After the release version is out, then switch over to normal update methods.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,430

    Default Re: Yast programs

    Additionally:

    Check you have the basic libyui*n packages and that "n" is the same for all packages, I don't know what version of libyui 15.2 ships with. This TW system has "11"

    libyui11
    libyui-qt11
    libyui-qt-pkg11
    libyui-ncurses11
    libyui-ncurses-pkg11
    Regards, Paul

    2x Tumbleweed (Snapshot: 20200314) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,324
    Blog Entries
    3

    Default Re: Yast programs

    Yes, it is "11" for Leap 15.2. But Yast was updated recently. And if that changed the version, the OP might still have the old packages rather than the new. Or, worse, he might have a mixture. That's what "zypper dup" can fix.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  10. #10
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,430

    Default Re: Yast programs

    Quote Originally Posted by nrickert View Post
    ... That's what "zypper dup" can fix.
    There was a bug a while back whereby "libyui-ncurses-pkgN" wasn't being updated/installed on some systems. I was caught by it when libyui* went from 9 -> 10. Having said that, 10 -> 11 went OK, so yes, hopefully a zypper dup will fix in the case of the OP.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20200314) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •