Results 1 to 3 of 3

Thread: Crashes on Suspend

  1. #1

    Default Crashes on Suspend

    Hello everyone! I was not sure where to put this thread on the forum, but I feel like it could potentially be classified under a "booting problem." Quick story: I finally made the jump from windows a little over a year ago to using LEAP 15.1 and I have loved absolutely every second of it! I cannot begin to say how much I love openSUSE! In September I purchased a new HP Spectre x360 13" laptop and unfortunately I have spent most of my time with it since then trying to make it work. I decided to go the TUMBLEWEED route with my laptop and have already reinstalled the OS about three times now working on fixing issues. Given enough time, I have been successful with everything I have attempted to fix, except for two issues, one of which follows:

    My first install of Tumbleweed was with the gnome desktop, where it worked provisionally well for a while until about a week and a half ago when it developed an issue where on closing the lid of the laptop, it would not suspend the system. The fans would often be running, and the power light would still be on, and no matter how long I waited it would not go to sleep. Upon opening the lid back up, i would be met with a black screen with the backlight still on, and eventually the caps lock key would start blinking. I have looked on the HP forums, and many note that this means the bios is corrupted. I have a dual boot set up, with the openSUSE UEFI partition handling booting for both openSUSE and Windows 10. I booted into windows 10 where it behaved the exact same way- windows would crash or just refuse to suspend the system. I installed an update Windows 10 had downloaded for the HP bios and the windows problem went away. Windows 10 would suspend normally on closing the lid of the laptop. Tumbleweed still would not. Somewhere online I found someone talking about GNOME sometimes hanging on waiting for something, so that combined with a few other issues I was having with GNOME at the time made me curious to install KDE Plasma (which is my preferred DE anyway). Logging out of GNOME, and logging back into KDE made the issue go away! Closing the lid now actually successfully put the machine into a suspended state!

    Unfortunately, because of the other issue mentioned in my first paragraph, I decided to reinstall Tumbleweed again with the KDE desktop as default. The other issue I was having was sound related, where KDE would say "No Input or Output Devices found" and even YaST2 would run into a "kernel module could not be loaded" problem when trying to configure my sound card. I add this information to this post just in case it might pertain to the suspend problem. After installing a bunch of updates after the second OS Install, suddenly the audio issue was back. Suspend continued to work, however; until last night when I installed updates via zypper. I close the lid on the machine, and it started doing the all to familiar dance of the fans coming on slightly, the power light not shutting off, and then upon opening the lid- the caps lock began to blink. Hard restarting the machine always brings openSUSE up- it never has any trouble booting from off, only coming back from a suspend state. And the same is true even when selecting "Sleep/Suspend to RAM" from the KDE menu.

    Thank you all so much in advance for any help you might be able to provide on the matter! Even if the answer is going back to LEAP I certainly do not mind at this point! If I can get this sorted out, then I will likely make another post under Hardware for the audio related issue with more detail.

  2. #2

    Default Re: Crashes on Suspend


  3. #3

    Default Re: Crashes on Suspend

    Quote Originally Posted by bobbie424242 View Post
    Thank you so much for sharing that! I looked through the entire bugzilla thread and it looks like it was the same exact problem I was experiencing.

    I started off by trying to use lsmod to view all modules related to the "snd_hda_intel" module that was giving YaST trouble. Following this I used modprobe to remove every module listed. This fixed my issue for about an hour and suspend worked, then the same issue came right back. Running a distribution upgrade through zypper to kernel version 5.4.12 did not fix the issue either. Yesterday, I ran another distribution upgrade to 5.4.13, which included a long list of kernel hardware packages. After the upgrade, I used modprobe to re-enable all of the modules I removed earlier and the issue is now totally resolved! On top of that, sound is working on my computer again as well!

    It appears that a lot of people have had issues with hardware regardless of computer manufacturer or distribution. So it looks like this actually was a kernel/hardware problem.

    Thank you for your help bobbie424242!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •