Results 1 to 10 of 10

Thread: Cannot update software.

  1. #1

    Default Cannot update software.

    Get the following error
    PackageKit-branding-openSUSE-42.1-1.19.noarch requires PackageKit = 1.1.9, but this requirement cannot be provided
    nothing provides libzypp.so.1709 needed by PackageKit-backend-zypp-1.1.10-lp151.8.3.1.i586
    nothing provides libzypp.so.1709 needed by PackageKit-backend-zypp-1.1.10-lp151.8.3.1.i586
    yast2-ruby-bindings-4.0.4-1.2.x86_64 requires

    When I try to install PackageKit, Yast crashes.
    When I run zypper on terminal, gives me 4 options, when I type number for any option, goes back to options again.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,810
    Blog Entries
    15

    Default Re: Cannot update software.

    Quote Originally Posted by mrjacque View Post
    Get the following error
    PackageKit-branding-openSUSE-42.1-1.19.noarch requires PackageKit = 1.1.9, but this requirement cannot be provided
    nothing provides libzypp.so.1709 needed by PackageKit-backend-zypp-1.1.10-lp151.8.3.1.i586
    nothing provides libzypp.so.1709 needed by PackageKit-backend-zypp-1.1.10-lp151.8.3.1.i586
    yast2-ruby-bindings-4.0.4-1.2.x86_64 requires

    When I try to install PackageKit, Yast crashes.
    When I run zypper on terminal, gives me 4 options, when I type number for any option, goes back to options again.
    Hi
    I would surmise from that output you have the wrong repositories enabled..... lp151 is not a Tumbleweed package.

    Can you post the output from;

    Code:
    zypper lr -d
    Plus with Tumbleweed, you should just be using zypper dup from the command line.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Cannot update software.

    Tried to load latest zypper using terminal in case that was a problem, would not load with option 1 so loaded only option that would load, so may also have destroyed zypper

    zypper: error while loading shared libraries: libzypp.so.1720: cannot open shared object file: No such file or directory

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,810
    Blog Entries
    15

    Default Re: Cannot update software.

    Quote Originally Posted by mrjacque View Post
    Tried to load latest zypper using terminal in case that was a problem, would not load with option 1 so loaded only option that would load, so may also have destroyed zypper
    Hi
    You have a broken system...... was there any output from the command I requested?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Cannot update software.

    The quote I supplied is the error from the terminal.
    How do I load zypper without yast?

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,810
    Blog Entries
    15

    Default Re: Cannot update software.

    Quote Originally Posted by mrjacque View Post
    The quote I supplied is the error from the terminal.
    How do I load zypper without yast?
    Hi
    What about the following;

    Code:
    ls /etc/zypp/repos.d/
    cat /etc/os-release
    Might need to make a backup and re-install.....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7

    Default Re: Cannot update software.

    Unfortunately, this is occurring after I re-installed Tumbleweed from DVD on a broken Tumbleweed system.

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,810
    Blog Entries
    15

    Default Re: Cannot update software.

    Quote Originally Posted by mrjacque View Post
    Unfortunately, this is occurring after I re-installed Tumbleweed from DVD on a broken Tumbleweed system.
    Hi
    What dvd snapshot are you using for the re-install? If not the latest (20200118), then suggest you download that one....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9

    Default Re: Cannot update software.

    Trying to do a update and I get this:
    Problem: libappstream-builder8-0.7.8+3-1.1.x86_64 requires librpm.so.8()(64bit), but this requirement cannot be provided
    deleted providers: rpm-4.14.2.1-9.2.x86_64
    not installable providers: rpm-4.14.1-7.1.x86_64[openSUSE-20180525-0]

    zypper lr -d


    --+--------+--------------------------------------------------------------------+--------
    1 | Google-Chrome | Google-Chrome | No | ---- | ---- | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64 |
    2 | adobe | adobe | Yes | ( p) Yes | Yes | 99 | rpm-md | http://linuxdownload.adobe.com/linux/x86_64/ |
    3 | google-chrome | google-chrome | Yes | (r ) Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64 |
    4 | openSUSE-20180525-0 | openSUSE-20180525-0 | Yes | (r ) Yes | No | 99 | rpm-md | cd:/?devices=/dev/disk/by-id/ata-HL-DT-ST_DVDRAM_GUE1N_KX5H5J25046 |
    5 | packman | packman | Yes | (r ) Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/ |
    6 | repo-debug | openSUSE-Tumbleweed-Debug | No | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/tumbleweed/repo/oss/ |
    7 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/ |
    8 | repo-oss | openSUSE-Tumbleweed-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/ |
    9 | repo-source | openSUSE-Tumbleweed-Source | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/source/...weed/repo/oss/ |
    10 | repo-update | openSUSE-Tumbleweed-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed/ |

    That is my Repo list .
    Thanks

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,306
    Blog Entries
    14

    Default Re: Cannot update software.

    1. Please use CODE tags around output. It's the # in the editor layout ribbon.

    2. You have used an ancient Tumbleweed snapshot ( > 1,5 years is ancient for a rolling release )

    3. You should NOT use YaSTs software manager to update Tumbleweed, see the documentation.

    4. Like Malcolm already suggested: backup your data, download and install the latest DVD image for Tumbleweed. And use nothing but ( in come the CODE tags :-) )
    Code:
    sudo zypper dup
    or, if on KDE or GNOME the updater applet of the desktop environment.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •