Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: created new partition for /home, having trouble moving data

  1. #11
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,204
    Blog Entries
    3

    Default Re: created new partition for /home, having trouble moving data

    Quote Originally Posted by hcvv View Post
    You did not delete all the data in /home that was there all the time. You can not reach that data as long as your new /home file system is mounted on /home. Noody can, not even root, because nobody can see it.
    Not completely true.

    What I have done, in that case, is:
    Code:
    mount --bind / /mnt
    cd /mnt/home
    ls -l  ### carefully check timestamps to be sure that this is the old "/home" and not the new one.
    /bin/rm -f *
    cd /
    umount /mnt
    The "--bind" mount does not apply to mounted file systems, so you can see what is in the original "/home"
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  2. #12
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,788

    Default Re: created new partition for /home, having trouble moving data

    Quote Originally Posted by nrickert View Post
    Not completely true.

    What I have done, in that case, is:
    Code:
    mount --bind / /mnt
    cd /mnt/home
    ls -l  ### carefully check timestamps to be sure that this is the old "/home" and not the new one.
    /bin/rm -f *
    cd /
    umount /mnt
    The "--bind" mount does not apply to mounted file systems, so you can see what is in the original "/home"
    OK, higher science
    Good to make a mental note if this.
    Henk van Velden

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •