Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: no graphic login after today upgrade

  1. #1

    Default no graphic login after today upgrade

    on my TUXEDO InfinityBook Pro 15 v4, processor= Intel Core i7-8565U, RAM=32Gb, 2TB SSD disk
    I upraded TW with KDE with zypper dup --no-allow-vendor-change and no graphicc login.
    this is the problem appeared:
    https://susepaste.org/51836074
    it suggest to look at:
    /home/pla/.local/share/xorg/Xorg.0.log
    Code:
    [    44.201] 
    X.Org X Server 1.20.6
    X Protocol Version 11, Revision 0
    [    44.201] Build Operating System: openSUSE SUSE LINUX
    [    44.201] Current Operating System: Linux pla4-TW.homenet.telecomitalia.it 5.4.10-1-default #1 SMP Thu Jan 9 15:45:45 UTC 2020 (556a6fe) x86_64
    [    44.201] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.4.10-1-default root=UUID=1d751934-8345-408d-a47f-56e6b4d09f7a resume=/dev/disk/by-uuid/551fc2e6-1664-473b-ba77-495bc9bbbed7 splash=silent quiet showopts loglevel=0 acpi_osi= acpi_os_name=Linux acpi_backlight=vendor
    [    44.201] Build Date: 29 November 2019  12:00:00PM
    [    44.201]  
    [    44.202] Current version of pixman: 0.36.0
    [    44.202]     Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
    [    44.202] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [    44.202] (==) Log file: "/home/pla/.local/share/xorg/Xorg.0.log", Time: Sat Jan 18 17:34:36 2020
    [    44.203] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [    44.203] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [    44.207] (==) No Layout section.  Using the first Screen section.
    [    44.207] (==) No screen section available. Using defaults.
    [    44.207] (**) |-->Screen "Default Screen Section" (0)
    [    44.207] (**) |   |-->Monitor "<default monitor>"
    [    44.207] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
    [    44.207] (==) Automatically adding devices
    [    44.208] (==) Automatically enabling devices
    [    44.208] (==) Automatically adding GPU devices
    [    44.208] (==) Max clients allowed: 256, resource mask: 0x1fffff
    [    44.210] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    [    44.210]     Entry deleted from font path.
    [    44.210] (==) FontPath set to:
        /usr/share/fonts/misc:unscaled,
        /usr/share/fonts/Type1/,
        /usr/share/fonts/100dpi:unscaled,
        /usr/share/fonts/75dpi:unscaled,
        /usr/share/fonts/ghostscript/,
        /usr/share/fonts/cyrillic:unscaled,
        /usr/share/fonts/truetype/,
        built-ins
    [    44.210] (==) ModulePath set to "/usr/lib64/xorg/modules"
    [    44.210] (WW) Ignoring unrecognized extension "XFree86-DGA"
    [    44.210] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
    [    44.210] (II) Loader magic: 0x55d9e2972d00
    [    44.210] (II) Module ABI versions:
    [    44.210]     X.Org ANSI C Emulation: 0.4
    [    44.210]     X.Org Video Driver: 24.0
    [    44.210]     X.Org XInput driver : 24.1
    [    44.210]     X.Org Server Extension : 10.0
    [    44.212] (++) using VT number 1
    
    [    44.217] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
    [    44.223] (--) PCI:*(0@0:2:0) 8086:3ea0:1558:1325 rev 0, Mem @ 0x6022000000/16777216, 0x4000000000/268435456, I/O @ 0x00004000/64, BIOS @ 0x????????/131072
    [    44.223] (II) LoadModule: "glx"
    [    44.225] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
    [    44.233] (II) Module glx: vendor="X.Org Foundation"
    [    44.233]     compiled for 1.20.6, module version = 1.0.0
    [    44.233]     ABI class: X.Org Server Extension, version 10.0
    [    44.233] (II) Scanning /etc/X11/xorg_pci_ids directory for additional PCI ID's supported by the drivers
    [    44.234] (==) Matched intel as autoconfigured driver 0
    [    44.234] (==) Matched modesetting as autoconfigured driver 1
    [    44.234] (==) Matched fbdev as autoconfigured driver 2
    [    44.234] (==) Matched vesa as autoconfigured driver 3
    [    44.234] (==) Assigned the driver to the xf86ConfigLayout
    [    44.234] (II) LoadModule: "intel"
    [    44.235] (WW) Warning, couldn't open module intel
    [    44.235] (EE) Failed to load module "intel" (module does not exist, 0)
    [    44.235] (II) LoadModule: "modesetting"
    [    44.235] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
    [    44.236] (II) Module modesetting: vendor="X.Org Foundation"
    [    44.236]     compiled for 1.20.6, module version = 1.20.6
    [    44.236]     Module class: X.Org Video Driver
    [    44.236]     ABI class: X.Org Video Driver, version 24.0
    [    44.236] (II) LoadModule: "fbdev"
    [    44.237] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
    [    44.237] (II) Module fbdev: vendor="X.Org Foundation"
    [    44.237]     compiled for 1.20.5, module version = 0.5.0
    [    44.237]     Module class: X.Org Video Driver
    [    44.238]     ABI class: X.Org Video Driver, version 24.0
    [    44.238] (II) LoadModule: "vesa"
    [    44.238] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
    [    44.238] (II) Module vesa: vendor="X.Org Foundation"
    [    44.239]     compiled for 1.20.5, module version = 2.4.0
    [    44.239]     Module class: X.Org Video Driver
    [    44.239]     ABI class: X.Org Video Driver, version 24.0
    [    44.239] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [    44.239] (II) FBDEV: driver for framebuffer: fbdev
    [    44.239] (II) VESA: driver for VESA chipsets: vesa
    [    44.239] (EE) 
    Fatal server error:
    [    44.239] (EE) xf86OpenConsole: Cannot open virtual console 1 (Permission denied)
    [    44.239] (EE) 
    [    44.239] (EE) 
    Please consult the The X.Org Foundation support 
         at http://wiki.x.org
     for help. 
    [    44.239] (EE) Please also check the log file at "/home/pla/.local/share/xorg/Xorg.0.log" for additional information.
    [    44.239] (EE) 
    [    44.239] (WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
    [    44.239] (WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor
    [    44.252] (EE) Server terminated with error (1). Closing log file.
    I rebooted with the previous kernel (5.3.12-2-default) and it worked fairly
    how can I boot with the last kernel and login fairly?

  2. #2

    Default Re: no graphic login after today upgrade

    Do you login via the text console and not SDDM ?

    If so, you need to have Xorg setuid root.

    For this, uncomment the 2 last lines of /etc/permission.local and to apply it run
    sudo chkstat --system /usr/bin/Xorg

  3. #3

    Default Re: no graphic login after today upgrade

    Quote Originally Posted by bobbie424242 View Post
    Do you login via the text console and not SDDM ?
    I logged in via text console becouse there wasn't SDDM login screen, that was the problem, but I would like to login with SDDM

    Quote Originally Posted by bobbie424242 View Post
    If so, you need to have Xorg setuid root.

    For this, uncomment the 2 last lines of /etc/permission.local and to apply it run
    sudo chkstat --system /usr/bin/Xorg

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,193
    Blog Entries
    15

    Default Re: no graphic login after today upgrade

    Hi
    This is a Nvidia machine? If so are you using the openSUSE repository for the drivers... they are still not up to date with the running kernel, as of today 5.4.12-1-default (20200121).

    http://http.download.nvidia.com/open...leweed/x86_64/

    Perhaps consider installing the hardway instead? https://en.opensuse.org/SDB:NVIDIA_the_hard_way
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: no graphic login after today upgrade

    Quote Originally Posted by malcolmlewis View Post
    Hi
    This is a Nvidia machine? If so are you using the openSUSE repository for the drivers... they are still not up to date with the running kernel, as of today 5.4.12-1-default (20200121).

    http://http.download.nvidia.com/open...leweed/x86_64/

    Perhaps consider installing the hardway instead? https://en.opensuse.org/SDB:NVIDIA_the_hard_way
    no, it is this:
    Hardware Class: graphics card
    Model: "Intel UHD Graphics 620 (Whiskey Lake)"

  6. #6
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,084

    Default Re: no graphic login after today upgrade

    --no-allow-vendor-change is the TW default, so there is no need to use it unless you have modified zypp.conf to change the default to allow.

    Do you have any non-TW repos enabled, other than Packman? If so, please use code tags or susepaste.org to show us output from zypper lr -d

    If not, try doing another zypper dup. It may be that something simply went wrong with the last one. First, use zypper al kernel-default-5.3.12* to provide additional insurance it won't be deleted before a newer kernel that works can be installed.

    Output from this pasted here using code tags after having attempted to use a broken kernel on the immediately preceding boot may also be helpful:
    Code:
    sudo journalctl -b -1 | egrep -i 'sddm|xdm|failed'
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1,TW,15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on 965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  7. #7

    Default Re: no graphic login after today upgrade

    Quote Originally Posted by mrmazda View Post
    --no-allow-vendor-change is the TW default, so there is no need to use it unless you have modified zypp.conf to change the default to allow.
    manythanks, it remained in my mind becouse I red something about the benefit to use allow-vendor-change in order to have the best of all... but I decided to remai to the standard

    Quote Originally Posted by mrmazda View Post
    Do you have any non-TW repos enabled, other than Packman? If so, please use code tags or susepaste.org to show us output from zypper lr -d
    here is
    Code:
    pla4-TW:/home/pla # zypper lr -d
    #  | Alias                                  | Name                 | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                        | Service
    ---+----------------------------------------+----------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------+--------
     1 | 15.1                                   | tuxedo-15.1          | No      | ----      | ----    |   99     | rpm-md | https://rpm.tuxedocomputers.com/opensuse/15.1/                             |        
     2 | openSUSE_Tumbleweed                    | suse-TUXEDO TW       | Yes     | (r ) Yes  | Yes     |   90     | rpm-md | http://download.opensuse.org/repositories/isv:/TUXEDO/openSUSE_Tumbleweed/ |        
     3 | opensuse-guide.org-openSUSE_Tumbleweed | libdvdcss repository | No      | ----      | ----    |   93     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                        |        
     4 | packman.inode.at-openSUSE_Tumbleweed   | Packman Repository   | Yes     | (r ) Yes  | Yes     |   90     | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/                          |        
     5 | repo-debug                             | repo-debug           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/debug                         |        
     6 | repo-non-oss                           | repo-non-oss         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss                       |        
     7 | repo-oss                               | repo-oss             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss                           |        
     8 | repo-src-non-oss                       | repo-src-non-oss     | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/tumbleweed/repo/src-non-oss                   |        
     9 | repo-src-os                            | repo-src-os          | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/tumbleweed/repo/src-oss                       |        
    10 | repo-update                            | repo-update          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                            |        
    11 | x86_64                                 | google(chrome)       | Yes     | (r ) Yes  | Yes     |   93     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                        |        
    pla4-TW:/home/pla #
    Quote Originally Posted by mrmazda View Post
    If not, try doing another zypper dup. It may be that something simply went wrong with the last one.
    I will try

    Quote Originally Posted by mrmazda View Post
    First, use zypper al kernel-default-5.3.12* to provide additional insurance it won't be deleted before a newer kernel that works can be installed.
    please could you explain better, I didn't understand how to use "zypper al kernel-default-5.3.12*", before zypper dup? after? during as an option? and then, when the new kernel works, how can I delete the old kernel?

    Quote Originally Posted by mrmazda View Post
    Output from this pasted here using code tags after having attempted to use a broken kernel on the immediately preceding boot may also be helpful:
    Code:
    sudo journalctl -b -1 | egrep -i 'sddm|xdm|failed'
    sorry again, what you intend for "on the immediately preceding boot"? how can I run the command you gave me on the immediately preceding boot?
    manythanks, ciao, P :-)

  8. #8
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    2,084

    Default Re: no graphic login after today upgrade

    Quote Originally Posted by pier_andreit View Post
    please could you explain better, I didn't understand how to use "zypper al kernel-default-5.3.12*", before zypper dup? after? during as an option? and then, when the new kernel works, how can I delete the old kernel?
    Code:
    # zypper al kernel-default-5.3.12*
    Specified lock has been successfully added
    # zypper ll | grep 5.3.1
    19 | kernel-default-5.3.12* | package | (any)
    # journalctl -b -1 | egrep -i 'sddm|xdm|failed'
    Jan 17 07:43:12 gb250 kernel: acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM
    Jan 17 12:43:15 gb250 systemd-udevd[504]: controlC0: Process '/usr/sbin/alsactl restore 0' failed with exit code 99.
    Jan 17 12:56:43 gb250 kernel: sd 7:0:0:0: [sdg] Synchronize Cache(10) failed: Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
    Jan 17 12:57:51 gb250 kernel: sd 7:0:0:0: [sdg] Asking for cache data failed
    # rpm -qa | grep 5.3.12
    kernel-default-5.3.12-2.2.x86_64
    # zypper ref
    ...
    # zypper dup
    ...
    ...
    ...
    ...
    ...
    ...
    ...
    ...
    ...
    ...
    ...
    ...
    # zypper rl kernel-default-5.3.12*
    1 lock has been successfully removed.
    # rpm -qa | grep 5.3.12
    kernel-default-5.3.12-2.2.x86_64
    # zypper rm kernel-default-5.3.12
    kernel-default-5.3.12 has been removed
    #
    sorry again, what you intend for "on the immediately preceding boot"? how can I run the command you gave me on the immediately preceding boot?
    1. Try to boot 5.4 kernel
    2. Boot 5.3 kernel
    3. Login
    4. Code:
      journalctl -b -1 | egrep -i 'sddm|xdm|failed'
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.1,TW,15.2 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&15.1 on 965P/Radeon
    Tertiary: TW,15.2,15.1,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  9. #9

    Default Re: no graphic login after today upgrade

    Had the same issue on my Tuxedo Infinity Book Pro with Intel graphics
    Get SDDM graphic login with Kernel 5.3 but not with 5.4.xx.
    I get following message during boot:
    i915 invalid for parameter enable_dpcd_backlight
    I changed the line in /etc/modprobe.d/i915.conf to #options i915 enable_dpcd_backlight
    No I can boot to graphical login screen with kernel 5.4.13
    The message remains.

  10. #10

    Default Re: no graphic login after today upgrade

    Quote Originally Posted by lorenzius View Post
    Had the same issue on my Tuxedo Infinity Book Pro with Intel graphics
    Get SDDM graphic login with Kernel 5.3 but not with 5.4.xx.
    I get following message during boot:
    i915 invalid for parameter enable_dpcd_backlight
    I changed the line in /etc/modprobe.d/i915.conf to #options i915 enable_dpcd_backlight
    No I can boot to graphical login screen with kernel 5.4.13
    The message remains.
    manythanks I will try also this

    ...furthermore, as you have my same laptop, does in your works the backlight keyboard?
    in mine it works but I cannot change the colors, I written to tuxedo but they are rather slow to answer, maybe you can answer to me.
    my last email to tuxedo said this:
    "maybe the kernel module is not loaded?
    Please try adding the module with:

    sudo modprobe tuxedo-keyboard

    Or as a permanent solution:

    sudo echo tuxedo_keyboard >> /etc/modules

    Does that work?"
    but it didn't worked

    if you think I can open a new thread for this :-)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •