Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Issues when accessing folders with special characters (Umlaute)

  1. #1

    Default Issues when accessing folders with special characters (Umlaute)

    Hello,

    approximately 10 days ago (around Jan 6), my LibreOffice started to show issues when I wanted to open a folder which has special characters in its name. Since the LibreOffice release did not change, I suspect that the issue is in the underlying system, e.g. Plasma. (Hence, the LibreOffice people will claim not to be repsonsible, I suppose.)

    LibreOffice seems to use a standard file dialog; when I click on a folder in the tree (like "Entwürfe"), I now get an error dialog "The specified folder does not exist or was not readable". I can, however, expand the subtree of this folder in the detail view and then access the files in there. Also, I can open a file with Umlaut characters. I just cannot double-click on the "Entwürfe" folder.

    The issue does not occur in Dolphin, neither does it occur in file dialogs of Okular (although the latter one really looks similar to the failing dialog in LibreOffice). This would actually be an argument against my hypothesis, but anyway: Who should I ask for help, or who might be interested in a bug report from me on this topic?

    Greetings,

    Michael

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,475

    Default Re: Issues when accessing folders with special characters (Umlaute)

    Try Tools>Options>General and uncheck Use LibreOffice dialogue boxes in Open/Save dialogue boxes. If that solves the problem, it is a LibreOffice problem.

  3. #3

    Default Re: Issues when accessing folders with special characters (Umlaute)

    Option was already unchecked. When I check it, the problem disappears - which means that LibreOffice has no such issues with its own File dialog.

  4. #4
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,475

    Default Re: Issues when accessing folders with special characters (Umlaute)

    So your original diagnosis was correct; I have no problems either way with Slav accents but I do not have a folder name containing an Umlaut. Perhaps the issue is confined to the Umlaut. Open a ticket in Bugzilla.

  5. #5

    Default Re: Issues when accessing folders with special characters (Umlaute)

    Not only a single umlaut but any non-ascii character. I tried to open the following folders in the file dialog:

    ~/tmp/ça/
    ~/tmp/čeština/
    ~/tmp/déjà/
    ~/tmp/það/


    but I always get the error message that this folder does not exist. As I said, only LibreOffice has this issue.

    Using strace, I found the following lines in the trace:

    openat(AT_FDCWD, "/home/michael/tmp/?a", O_RDONLY|O_NONBLOCK|O_CLOEXEC|O_DIRECTORY) = -1 ENOENT (No such file or directory)
    openat(AT_FDCWD, "/home/michael/tmp/?e?tina", O_RDONLY|O_NONBLOCK|O_CLOEXEC|O_DIRECTORY) = -1 ENOENT (No such file or directory)
    openat(AT_FDCWD, "/home/michael/tmp/d?j?", O_RDONLY|O_NONBLOCK|O_CLOEXEC|O_DIRECTORY) = -1 ENOENT (No such file or directory)
    openat(AT_FDCWD, "/home/michael/tmp/?a?", O_RDONLY|O_NONBLOCK|O_CLOEXEC|O_DIRECTORY) = -1 ENOENT (No such file or directory)

  6. #6

    Default Re: Issues when accessing folders with special characters (Umlaute)

    I just started from an earlier snapshot (Jan 6), and this is what I find in the strace:

    openat(AT_FDCWD, "/home/michael/tmp/\303\247a", O_RDONLY|O_NONBLOCK|O_CLOEXEC|O_DIRECTORY) = 32
    openat(AT_FDCWD, "/home/michael/tmp/\303\276a\303\260", O_RDONLY|O_NONBLOCK|O_CLOEXEC|O_DIRECTORY) = 32
    openat(AT_FDCWD, "/home/michael/tmp/d\303\251j\303\240", O_RDONLY|O_NONBLOCK|O_CLOEXEC|O_DIRECTORY) = 32
    openat(AT_FDCWD, "/home/michael/tmp/\304\215e\305\241tina", O_RDONLY|O_NONBLOCK|O_CLOEXEC|O_DIRECTORY) = 32

    What may have changed in Plasma so that the unicode characters are not accepted anymore? Since other programs do not have a problem, I suppose LibreOffice does something wrong what was good before. As said above, LibreOffice did not change in the meantime, as far as I can see (same release number; now it has advanced to 6.4, but the problem was already with the previous release).

  7. #7
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,475

    Default Re: Issues when accessing folders with special characters (Umlaute)

    I have LibreOffice 6.3.3.2.0+ installed. Which version have you installed?

  8. #8
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,231

    Default Re: Issues when accessing folders with special characters (Umlaute)

    Quote Originally Posted by john_hudson View Post
    I have LibreOffice 6.3.3.2.0+ installed. Which version have you installed?
    This is a Tumbleweed problem. I have replicated it with libreoffice-6.4.0.2-1.2.x86_64 and the previous version (6.4.0.2).
    It does not apply to Leap-15.1 or Leap-15.2 alpha.
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

  9. #9

    Default Re: Issues when accessing folders with special characters (Umlaute)

    I have just filed a bug report on that topic in the openSUSE bugzilla.

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,788

    Default Re: Issues when accessing folders with special characters (Umlaute)

    Quote Originally Posted by mizapf View Post
    I have just filed a bug report on that topic in the openSUSE bugzilla.
    Please always post a link to the report here, so that others may follow it or add (maybe important) information to it.
    Henk van Velden

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •