Results 1 to 5 of 5

Thread: Software Update and the google-chrome-beta repo

  1. #1

    Default Software Update and the google-chrome-beta repo

    Signature verification for Repository google-chrome-beta failed:

    Software Update at the start of a session was working fine until yesterday when the google-chrome-beta repo started giving me a Signature Verification error.

    Disabling and then enabling the repo in yast gave me the gpg error that one always gets when installing google chrome or the beta, but after answering the "Do you want to use it anyway" question with a positive, allows the refresh of repos to proceed fine.

    Zypper dup does not give me the error with the repo enabled, and, my 2 Tumbleweed installs aren't showing the error either. It's only happening when using Software Update on Leap 15.1 from within KDE.

    Is anyone else seeing this error? Any advice?

  2. #2
    Join Date
    Jun 2008
    San Diego, Ca, USA
    Blog Entries

    Default Re: Software Update and the google-chrome-beta repo

    Are you using the repo through this web page's link? If so, then that's Google's repository, not openSUSE

    You can also change or remove and re-add the repository, re-accepting whatever keys are effective,
    Although the Google instructions on the following page describes the usual method for all Linux distros, the second link from my Wiki describes how to "auto accept GPG keys" without all the work

    Beginner Wiki Quickstart -
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: Software Update and the google-chrome-beta repo

    Thanks tsu2

    Yes, I was using the repo from that web pages link. In fact I've been using that repo for years. Darned if I know why it just started acting up.

    Thank you for the link, especially the one to your wiki. I'm going to give that a try and see if It can fix the problem.

    Thanks again, I'll post back to post the results.


  4. #4

    Default Re: Software Update and the google-chrome-beta repo


    It took deleting the old key, and using your "zypper --gpg-auto-import-keys ref" to solve the problem.

    The key I freshly imported looks exactly like the one I deleted, so, it's still confusing, but, now it works.

    Thanks again


  5. #5
    Join Date
    Mar 2019

    Default Re: TW 20200121 Chrome Dev Jan 21st RPM Package

    Also present in TW, just a validation window in Yast asking to enroll the key.

    This new pop-up for the missing Key is also present for Chrome Dev after installation in Yast. Answering yes, after re-opening Yast seems to work with the latest .RPM package. Never seen it before in TW, but present for a long time (Intermittent) for the .DEB package in Discover.

    'sudo apt-get --fix-broken install' generates the key.

    Chrome Dev: 81.0.4033.2_x64
    Ryzen 2700U FHD Lenovo ThinkPad E585

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts