Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Devede won't start

  1. #11
    Join Date
    Sep 2012
    Posts
    6,795

    Default Re: Devede won't start

    Quote Originally Posted by caf4926 View Post
    Code:
        gi.require_version('Gtk', '3.0')
    ValueError: Namespace Gtk not available
    You need Gtk typelib.
    Code:
    zypper in -C 'typelib(Gtk)=3.0'
    P.S. you do realize that in 1.5 year most everything has changed on Tumbleweed , do not you?

  2. #12
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Devede won't start

    Now it does

    Code:
    Traceback (most recent call last):
      File "/usr/bin/devede_ng.py", line 48, in <module>
        mwindow = devedeng.project.devede_project()
      File "/usr/lib/python3.8/site-packages/devedeng/project.py", line 83, in __init__
        builder.connect_signals(self)
    ValueError: Pointer arguments are restricted to integers, capsules, and None. See: https://bugzilla.gnome.org/sh
    ow_bug.cgi?id=683599
    
    
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #13
    Join Date
    Sep 2021
    Posts
    2

    Default Re: Devede won't start

    I have downloaded the Devede file 3.23.0 and DevedeNG file 4.16.0 from the Packman repository. I attempted to install both on Leap 15.2, and recieved the same errors as earlier reported.

    I then downloaded the Devede file 3.16.9 from the Packman repository which was listed for openSUSE 11.2. I was able to successfully install and run this version. As this is an interpreted Python code, the creation of the rpm does not compile or change the original code lines. It appears to utilize Python 2 and GTK+ 2 - both of which are supported on Leap 15.2 and Tumbleweed.

    I found only two problems with the installation. The first problem is the video preview window did not have any sound. That was traced back to the KDE Plasma widget controlling sound volume. It was set to mute. Fixing this allowed sound and it maintained the setting though multiple startup/shutdown sequences. This setting is found on the system tray icon "audio volume" and applications tab as MPlayer (the helper application actually playing the video). The second problem is MEncoder is being used to encode the videos and create the menu video. It is calling ffmpeg to do the actual conversion. The version of ffmpeg shipped from openSUSE has been neutered to remove some codecs. The necessary ac3 codec was one of those removed. You must install a full version of ffmpeg to obtain this codec - available in the Packman repository. There are multiple versions and dependencies, so this is sometimes tricky. The versions and dependent programs are constantly changing, but I had success with version 4.2.1 release 2.9.4. You must use an ffmpeg version 4 program; recently MPlayer/MEncoder has been updated to use version 4 from version 3.

    While much information has been removed from the internet on Devede version 3, the following is the best history I can develop. Version 3.16.9 was updated to the version 3.20.0-3.23.0 series. The update added a selection of new encoders to the previous single MPlayer/MEncoder choice. It also provided a capability to directly call the CD burner software Brasero or K3b. After Devede 3.23.0, the program was completely rewritten for Python 3 and GTK+ 3, and renamed DevedeNG. Its present version is 4.16.0.

    While I can continue to look at the later version Devede issues, the 3.16.9 version provides all the core functionality that the later versions have.

  4. #14
    Join Date
    Sep 2021
    Posts
    2

    Default Re: Devede won't start

    I have downloaded the DevedeNG file 4.16.0 from the Packman repository. I attempted to install it on Leap 15.2, and recieved the same errors as earlier reported. After some effort, I have been able to get the program running on Leap 15.2. There were two issues that I found.

    The first issue is that four rpm packages need to be installed:

    python3-gobject
    python3-cairo
    python3-gobject-Gdk
    python3-gobject-cairo

    Some of these are installed by DevedeNG setup, and others call each other when installed. Just check that all four are installed to operate DevedeNG.

    The second issue is that Packman has deleted the documents from the install package. In DevedeNG these documents have been added to the program as the help files. You must retrieve the doc directory from the original source file and place the files into /usr/share/devedeng/html directory if you wish to use the help files.

    While this was done on Leap 15.2, the same procedures should work for Tumbleweed.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •