Results 1 to 10 of 10

Thread: no Internet after openSuSE Tumbleweed update today

  1. #1

    Default no Internet after openSuSE Tumbleweed update today

    Today - Saturday, January 4th - I performed update to openSuSE Tumbleweed via "zypper dup" for about the fiftieth time during 2019.

    Update indicate requiring reboot since systemd and udev were to be updated.

    After update, the bootup and login were OK and everything worked, except no Internet. Network connection listed as disconnected, and after clicking connect, it returned to disconnected after about 10 seconds.

    I booted computer with 3 other Linux Live DVD distros, and Internet works perfectly.

    Help appreciated, including info on process for returning computer to state before this last update.

    Wendell Anderson
    w.edmund.anderson@gmail.com
    wanderson@kimalcorp.org

  2. #2

    Default Re: no Internet after openSuSE Tumbleweed update today

    Is this WiFi + NetworkManager?

    If so, I've experienced something similar on my laptop. I had to remove the affected connection (deleted config file in /etc/NetworkManager/... restart network services) and configured it again.

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,966

    Default Re: no Internet after openSuSE Tumbleweed update today

    You say "no internet", but how did you find out?
    Remember that while we love descriptiosn, we are much mor eager for computer facts. So your conclusion "no internet" might be correct, but we want to know more.

    Can we assume correct that your network functions and that you can reach other systems on the LAN?

    I can also offer you a step by step program to find out what works and what not:
    =============


    You check from bottom to top:

    Is the NIC up with an IP address?
    Code:
    ip addr
    Can you connect to another system on your LAN?
    Code:
    ping -c1 <IP-address of your router>
    (I hope you know that address)
    Do you have a default route to the Internet?
    Code:
    ip route
    Can you connect to a system on the internet?
    Code:
    ping -c1 130.57.66.6
    Can you resolve host/domain names?
    Code:
    ping -c1 forums.opensuse.org
    Take care. As soon a one step fails, that must be resolved first. It is useless to go to the next step before it is resolved.

    So start with 1. and do not hesitate to post the output here to get help on the interpretation.
    Henk van Velden

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,452
    Blog Entries
    14

    Default Re: no Internet after openSuSE Tumbleweed update today

    This has already been reported ( it's a Networkmanager upstream bug ) on the factory ML. And fixed by Fabian Vogdt, AFAIK the fix would be in one of the next snapshots. For now, either rollback ( btrfs ) or use tumbleweed-cli to go back to TWs previous snapshot.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: no Internet after openSuSE Tumbleweed update today

    I appreciate the feedback.

    1/ I am usubf a desktop Dell with Wired internet connection.

    2/ I can connect to internet via bootup in recovery mode and set "auto negotiation" which allowed internet connection.
    All sets reconnendd for a/ pinging my router, forums.suse.org, internet ip address, getting browser up and running work in recovery mode.

    I will attempt to perform new "zypper dup" update as notified, and hope bug fix in networkmanager is included as noted in a response comment.

    Thanks all for help.

    Wendell Anderson

  6. #6
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,257

    Default Re: no Internet after openSuSE Tumbleweed update today

    Quote Originally Posted by weeanderson View Post
    1/ I am usubf a desktop Dell with Wired internet connection.
    You did not reply to the request for basic information.
    Are you using Network Manager?
    If so, you can avoid it by using
    YaST > System > Network Settings
    and configuring your wired connection using the wicked service. This is generally the preferred option for a desktop (non-mobile) system.
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,966

    Default Re: no Internet after openSuSE Tumbleweed update today

    Quote Originally Posted by eng-int View Post
    You did not reply to the request for basic information.
    Are you using Network Manager?
    If so, you can avoid it by using
    YaST > System > Network Settings
    and configuring your wired connection using the wicked service. This is generally the preferred option for a desktop (non-mobile) system.
    When you reread the posts above, you probably will find out that
    • the OP was able to use his wired connection by configuring it with YaST using Wicked (with DHCP);
    • the OP then explained that, while it is a desktop always connected to the same router, he prefers to use Wifi, because his dislikes a cable in his personal situation;
    • he now tries to configure Wifi, again using YaST and Wicked.
    • While the word NetworkManager was used in the thread, the OP never tried to use it, nor does he intend to do so;
    • HIs trial to configure using Wicked (using DHCP) seems to go along the correct path, but until now did not succeed.


    I hope now the path the OP tries to walk is clear. As usual, all suggestion helping him with this are welcome.

    My suggestion was that he still had his wired connection running while trying his Wifi. Most probably Wicked will not use the Wifi in such a situation. Thus my suggestion to pull the cable. Until now I am waiting for his answer on that.
    Henk van Velden

  8. #8
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,257

    Default Re: no Internet after openSuSE Tumbleweed update today

    Quote Originally Posted by hcvv View Post
    When you reread the posts above, you probably will find out ...
    Hi Henk,
    Did you post this in the wrong thread?
    I cannot find any reference to WiFi or YaST in either of the OP (weeanderson)'s posts.
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,175
    Blog Entries
    15

    Default Re: no Internet after openSuSE Tumbleweed update today

    Hi
    And since the OP's post there have been 4 Tumbleweed snapshots released.... @OP, have you updated the system to the latest release, be interesting to see if it's now working (esp after kernel and firmware updates)...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,966

    Default Re: no Internet after openSuSE Tumbleweed update today

    Quote Originally Posted by eng-int View Post
    Hi Henk,
    Did you post this in the wrong thread?
    I cannot find any reference to WiFi or YaST in either of the OP (weeanderson)'s posts.
    You are correct. I am at the wrong thread. I apologize. I now remember that earlier yesterday I also mixed up these two threads. Do not know why, probably because both are about network connectivety. But that is not an excuse. I shoudl re-read (as I advised you ) before I post.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •