Results 1 to 8 of 8

Thread: No network devices found after kernel update

  1. #1

    Default No network devices found after kernel update

    Hi everyone,
    After I did an upgrade today (kernel is now 5.4.7), I lost all my network devices (ethernet and wifi). Fortunately, using the older kernel, at least wifi works, so I can post relevant information here. My wireless card is a Qualcomm Atheros card (kernel module ath10k_pci is loaded). For some reason, I cannot get info on my ethernet card anymore (seems it is not detected). With the newer kernel, only the loopback device is listed. I noticed that with the last upgrade, some things changed - apparently various firmware components which AFAIK where bundled in one single package are now split into separate packages. Maybe I'm missing packages? Here is the list of installed firmware packages after a quick zypper se -i firmware:

    Code:
    --+-----------------------------+---------------------------------------------------------------+------
    i | kernel-firmware-all         | Compatibility metapackage for kernel firmware files           | Paket
    i | kernel-firmware-amdgpu      | Kernel firmware files for AMDGPU graphics driver              | Paket
    i | kernel-firmware-ath10k      | Kernel firmware files for Atheros QCA988x WiFi drivers        | Paket
    i | kernel-firmware-atheros     | Kernel firmware files for Atheros wireless drivers            | Paket
    i | kernel-firmware-bluetooth   | Kernel firmware files for various Bluetooth drivers           | Paket
    i | kernel-firmware-bnx2        | Kernel firmware files for Broadcom network drivers            | Paket
    i | kernel-firmware-brcm        | Kernel firmware files for Broadcom wireless drivers           | Paket
    i | kernel-firmware-chelsio     | Kernel firmware files for Chelsio network drivers             | Paket
    i | kernel-firmware-dpaa2       | Kernel firmware files for NXP Management Complex bus driver   | Paket
    i | kernel-firmware-i915        | Kernel firmware files for Intel i915 graphics driver          | Paket
    i | kernel-firmware-intel       | Kernel firmware files for Intel-platform device drivers       | Paket
    i | kernel-firmware-iwlwifi     | Kernel firmware files for Intel wireless drivers              | Paket
    i | kernel-firmware-liquidio    | Kernel firmware files for Cavium LiquidIO driver              | Paket
    i | kernel-firmware-marvell     | Kernel firmware files for Marvell network drivers             | Paket
    i | kernel-firmware-media       | Kernel firmware files for various Video4Linux drivers         | Paket
    i | kernel-firmware-mediatek    | Kernel firmware files for Mediatek network drivers            | Paket
    i | kernel-firmware-mellanox    | Kernel firmware files for Mellanox Spectrum switch driver     | Paket
    i | kernel-firmware-mwifiex     | Kernel firmware files for Marvell WiFi fullmac drivers        | Paket
    i | kernel-firmware-network     | Kernel firmware files for various network drivers             | Paket
    i | kernel-firmware-nfp         | Kernel firmware files for Netronome Flow Processor driver     | Paket
    i | kernel-firmware-nvidia      | Kernel firmware files for Nvidia Tegra and graphics drivers   | Paket
    i | kernel-firmware-platform    | Kernel firmware files for various platform drivers            | Paket
    i | kernel-firmware-qlogic      | Kernel firmware files for QLogic network drivers              | Paket
    i | kernel-firmware-radeon      | Kernel firmware files for Radeon graphics driver              | Paket
    i | kernel-firmware-realtek     | Kernel firmware files for Realtek wireless drivers            | Paket
    i | kernel-firmware-serial      | Kernel firmware files for various serial drivers              | Paket
    i | kernel-firmware-sound       | Kernel firmware files for various sound drivers               | Paket
    i | kernel-firmware-ti          | Kernel firmware files for Texas Instruments wireless drivers  | Paket
    i | kernel-firmware-ueagle      | Kernel firmware files for Eagle IV USB ADSL modem driver      | Paket
    i | kernel-firmware-usb-network | Kernel firmware files for various USB WiFi / Ethernet drivers | Paket
    Or maybe I'm just missing some kernel modules? But how to find out? Any help is really appreciated here.

  2. #2

    Default Re: No network devices found after kernel update

    Okay, nevermind on the wireless card. It is working now after another reboot (some hiccup in the system I guess). But the ethernet card is still not displayed. Don't know whether this is intentional since I don't have a network cable plugged in or not. Can't test this unfortunately at the moment.

  3. #3
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,257

    Default Re: No network devices found after kernel update

    Quote Originally Posted by kyoki View Post
    But the ethernet card is still not displayed. Don't know whether this is intentional since I don't have a network cable plugged in or not.
    Where is the network card not displayed? Try:
    Code:
    > ip link
    > ip address
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

  4. #4

    Default Re: No network devices found after kernel update

    Quote Originally Posted by eng-int View Post
    Where is the network card not displayed? Try:
    Code:
    > ip link
    > ip address
    Yep, that's where it is not listed. Also not in the KDE info center. If I look at journalctl, only the loopback and wifi interfaces are listed when NetworkManager is brought up. My guess is/was, that it is brought up when I plug in a network cable. Previously, it was always listed, though. It's also not listed with the older kernel (5.3.12).

    [EDIT] For what it's worth, here is the output of ip link:

    Code:
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
        link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff
    Last edited by kyoki; 11-Jan-2020 at 05:06. Reason: Added more info

  5. #5
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,257

    Default Re: No network devices found after kernel update

    What sort of ethernet hardare do you have?
    Code:
    > sudo hwinfo --netcard
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

  6. #6

    Default Re: No network devices found after kernel update

    hwinfo only shows my wifi adapter:

    Code:
    sudo hwinfo --netcard
    [sudo] Passwort für root: 
    11: PCI 200.0: 0282 WLAN controller                             
      [Created at pci.386]
      Unique ID: qru8.u+1hk7+ZFW3
      Parent ID: hoOk.PTwCBDvuDl3
      SysFS ID: /devices/pci0000:00/0000:00:1c.2/0000:02:00.0
      SysFS BusID: 0000:02:00.0
      Hardware Class: network
      Model: "Bigfoot Networks Killer 1435 Wireless-AC"
      Vendor: pci 0x168c "Qualcomm Atheros"
      Device: pci 0x003e "QCA6174 802.11ac Wireless Network Adapter"
      SubVendor: pci 0x1a56 "Bigfoot Networks, Inc."
      SubDevice: pci 0x143a "Killer 1435 Wireless-AC"
      Revision: 0x32
      Driver: "ath10k_pci"
      Driver Modules: "ath10k_pci"
      Device File: wlp2s0
      Features: WLAN
      Memory Range: 0xdc000000-0xdc1fffff (rw,non-prefetchable)
      IRQ: 140 (193824 events)
      HW Address: xx:xx:xx:xx:xx:xx
      Permanent HW Address: xx:xx:xx:xx:xx:xx
      Link detected: yes
      WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140
      WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 5.18 5.2 5.22 5.24 5.26 5.28 5.3 5.32 5.5 5.52 5.54 5.56 5.58 5.6 5.62 5.64 5.66 5.68 5.7
      WLAN encryption modes: WEP40 WEP104 TKIP CCMP
      WLAN authentication modes: open sharedkey wpa-psk wpa-eap
      Module Alias: "pci:v0000168Cd0000003Esv00001A56sd0000143Abc02sc80i00"
      Driver Info #0:
        Driver Status: ath10k_pci is active
        Driver Activation Cmd: "modprobe ath10k_pci"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #25 (PCI bridge)
    I will check my BIOS settings, but did not change anything there...

  7. #7
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,257

    Default Re: No network devices found after kernel update

    For the purposes of elimination; try shutting down, then physically disconnecting the power supply for five to ten minutes before reconnecting and restarting. Pull the mains plug out to be sure. Sometimes that is the only way to reset the firmware (think bout features like wake-on-lan).
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

  8. #8

    Default Re: No network devices found after kernel update

    Quote Originally Posted by kyoki View Post
    But the ethernet card is still not displayed. Don't know whether this is intentional since I don't have a network cable plugged in or not. Can't test this unfortunately at the moment.
    Well, duh. Today I realized that my ethernet card does not show up, since I don't have one built into my laptop *facepalm*. I have an adapter that functions as a USB ethernet card (hwinfo --netcard properly displays this when the adapter is plugged in). Thus everything is fine. @eng-int: I'm sorry for bothering you. Thanks for the help, though!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •