Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Doesn't login in no one desktop manager

  1. #1

    Default Doesn't login in no one desktop manager

    Good afternoon. I've installed nvidia g05 video driver (I had g04 installed before) from the community repos, but now when i try to login in any desktop session, the screen become black and go back to the login screen, not to the desktop. I tried 2 things:

    - press ctrl+alt+f1, and re-installed g04 drivers. Nothing changed.
    - tried to restore from a snapshot, but it doesn't arrive to the login screen, because i see only a violet screen.

    Just another thing: if i'm on login screen, even if i don't do anything, the screen become black for 2 seconds and go back to the login screen.

    Any ideas?

  2. #2

    Default Re: Doesn't login in no one desktop manager

    - I removed all drivers
    - Installed x11-video-nvidiaG05 package (not nvidia-gfxG05-kmp-default, but i think is the same because zypper automatically install both)

    Now it works.

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,550
    Blog Entries
    15

    Default Re: Doesn't login in no one desktop manager

    Quote Originally Posted by Quiquoqua48 View Post
    Good afternoon. I've installed nvidia g05 video driver (I had g04 installed before) from the community repos, but now when i try to login in any desktop session, the screen become black and go back to the login screen, not to the desktop. I tried 2 things:

    - press ctrl+alt+f1, and re-installed g04 drivers. Nothing changed.
    - tried to restore from a snapshot, but it doesn't arrive to the login screen, because i see only a violet screen.

    Just another thing: if i'm on login screen, even if i don't do anything, the screen become black for 2 seconds and go back to the login screen.

    Any ideas?
    Hi
    Is your card supported with the 05 driver?

    Code:
    /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    When you re-installed the 04 driver, perhaps running mkinitrd command would ensure the older driver is used.

    The other one to check is do the nvidia kmp's match your running kernel?

    Code:
    uname -a
    zypper se -si nvidia
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4

    Default Re: Doesn't login in no one desktop manager

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Is your card supported with the 05 driver?

    Code:
    /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    When you re-installed the 04 driver, perhaps running mkinitrd command would ensure the older driver is used.

    The other one to check is do the nvidia kmp's match your running kernel?

    Code:
    uname -a
    zypper se -si nvidia
    Thanks for your answer! I posted in the same seconds, i don't understand why, but now it works... Do you know why?

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,550
    Blog Entries
    15

    Default Re: Doesn't login in no one desktop manager

    Quote Originally Posted by Quiquoqua48 View Post
    Thanks for your answer! I posted in the same seconds, i don't understand why, but now it works... Do you know why?
    Hi
    Run the first command above to see the card information, likely it's now using the nouveau driver or may have a mixture, post output from second command...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: Doesn't login in no one desktop manager

    Hi, the outputs are:

    Code:
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] [10de:1380] (rev a2)	Subsystem: ZOTAC International (MCO) Ltd. Device [19da:288a]
    	Kernel driver in use: nvidia
    	Kernel modules: nouveau, nvidia_drm, nvidia
    Code:
    Linux linux-h29h 4.12.14-lp151.28.36-default #1 SMP Fri Dec 6 13:50:27 UTC 2019 (8f4a495) x86_64 x86_64 x86_64 GNU/Linux
    Code:
    i  | nvidia-computeG05         | pacchetto | 440.44-lp151.22.1                   | x86_64 | nVidia Graphics Driversi  | nvidia-gfxG05-kmp-default | pacchetto | 440.44_k4.12.14_lp151.27-lp151.22.1 | x86_64 | nVidia Graphics Drivers
    i  | nvidia-glG05              | pacchetto | 440.44-lp151.22.1                   | x86_64 | nVidia Graphics Drivers
    i+ | x11-video-nvidiaG05       | pacchetto | 440.44-lp151.22.1                   | x86_64 | nVidia Graphics Drivers
    ...so that's a mix, right? And the performances are worse than only nvidia drivers?

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,550
    Blog Entries
    15

    Default Re: Doesn't login in no one desktop manager

    Quote Originally Posted by Quiquoqua48 View Post
    Hi, the outputs are:

    Code:
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] [10de:1380] (rev a2)    Subsystem: ZOTAC International (MCO) Ltd. Device [19da:288a]
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia_drm, nvidia
    Code:
    Linux linux-h29h 4.12.14-lp151.28.36-default #1 SMP Fri Dec 6 13:50:27 UTC 2019 (8f4a495) x86_64 x86_64 x86_64 GNU/Linux
    Code:
    i  | nvidia-computeG05         | pacchetto | 440.44-lp151.22.1                   | x86_64 | nVidia Graphics Driversi  | nvidia-gfxG05-kmp-default | pacchetto | 440.44_k4.12.14_lp151.27-lp151.22.1 | x86_64 | nVidia Graphics Drivers
    i  | nvidia-glG05              | pacchetto | 440.44-lp151.22.1                   | x86_64 | nVidia Graphics Drivers
    i+ | x11-video-nvidiaG05       | pacchetto | 440.44-lp151.22.1                   | x86_64 | nVidia Graphics Drivers
    ...so that's a mix, right? And the performances are worse than only nvidia drivers?
    Hi
    The nvidia packages (4.12.14_lp151.27-lp151.22.1) do not match the running kernel (4.12.14-lp151.28.36).

    If you run the following command, is the module in weak-updates?

    Code:
    /sbin/modinfo nvidia
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8

    Default Re: Doesn't login in no one desktop manager

    mmm i don't know, this is the output:

    Code:
    filename:       /lib/modules/4.12.14-lp151.28.36-default/updates/nvidia.koalias:          char-major-195-*
    version:        440.44
    supported:      external
    license:        NVIDIA
    suserelease:    openSUSE Leap 15.1
    srcversion:     76C1A18886D409B7BFE6518
    alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
    alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
    depends:        ipmi_msghandler
    retpoline:      Y
    vermagic:       4.12.14-lp151.28.36-default SMP mod_unload modversions 
    parm:           NvSwitchRegDwords:NvSwitch regkey (charp)
    parm:           NVreg_Mobile:int
    parm:           NVreg_ResmanDebugLevel:int
    parm:           NVreg_RmLogonRC:int
    parm:           NVreg_ModifyDeviceFiles:int
    parm:           NVreg_DeviceFileUID:int
    parm:           NVreg_DeviceFileGID:int
    parm:           NVreg_DeviceFileMode:int
    parm:           NVreg_InitializeSystemMemoryAllocations:int
    parm:           NVreg_UsePageAttributeTable:int
    parm:           NVreg_MapRegistersEarly:int
    parm:           NVreg_RegisterForACPIEvents:int
    parm:           NVreg_EnablePCIeGen3:int
    parm:           NVreg_EnableMSI:int
    parm:           NVreg_TCEBypassMode:int
    parm:           NVreg_EnableStreamMemOPs:int
    parm:           NVreg_EnableBacklightHandler:int
    parm:           NVreg_RestrictProfilingToAdminUsers:int
    parm:           NVreg_PreserveVideoMemoryAllocations:int
    parm:           NVreg_DynamicPowerManagement:int
    parm:           NVreg_EnableUserNUMAManagement:int
    parm:           NVreg_MemoryPoolSize:int
    parm:           NVreg_KMallocHeapMaxSize:int
    parm:           NVreg_VMallocHeapMaxSize:int
    parm:           NVreg_IgnoreMMIOCheck:int
    parm:           NVreg_NvLinkDisable:int
    parm:           NVreg_RegisterPCIDriver:int
    parm:           NVreg_RegistryDwords:charp
    parm:           NVreg_RegistryDwordsPerDevice:charp
    parm:           NVreg_RmMsg:charp
    parm:           NVreg_GpuBlacklist:charp
    parm:           NVreg_TemporaryFilePath:charp
    parm:           NVreg_AssignGpus:charp

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,550
    Blog Entries
    15

    Default Re: Doesn't login in no one desktop manager

    Hi
    Looks like it rebuilt (dracut) on your next reboot. So your saying performance is down?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10

    Default Re: Doesn't login in no one desktop manager

    Hi! No no, i was just asking you if the performance could be lower with mixed drivers or not... For what i'm doing, i don't observe any big problem (just a problem for a videogame with wine but i'm quiet sure that it doesn't depend from that).

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •