Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Videos on cbs.com won't play in Leap regardless of.....

  1. #11
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,963

    Default Re: Videos on cbs.com won't play in Leap regardless of.....

    Could it be the problem is Linux in the UA string? Looks like it would play in SeaMonkey 2.49.5 if CBS was providing its own ads instead of getting them from some ad spammer. I used this one "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0" to reach this point:
    https://susepaste.org/view/raw/4334587
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  2. #12
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,161
    Blog Entries
    3

    Default Re: Videos on cbs.com won't play in Leap regardless of.....

    Quote Originally Posted by mrmazda View Post
    ... to reach this point:
    I did not block scripts or ads. The advertisement played. But it would not play the video after the ad.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #13
    Join Date
    Nov 2010
    Location
    Texas, USA
    Posts
    97

    Default Re: Videos on cbs.com won't play in Leap regardless of.....

    The CBS Help page lists Windows 7, Windows 10, and Mac OS X version 10.6 or higher
    as the only supported systems.

    On Android phones the CBS shows will not play in Chrome.
    When you try to launch a CBS show in Chrome it tells you to download
    the standalone CBS App to play the shows.

    I have a CBS All Access account. It does not matter on Linux.
    Logged in to CBS or not, the CBS show videos will not play.

    I use Chrome version 79.0.3945.117 on Linux and Windows 10.

    All CBS functions work fine on Windows 10, but not on Linux
    (openSUSE 15.1)

    I have NO problems watching shows in Chrome for Linux on ABC,
    NBC, CW, SyFy web sites. This appears to be CBS specifically
    blocking Linux.

    Regards,

  4. #14
    Join Date
    Nov 2010
    Location
    Texas, USA
    Posts
    97

    Default Re: Videos on cbs.com won't play in Leap regardless of.....

    Hmm... FYI.

    I have an Amazon Prime account.
    If I start Chrome on Linux and logon to my Prime account then
    I can watch all the CBS shows thru the Prime web site.
    A CBS All Access account IS still required to watch thru Prime.

    If I go directly to CBS.COM in Chrome and login to my CBS account,
    the CBS shows will NOT play.

    If I got directly to Amazon Prime Video in Chrome, ALL of the CBS shows
    are listed on Prime and WILL play.

    In conclusion, yes it seems that CBS.COM is directly blocking Linux playback.

    Regards

  5. #15
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    617

    Default Re: Videos on cbs.com won't play in Leap regardless of.....

    Verified via a phone call to there ‘help and support’ line. I was told Linux was taken out of there ‘approved’ platforms about 8 months ago.
    I was able to watch the programs at cbs.com in 2018 & early 2019, then it stopped allowing them in Linux.

    I despise these places that want to handcuff users to MS or Apple!
    Time to find other entertainment I guess.

    BTW, regardless of their so called platform support, I can watch them in WinXP.
    HP Compaq desktop Leap15.1 Win10, Win7
    Toshiba laptops Leap15.1 & Win10, HP AiO Win10.
    I can now print with openSuSe Leap! Can Scan now, could be better!!
    I can backup my iPod and iPad with Windows, can't with Linux.(Will get there someday!)

  6. #16
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,829
    Blog Entries
    2

    Default Re: Videos on cbs.com won't play in Leap regardless of.....

    I assume from the postings in this thread that it's an issue but nothing to get too excited about since it should be easily addressable...
    Just install a UA(User Agent) plugin or extension in the web browser you're using, set it to a MSWindows or MacOS string and then everything should work fine...
    Your browser will now look like it's from that other OS you've configured to the Server you're connecting to...
    This is also a common "must do" when building Websites and you want to verify Users on "those other" systems can see your website properly.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #17
    Join Date
    Nov 2010
    Location
    Texas, USA
    Posts
    97

    Default Re: Videos on cbs.com won't play in Leap regardless of.....

    I tried a couple of User Agent Switcher extensions for Chrome.
    They didn't help.

    Other folks may have success. If so, please post the name of the User Agent
    extension that succeeded here.

    Regards

  8. #18
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,963

    Default Re: Videos on cbs.com won't play in Leap regardless of.....

    An extension was not needed in SeaMonkey. Whether in current Firefox maybe this has changed. In about:config I did:
    added name general.useragent.override.cbs.com
    added Windows UA string Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/68.0
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •