Results 1 to 5 of 5

Thread: Slow Internet on RTL8188EE Wireless Network Adapter

Hybrid View

  1. #1

    Default Slow Internet on RTL8188EE Wireless Network Adapter

    Good day. Newbie here trying to figure out the slow down on my TP Link TL-WN781ND pci-ewireless adapter using latest Tumbleweed. Tried some commands in the terminal via web with the following results:

    lspci -k
    29:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter (rev 01)
    Subsystem: Realtek Semiconductor Co., Ltd. Device 8197
    Kernel driver in use: rtl8188ee
    Kernel modules: rtl8188ee
    dmesg | grep firmware
    192:~ # dmesg | grep firmware
    [ 2.754007] [drm] Found VCN firmware Version ENC: 1.7 DEC: 4 VEP: 0 Revision: 13
    [ 2.754009] [drm] PSP loading VCN firmware
    [ 5.810161] rtl8188ee: Using firmware rtlwifi/rtl8188efw.bin
    iwconfig wlp41s0
    wlp41s0 IEEE 802.11 ESSID:"SweetPotato"
    Mode:Managed Frequency:2.462 GHz Access Point: ****************
    Bit Rate=135 Mb/s Tx-Power=20 dBm
    Retry short limit:7 RTS thr=2347 B Fragment thr 0ff
    Encryption key 0ff
    Power Management 0ff
    Link Quality=48/70 Signal level=-62 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:5142 Missed beacon:0
    sudo hwinfo --wlan
    [sudo] password for root:
    35: PCI 2900.0: 0282 WLAN controller
    [Created at pci.386]
    Unique ID: ***********************
    Parent ID: ***********************
    SysFS ID: /devices/pci0000:00/0000:00:01.2/0000:20:00.0/0000:21:07.0/0000:29:00.0
    SysFS BusID: 0000:29:00.0
    Hardware Class: network
    Model: "Realtek RTL8188EE Wireless Network Adapter"
    Vendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
    Device: pci 0x8179 "RTL8188EE Wireless Network Adapter"
    SubVendor: pci 0x10ec "Realtek Semiconductor Co., Ltd."
    SubDevice: pci 0x8197
    Revision: 0x01
    Driver: "rtl8188ee"
    Driver Modules: "rtl8188ee"
    Device File: wlp41s0
    Features: WLAN
    I/O Ports: 0xc000-0xc0ff (rw)
    Memory Range: ************************* (rw,non-prefetchable)
    IRQ: 142 (no events)
    HW Address: ******************
    Permanent HW Address: *******************
    Link detected: yes
    WLAN channels: 1 2 3 4 5 6 7 8 9 10 11
    WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462
    WLAN encryption modes: WEP40 WEP104 TKIP CCMP
    WLAN authentication modes: open sharedkey wpa-psk wpa-eap
    Module Alias: "*********************************************************"
    Driver Info #0:
    Driver Status: rtl8188ee is active
    Driver Activation Cmd: "modprobe rtl8188ee"
    Config Status: cfg=no, avail=yes, need=no, active=unknown
    Attached to: #40 (PCI bridge)
    via Ookla's Speedtest

    **********:~> speedtest-cli
    Retrieving speedtest.net configuration...
    Testing from *********** (***.***.***.**)...
    Retrieving speedtest.net server list...
    Selecting best server based on ping...
    Hosted by DOST**** (*********) [57.40 km]: 8.241 ms
    Testing download speed..................................
    Download: 2.67 Mbit/s
    Testing upload speed....................................
    Upload: 2.01 Mbit/s
    **********:~>
    See, I manage a higher bandwidth using Windows 10 (in Dual Boot Config | Legacy Setup in Bios), atleast 20Mbps connection (out of 35Mbps in 2.4GHz band) for the same wireless network adapter on the same PC. Distance from AP to PC is about 12 Meters w/ few partitions on the same floor.

    Is this a problem within the driver? Link Quality & Signal Level are way too low [Link Quality=48/70 Signal level=-62 dBm]. I'm using a version 3 for Windows driver and here in Tumbleweed uses Version 1 [29:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188EE Wireless Network Adapter (rev 01)]. My ZTE Router | AP has no problems with reliable ISP to date, btw.

    I hope someone could lead me to a right troubleshooting tips. TIA

  2. #2

    Default Re: Slow Internet on RTL8188EE Wireless Network Adapter

    Update:
    *Re-installed Tumbleweed, latest snapshot = same low results (KDE; default using network manager; can't seem to configure in wicked)
    *Installed latest Leap 15.1 with updates = same low results (KDE; default using network manager; can't seem to configure in wicked)
    *Installed another distro, Zorin OS 15 Core x64 | Educ Lite x64 with updates = same low results (using gnome | xfce network manager)

    *On Windows 10 x64 = no problems

    PC Specs:

    R5 3600x
    Gigabyte x570
    Rx 5700


  3. #3

    Default Re: Slow Internet on RTL8188EE Wireless Network Adapter

    Hi, same here, maybe some problem with network manager, see this thread: https://forums.opensuse.org/showthre...-on-tumbleweed

    To make the change, start yast, search for network settings, in global options switch for wicked service and reboot. This fixed the issue for me. Later you can try what nrickert suggested: nuke network manager settings and switch back, which I have not tested. I will rather get used to wicked to avoid unnecessary problems

  4. #4

    Default Re: Slow Internet on RTL8188EE Wireless Network Adapter

    Hi, sorry, I have not noticed you have wireless card, I have seen RTL when I had the same problem with my wired RTL... Sadly I can confirm, that some wireless cards have really poor performance under linux when compared to windows, I had mainly problems with mediatek, broadcom and ralink I don't know if it is safe to generalize, but all atheros cards I have tried have been fine.

  5. #5

    Default Re: Slow Internet on RTL8188EE Wireless Network Adapter

    ^thanks for the info, appreciate it.

    Well, tried another distro, Manajro KDE (Live), same results, tsk.. Time to hunt for an Atheros-chipped wlan pcie card or go for 20 Meters utp cable. I hope this issue with the chipset be resolved soon.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •