Page 14 of 16 FirstFirst ... 41213141516 LastLast
Results 131 to 140 of 157

Thread: 2.81 on opensuse - crashes when opening

  1. #131
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,872
    Blog Entries
    15

    Default Re: 2.81 on opensuse - crashes when opening

    Quote Originally Posted by idee View Post
    Trying to make more space, would like to resize (shrink) the Windows C: and add that to the /root partition.
    I can't find anything to shrink the C:. I have tried the YaST Partition Tool, Partition Magic & Gparted.
    As a not the windows drive is just before the root.
    So if I shrink it, I was hoping to add that portion to the beginning of the root.
    Is that possible?
    Hi
    Use the windows disk management tool for that (C:).... then boot from a rescue USB device and expand the space with say gparted.
    Last edited by malcolmlewis; 18-Jan-2020 at 16:21.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  2. #132

    Default Re: 2.81 on opensuse - crashes when opening

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Use the windows disk management tool for that (C.... then boot from a rescue USB device and expand the space with say gparted.
    That is what I have been doing. It doesn't let me shrink the partition. I will keep working on it. I have both gparted and partitian magic on disk.
    openSUSE Tumbleweed 64-bit / Cinnamon

  3. #133
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,804

    Default Re: 2.81 on opensuse - crashes when opening

    There are limits how much Windows allows its c drive to shrink has to do with the size and position of it's swap file.

    Also you can only add space to a partition to the end of it not to the beginning. So you have to move the partition to the end of the previous one and add space to the end.

  4. #134

    Default Re: 2.81 on opensuse - crashes when opening

    Got it finally. Took a bit of digging. Found that the problem with the Vista and above htfs is that they place some system files at the end of the partition. There are very few defrag apps that will move it. The only one that I found that could clean and move those files was PerfectDisk from Raxco. It is a windows app. Then within windows the partition tool was finally able to shrink the file.

    Next step is to install cuda.
    openSUSE Tumbleweed 64-bit / Cinnamon

  5. #135

    Default Re: 2.81 on opensuse - crashes when opening

    Malcom,
    After everything was back and running I ran zypper dup. There was a kernel update. I have been digging back through this post to pull out your notes to manually install the nvidia drivers.
    The nvidia .run file installed, ran mkinitrd, rebooted, started the graphics and stalled. Sorry for the ask, but need help still

    boot script ends at:

    Code:
    Update system wide CA certificates
    Locale Service
    openSUSE Tumbleweed 64-bit / Cinnamon

  6. #136
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,872
    Blog Entries
    15

    Default Re: 2.81 on opensuse - crashes when opening

    Quote Originally Posted by idee View Post
    Malcom,
    After everything was back and running I ran zypper dup. There was a kernel update. I have been digging back through this post to pull out your notes to manually install the nvidia drivers.
    The nvidia .run file installed, ran mkinitrd, rebooted, started the graphics and stalled. Sorry for the ask, but need help still

    boot script ends at:

    Code:
    Update system wide CA certificates
    Locale Service
    Hi
    All strange, I see this thread here (But for Leap) https://forums.opensuse.org/showthre...locale+service

    I don't see anything locale related here with errors, what is the status?

    Code:
    systemctl status systemd-localed.service
    So you dropped to runlevel 3, installed the nvidia driver (should be no need to rebuild initrd) then boot to graphical. Can you check initrd to see it blacklisted nouveau;

    Code:
    lsinitrd |grep nvidia
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #137

    Default Re: 2.81 on opensuse - crashes when opening

    thanks. I will check tonight.
    openSUSE Tumbleweed 64-bit / Cinnamon

  8. #138

    Default Re: 2.81 on opensuse - crashes when opening

    At lunch today I started putting together a cheat sheet for a manual installation of the nvidia and cuda drivers to use when there are kernel updates like there was this past weekend. Do you mind reviewing it and making any changes or corrections? I pulled these steps from this post and your help from the last couple of weeks. It is a bit rough, but wanted your input.

    thanks,

    Code:
      Check video card:
      zypper se nvidia
      /sbin/lspci -nnk |egrep -A3 "VGA|Display|3D"
       
      Check video drivers:
      zypper se nvidia
       
      Create folder for nvidia & cuda:
      mkdir -p /home/username/nvidia_work
      cd /home/username/nvidia_work
       
      Download nvidia & cuda .run files (cuda is 2.5gb):
      wget https://download.nvidia.com/XFree86/Linux-x86_64/440.44/NVIDIA-Linux-x86_64-440.44.run
      wget http://developer.download.nvidia.com...3.01_linux.run
      Note: verify check sums with:  sha256sum file_name.run
       
      Set for configuring drivers & reboot:
      chmod 0755 NVIDIA-Linux-x86_64-440.44.run cuda_10.2.89_440.33.01_linux.run
      su -
      zypper in make gcc kernel-devel 
      systemctl set-default multi-user
      exit
      reboot -r now
       
      Reboot into multi-user target, runlevel 3: 
      If needed, at Grub select E (edit)
      Add at the end of line with: “linux . . . silent” 3
      F10 to save and continue boot
       
      Remove all the nvidia rpms: 
      Using yast or zypper remove all nvidia rpms
      zypper rm nvidia-computeG05 nvidia-gfxG05-kmp-default nvidia-glG05 x11-video-nvidiaG05
      mkinitrd
      systemctl reboot
       
      Additional zypper tools:
      Zypper e nvidia  (search for all nvidia apps)
      Zypper rm nvidia  (remove all nvidia apps)
       
      Manually install nvidia drivers from run file & reboot:
      verify kernel-default-devel is installed
      cd /home/username/nvidia_work
      ./NVIDIA-Linux-x86_64-440.44.run -aq
      mkinitrd
      systemctl set-default graphical
      systemctl reboot
      Log into Linux graphical mode to verify installation success.
        Manually install cuda drivers from run file & reboot:
      su -
      cd /home/username/nvidia_work
      ./cuda_10.2.89_440.33.01_linux.run --override 
       
      When the options show up, deselect the driver so the older one is not installed, then you need to create a /etc/ld.so.conf.d/cuda-10-2.conf file containing the library path;
       
      cat /etc/ld.so.conf.d/cuda-10-2.conf
      /usr/local/cuda/lib64
       
      Then after saving run the command;
       
      ldconfig
       
      At this point exit root user 
      edit your ~/.profile and add;
       
      export PATH=$PATH:/usr/local/cuda/bin
       
      You should be good to go.....
    openSUSE Tumbleweed 64-bit / Cinnamon

  9. #139
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,872
    Blog Entries
    15

    Default Re: 2.81 on opensuse - crashes when opening

    Quote Originally Posted by idee View Post
    At lunch today I started putting together a cheat sheet for a manual installation of the nvidia and cuda drivers to use when there are kernel updates like there was this past weekend. Do you mind reviewing it and making any changes or corrections? I pulled these steps from this post and your help from the last couple of weeks. It is a bit rough, but wanted your input.

    thanks,

    Code:
      Check video card:
      zypper se nvidia
      /sbin/lspci -nnk |egrep -A3 "VGA|Display|3D"
       
      Check video drivers:
      zypper se nvidia
       
      Create folder for nvidia & cuda:
      mkdir -p /home/username/nvidia_work
      cd /home/username/nvidia_work
       
      Download nvidia & cuda .run files (cuda is 2.5gb):
      wget https://download.nvidia.com/XFree86/Linux-x86_64/440.44/NVIDIA-Linux-x86_64-440.44.run
      wget http://developer.download.nvidia.com...3.01_linux.run
      Note: verify check sums with:  sha256sum file_name.run
       
      Set for configuring drivers & reboot:
      chmod 0755 NVIDIA-Linux-x86_64-440.44.run cuda_10.2.89_440.33.01_linux.run
      su -
      zypper in make gcc kernel-devel 
      systemctl set-default multi-user
      exit
      reboot -r now
       
      Reboot into multi-user target, runlevel 3: 
      If needed, at Grub select E (edit)
      Add at the end of line with: “linux . . . silent” 3
      F10 to save and continue boot
       
      Remove all the nvidia rpms: 
      Using yast or zypper remove all nvidia rpms
      zypper rm nvidia-computeG05 nvidia-gfxG05-kmp-default nvidia-glG05 x11-video-nvidiaG05
      mkinitrd
      systemctl reboot
       
      Additional zypper tools:
      Zypper e nvidia  (search for all nvidia apps)
      Zypper rm nvidia  (remove all nvidia apps)
       
      Manually install nvidia drivers from run file & reboot:
      verify kernel-default-devel is installed
      cd /home/username/nvidia_work
      ./NVIDIA-Linux-x86_64-440.44.run -aq
      mkinitrd
      systemctl set-default graphical
      systemctl reboot
      Log into Linux graphical mode to verify installation success.
        Manually install cuda drivers from run file & reboot:
      su -
      cd /home/username/nvidia_work
      ./cuda_10.2.89_440.33.01_linux.run --override 
       
      When the options show up, deselect the driver so the older one is not installed, then you need to create a /etc/ld.so.conf.d/cuda-10-2.conf file containing the library path;
       
      cat /etc/ld.so.conf.d/cuda-10-2.conf
      /usr/local/cuda/lib64
       
      Then after saving run the command;
       
      ldconfig
       
      At this point exit root user 
      edit your ~/.profile and add;
       
      export PATH=$PATH:/usr/local/cuda/bin
       
      You should be good to go.....
    Hi
    That's all I do.... now the mkinitrd should only be needed once, did you check the lsinitrd output?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #140

    Default Re: 2.81 on opensuse - crashes when opening

    Not yet, still at work. Will tonight when I get home. thanks.

    mkinitrd only once. at which place? after the nvidia.run installation?
    openSUSE Tumbleweed 64-bit / Cinnamon

Page 14 of 16 FirstFirst ... 41213141516 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •