Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: REALTEC RTL8723BS WIRELESS no work

  1. #1
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    543

    Default REALTEC RTL8723BS WIRELESS no work

    I got a new noteBook "Positivo Motion Plus" model V142R4G-1, version 11144885
    The OpenSUSE 15.1 is not recognizing the wireless network card and I don't have internet and wifi access.
    With windows the wifi works well
    I have verified that the card being used is REALTEC RTL8723BS WIRELESS LAN 802.11nSDIO

    How can I solve ?

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,228

    Default AW: REALTEC RTL8723BS WIRELESS no work

    Not the name is important, the ID is important, so please post:
    Code:
    /sbin/lspci -nnk | grep -iA3 net

  3. #3
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    543

    Default Re: AW: REALTEC RTL8723BS WIRELESS no work

    Quote Originally Posted by Sauerland View Post
    Not the name is important, the ID is important, so please post:
    Code:
    /sbin/lspci -nnk | grep -iA3 net
    This code when used on this PC it returns a lot of information
    But when use on notBook does not show any lines

  4. #4
    Join Date
    Sep 2012
    Posts
    5,379

    Default Re: REALTEC RTL8723BS WIRELESS no work

    Quote Originally Posted by Sauerland View Post
    Code:
    /sbin/lspci -nnk | grep -iA3 net
    It is not PCI, it is SDIO adapter. I do not know if it is even possible to enumerate SDIO devices.

    Quote Originally Posted by sergelli View Post
    REALTEC RTL8723BS WIRELESS LAN 802.11nSDIO
    Try "modprobe r8723bs". If wireless interface does not appear, provide full output of dmesg (upload to https://susepaste.org if it is long and post link).

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,979
    Blog Entries
    1

    Default Re: REALTEC RTL8723BS WIRELESS no work

    Along with the requested dmesg output, you could also try examining the SDIO device tree with something like
    Code:
    ls -R /sys/bus/sdio
    However, I'm not certain that the wifi driver will handle such a device.
    openSUSE Leap 15.1; KDE Plasma 5

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,979
    Blog Entries
    1

    Default Re: REALTEC RTL8723BS WIRELESS no work

    FWIW, I found a Linux Mint thread dealing with the same wifi hardware which may be of interest...

    https://forums.linuxmint.com/viewtop...23722#p1183902
    openSUSE Leap 15.1; KDE Plasma 5

  7. #7
    Join Date
    Sep 2012
    Posts
    5,379

    Default Re: REALTEC RTL8723BS WIRELESS no work

    Quote Originally Posted by deano_ferrari View Post
    FWIW, I found a Linux Mint thread dealing with the same wifi hardware which may be of interest...

    https://forums.linuxmint.com/viewtop...23722#p1183902
    The linked repository is empty, driver is part of Linux staging tree (and is built by default on Leap 15.1).

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,979
    Blog Entries
    1

    Default Re: REALTEC RTL8723BS WIRELESS no work

    Quote Originally Posted by arvidjaar View Post
    The linked repository is empty, driver is part of Linux staging tree (and is built by default on Leap 15.1).
    I don't have it
    Code:
    # modinfo rtl8723bs
    modinfo: ERROR: Module rtl8723bs not found.
    # uname -r
    4.12.14-lp151.28.36-default
    In any case aside from the driver, the OP also mentioned
    Booted into Bios/ South Bridge/ LPSS & SCC CONFIGURATION/ SCC SDIO Support = changed acpi to PCI then saved and exit. After reboot, wifi working!
    openSUSE Leap 15.1; KDE Plasma 5

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,979
    Blog Entries
    1

    Default Re: REALTEC RTL8723BS WIRELESS no work

    Ah, I used the wrong name - it should have been r8723bs. All good.
    openSUSE Leap 15.1; KDE Plasma 5

  10. #10
    Join Date
    Sep 2012
    Posts
    5,379

    Default Re: REALTEC RTL8723BS WIRELESS no work

    Quote Originally Posted by deano_ferrari View Post
    I don't have it
    Code:
    # modinfo rtl8723bs
    modinfo: ERROR: Module rtl8723bs not found.
    Because it is not called rtl​8723bs.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •