Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 37

Thread: journalctl log flooded with NetworkManager warning

  1. #11
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    3,129

    Cool Re: journalctl log flooded with NetworkManager warning

    Quote Originally Posted by MakeTopSite View Post
    Code:
    Dec 21 19:36:42 lin NetworkManager[7615]: <warn>  [1576953402.6235] error requesting auth for org.freedesktop.NetworkManager.enable-disable-connectivity-check: Authorization check failed: Failed to open file “/proc/17814/status”: No such file or directory
    Whatever it was, that had the PID «Process Identification Number» “17814”, seems to have crashed or, disappeared, without crashing …
    • Take a look in ‘/var/lib/systemd/coredump/’ to see if the offending application had dumped core via systemd or, not …
    • With the user “root”, use the systemd Core Dump utility to examine what happened:

    Code:
     # coredumpctl info 17814
    (With the user “root) A list of known Core Dumps can be obtained by means of “coredumpctl list” – where “missing” is noted, the “core” file is no longer present in ‘/var/lib/systemd/coredump/’ but, systemd will still have stored most of the relevant crash information in the Journal.

  2. #12
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    3,129

    Default Re: journalctl log flooded with NetworkManager warning

    @MakeTopSite:

    BTW, the default openSUSE behaviour is, to restrict the storage time of core files located in ‘/var/lib/systemd/coredump/’ to 3 days – “usr/lib/tmpfiles.d/systemd.conf”.

  3. #13

    Default Re: journalctl log flooded with NetworkManager warning

    Quote Originally Posted by tsu2 View Post
    Recommend actually reading the log events...
    I see two types in what you posted (so don't know if you've posted everything relevant or not).
    I've posted everything relevant by selecting screen output & Ctrl-C & Ctrl-V. Output was wider than screen width so I couldn't copy everything. Missing text is the same and repeats so I copied it for first line only.

    Warnings repeats too so I've ommitted repeated warnings.

    This precedes network warnings (another time, network warnings starts at 07:08:18):
    Code:
    Jan 30 07:07:43 lin systemd[6581]: Started Accessibility services bus.
    Jan 30 07:07:43 lin dbus-daemon[6642]: [session uid=1000 pid=6642] Successfully activated service 'org.a11y.Bus'
    Jan 30 07:07:43 lin systemd[6581]: Starting Accessibility services bus...



    Quote Originally Posted by tsu2 View Post
    You should probably identify why a connectivity check is even being made... Are you invoking your Network Manager through something else? It's not enough to simply identify your network hardware, this is ordinarily a software problem. Are you running some kind of netowrking software issued by a Vendor like Cisco or a VPN manager or something else? What did you install on your machine that has anything to do with networking?
    I'm not aware of anything.


    Quote Originally Posted by tsu2 View Post
    - Is a connectivity check proper? Is it being invoked by something that shouldn't even be running on your machine?
    I'm not aware of anything wrong.

    Quote Originally Posted by tsu2 View Post
    - If you don't think that anything was installed on your machine properly, the next step is to consider it might be a misconfiguration, and possibly also by bad code.It's a common mistake in code running on *NIX to instantiate something but not set the PiD... so the sytem assigns some random PiD number that is available but the code might know what it is, and be expecting something permanently set. It's up to you how far you want to troubleshoot this or report a bug.

    The second error will depend on what kind of software is trying to do the connectivity check. Again, depending on your willingness to spend effort on this and your skill level, you may want to simply report as a bug.

    TSU
    Thank you, I'll try to find something.

  4. #14

    Default Re: journalctl log flooded with NetworkManager warning

    Quote Originally Posted by dcurtisfra View Post
    Whatever it was, that had the PID «Process Identification Number» “17814”, seems to have crashed or, disappeared, without crashing …
    • Take a look in ‘/var/lib/systemd/coredump/’ to see if the offending application had dumped core via systemd or, not …
    • With the user “root”, use the systemd Core Dump utility to examine what happened:

    Code:
     # coredumpctl info 17814
    (With the user “root) A list of known Core Dumps can be obtained by means of “coredumpctl list” – where “missing” is noted, the “core” file is no longer present in ‘/var/lib/systemd/coredump/’ but, systemd will still have stored most of the relevant crash information in the Journal.
    I'm sorry nothing was found.

  5. #15

    Default Re: journalctl log flooded with NetworkManager warning

    Quote Originally Posted by dcurtisfra View Post
    @MakeTopSite:

    BTW, the default openSUSE behaviour is, to restrict the storage time of core files located in ‘/var/lib/systemd/coredump/’ to 3 days – “usr/lib/tmpfiles.d/systemd.conf”.
    Thank you, yes I have default value.

  6. #16
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    3,129

    Question Re: journalctl log flooded with NetworkManager warning

    Quote Originally Posted by MakeTopSite View Post
    I'm sorry nothing was found.
    Then, whatever it was that disappeared – it didn't crash.
    And, the NetworkManager “Enable/Disable connectivity check" wanted to check it's status but, it was gone …

    So, it seems that, there was a Network Connection but, it disconnected, for whatever reason.
    • Is the machine a mobile device and, is it moving?


    One explanation is, that it's a mobile device, moving at say 100 or 200 km/h and, the network connection is being handed off from one radio cell to the next …

  7. #17

    Default Re: journalctl log flooded with NetworkManager warning

    Quote Originally Posted by dcurtisfra View Post
    Then, whatever it was that disappeared – it didn't crash.
    And, the NetworkManager “Enable/Disable connectivity check" wanted to check it's status but, it was gone …

    So, it seems that, there was a Network Connection but, it disconnected, for whatever reason.
    • Is the machine a mobile device and, is it moving?


    One explanation is, that it's a mobile device, moving at say 100 or 200 km/h and, the network connection is being handed off from one radio cell to the next …

    No

    No
    (The message you have entered is too short. Please lengthen your message to at least 10 characters.)

  8. #18
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    3,129

    Default Re: journalctl log flooded with NetworkManager warning

    @MakeTopSite:

    OK, the system ain't moving anywhere …

    Then, if a process simply disappears/dies without cleaning up it's dependencies, there's possibly something incompatible in your current installation.
    1. Please check your installation repositories – “zypper repos --uri” – anything which ain't “leap/15.1/” is suspect – please check very carefully …
    2. Refresh the RPM database – “zypper refresh” – and then, please check that the RPM database isn't corrupt and, rebuild it: “rpm --rebuilddb”.
    3. Please perform an initial Repository verification: “zypper verify”.
    4. Please check that all the installed files match to the RPM database: “rpm --verify --all”.
    5. Please check for orphaned packages: either, with YaST or, with “zypper packages --orphaned”.
    6. Make sure that, the “tmp” directories are clean: “systemctl start systemd-tmpfiles-clean.service”.
    7. Make sure that, the user's Cache directory is clean: “~/.cache/”.
    8. Logout and then reboot.

  9. #19

    Default Re: journalctl log flooded with NetworkManager warning

    Quote Originally Posted by dcurtisfra View Post
    @MakeTopSite:

    OK, the system ain't moving anywhere …

    Then, if a process simply disappears/dies without cleaning up it's dependencies, there's possibly something incompatible in your current installation.
    1. Please check your installation repositories – “zypper repos --uri” – anything which ain't “leap/15.1/” is suspect – please check very carefully …
    2. Refresh the RPM database – “zypper refresh” – and then, please check that the RPM database isn't corrupt and, rebuild it: “rpm --rebuilddb”.
    3. Please perform an initial Repository verification: “zypper verify”.
    4. Please check that all the installed files match to the RPM database: “rpm --verify --all”.
    5. Please check for orphaned packages: either, with YaST or, with “zypper packages --orphaned”.
    6. Make sure that, the “tmp” directories are clean: “systemctl start systemd-tmpfiles-clean.service”.
    7. Make sure that, the user's Cache directory is clean: “~/.cache/”.
    8. Logout and then reboot.
    Warnings have disappeared after removing postfix and correcting wicked configuration.

    Then I have tried commands you have suggested. Results seemed to be ok.
    Code:
    rpm --verify --all
    SM5....T.  c /etc/libvirt/nwfilter/allow-arp.xml
    SM5....T.  c /etc/libvirt/nwfilter/allow-dhcp-server.xml
    SM5....T.  c /etc/libvirt/nwfilter/allow-dhcp.xml
    SM5....T.  c /etc/libvirt/nwfilter/allow-incoming-ipv4.xml
    SM5....T.  c /etc/libvirt/nwfilter/allow-ipv4.xml
    SM5....T.  c /etc/libvirt/nwfilter/clean-traffic-gateway.xml
    SM5....T.  c /etc/libvirt/nwfilter/clean-traffic.xml
    SM5....T.  c /etc/libvirt/nwfilter/no-arp-ip-spoofing.xml
    SM5....T.  c /etc/libvirt/nwfilter/no-arp-mac-spoofing.xml
    SM5....T.  c /etc/libvirt/nwfilter/no-arp-spoofing.xml
    SM5....T.  c /etc/libvirt/nwfilter/no-ip-multicast.xml
    SM5....T.  c /etc/libvirt/nwfilter/no-ip-spoofing.xml
    SM5....T.  c /etc/libvirt/nwfilter/no-mac-broadcast.xml
    SM5....T.  c /etc/libvirt/nwfilter/no-mac-spoofing.xml
    SM5....T.  c /etc/libvirt/nwfilter/no-other-l2-traffic.xml
    SM5....T.  c /etc/libvirt/nwfilter/no-other-rarp-traffic.xml
    SM5....T.  c /etc/libvirt/nwfilter/qemu-announce-self-rarp.xml
    SM5....T.  c /etc/libvirt/nwfilter/qemu-announce-self.xml
    .M.......  g /run/lirc
    .M....G..  g /etc/brlapi.key
    ....L....  c /etc/pam.d/common-account
    ....L....  c /etc/pam.d/common-auth
    ....L....  c /etc/pam.d/common-password
    ....L....  c /etc/pam.d/common-session
    .M....G..  g /var/log/lastlog
    S.5....T.  c /etc/pam.d/login
    S.5....T.  c /etc/pam.d/xdm
    S.5....T.  c /etc/security/pam_mount.conf.xml
    ....L....    /usr/share/java/xml-commons-apis.jar
    ....L....  d /usr/share/man/man1/ftp.1.gz
    S.5....T.  c /etc/default/tlp
    .......T.    /usr/lib64/gconv/gconv-modules.cache
    S.5....T.  c /etc/pulse/client.conf
    .M.......  c /var/log/audit/audit.log
    .M.......  g /usr/share/fonts/75dpi/encodings.dir
    .M.......  g /usr/share/fonts/75dpi/fonts.scale
    .M.......  g /usr/share/fonts/misc/encodings.dir
    .M.......  g /usr/share/fonts/misc/fonts.scale
    .M.......  g /var/lib/GeoIP/GeoIP.dat
    S.5....T.    /usr/share/icewm/themes/Infadel2/Overloaded.theme
    .M...U...    /var/cache/cups
    .M.......  g /etc/mpv/scripts
    S.5....T.  c /etc/ntp.conf
    .M.......  g /var/lib/ca-certificates/ca-bundle.pem
    .M.......  g /var/lib/ca-certificates/java-cacerts
    .M.......  g /var/log/alternatives.log
    ....L....    /etc/ImageMagick-7
    .M.......  g /usr/share/fonts/100dpi/encodings.dir
    .M.......  g /usr/share/fonts/100dpi/fonts.scale
    .M.......  g /usr/share/fonts/Type1/encodings.dir
    .M.......  g /usr/share/fonts/cyrillic/encodings.dir
    .M.......  g /usr/share/fonts/cyrillic/fonts.scale
    .M.......  g /usr/share/fonts/truetype/encodings.dir
    S.5....T.  c /etc/sysconfig/SuSEfirewall2
    S.5....T.  c /etc/plymouth/plymouthd.conf
    .....UG..  g /run/lightdm
    S.5....T.  c /etc/fonts/conf.d/10-rendering-options.conf
    S.5....T.  c /etc/fonts/conf.d/58-family-prefer-local.conf
    .M.......  g /etc/udev/hwdb.bin
    S.5....T.  c /etc/pam.d/sudo
    .M.......  g /etc/iscsi/initiatorname.iscsi
    .M.......  g /boot/grub2/grub.cfg
    S.5....T.  c /etc/default/grub
    .......T.  c /etc/login.defs
    .M.......  g /var/lib/kerberos/krb5
    .M.......  g /var/lib/kerberos/krb5/user
    .M.......  c /etc/X11/xorg.conf.d/00-keyboard.conf
    .M.......  c /etc/locale.conf
    .M.......  c /etc/machine-id
    .M.......  c /etc/vconsole.conf
    .M.......  g /var/lib/systemd/random-seed
    .M.......  g /run/avahi-daemon
    .M.......  g /etc/xml/catalog-d.xml
    .M.......  g /etc/mpv/scripts
    SM5....T.  c /etc/fonts/conf.d/30-metric-aliases.conf
    .M.......  g /run/mcelog
    .M.......  g /run/cryptsetup
    Then I have tried to reproduce this warning by undoing wrong wicked configuration, but warnings have never appeared again.

  10. #20
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    3,129

    Default Re: journalctl log flooded with NetworkManager warning

    Quote Originally Posted by MakeTopSite View Post
    Warnings have disappeared after removing postfix
    Please be aware that, the “postfix” RPM package is recommended by the “patterns-base-enhanced_base” RPM package and suggested by the “openSUSE-release-15.1” RPM package.
    Check with “rpm --query --recommends patterns-base-enhanced_base” and “rpm --query --suggests openSUSE-release-15.1”.
    • You may find that, at some stage YaST Software will automatically re-install the “postfix” RPM package due to the dependencies noted above.

Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •