Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: plasmashell flooding journal while mpv is playing

  1. #1

    Question plasmashell flooding journal while mpv is playing

    Hi,

    While playing an internet stream in mpv I am getting thousands of these messages in journal:
    Code:
    ...
    [42510.470447] plasmashell[2519]: kde.dataengine.mpris: "org.mpris.MediaPlayer2.mpv.instance0x7f38b4009410" exports "SupportedMimeTypes" as D-Bus type "<unknown>" but it should be D-Bus type "as"
    [42510.470595] plasmashell[2519]: kde.dataengine.mpris: "org.mpris.MediaPlayer2.mpv.instance0x7f38b4009410" exports "SupportedUriSchemes" as D-Bus type "<unknown>" but it should be D-Bus type "as"
    [42510.470713] plasmashell[2519]: kde.dataengine.mpris: "org.mpris.MediaPlayer2.mpv.instance0x7f38b4009410" exports "Position" as D-Bus type "d" but it should be D-Bus type "x"
    ...
    This is flooding my logs with unnecessary info and (I suspect) it may even be influencing system performance by adding this logging overhead.

    How can I stop this log flood please?

  2. #2
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,874

    Default Re: plasmashell flooding journal while mpv is playing

    No guarantee this will work, but try:

    Create a text file "qtlogging.ini" in "/usr/share/qt5" with the following content:

    Code:
    [Rules]
    *.debug=false
    Be aware though, this will affect all kde/qt applications.
    Regards, Paul

  3. #3

    Default Re: plasmashell flooding journal while mpv is playing

    Before starting this thread I already had:

    Code:
    $ printenv | grep QT_LOGGING_RULES
    QT_LOGGING_RULES=*.debug=false;qt.qpa.*=false
    but it simply removed other (less fequent but still too many and annoying) messages like:

    Code:
    kwin_x11[2488]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 2508, resource id: 100663296, major code: 18 (ChangeProperty), minor code: 0
    The ones listed in the OP still remain though.

    Considering the above:
    Should I still do what you suggest?

    ETA: These seem to "warning" messages, not "debug" ones, so perhaps that's why they remain unaffected by QT logging setting?

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,874

    Default Re: plasmashell flooding journal while mpv is playing

    Sorry, I'd not looked that closely, I assumed(!) they were debug messages.


    Depends on what messages you want to suppress...

    other options for "non-essential" are
    *.warning=false
    *.info=false

    KDE/Qt does issue a lot of debug messages, digikam for example writes almost 64k to the journal just on start-up.

    Personally, I suppress debug and info...
    Regards, Paul

  5. #5

    Default Re: plasmashell flooding journal while mpv is playing

    Thanks for the additional clarifications.

    Quote Originally Posted by tannington View Post
    other options for "non-essential" are
    *.warning=false
    *.info=false
    Wouldn't suppressing all warnings (for all programs) have any negative effects?

    Is there a way to suppress only the warning messages for mpv?

  6. #6
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,874

    Default Re: plasmashell flooding journal while mpv is playing

    Quote Originally Posted by suseino View Post
    Wouldn't suppressing all warnings (for all programs) have any negative effects?
    Only if you're looking through the journal for warning messages...

    One could run with all warning messages suppressed, then if you had problems with an application re-enable warnings. The obvious drawback to that is (with warnings suppressed) if there was an unexpected problem you wouldn't then glean much from the journal.

    Is there a way to suppress only the warning messages for mpv?
    Not that I'm aware of, (which doesn't mean there isn't). I believe it would be up to the individual application to be less verbose, or to have some method of controlling it's verbosity. But I'm very much open to correction on that one.
    Regards, Paul

  7. #7

    Default Re: plasmashell flooding journal while mpv is playing

    Quote Originally Posted by tannington View Post
    The obvious drawback to that is (with warnings suppressed) if there was an unexpected problem you wouldn't then glean much from the journal.
    My concerns exactly.

    BTW searching the web I found there is a program called 'kdebugsettings' in which I see it is possible to control individually KDE programs. But mpv is not in the list of programs. Trying to add it through the "Insert" button results in a looooong delay after which typing 'mpv' in the search field shows some weird lines. So I have no idea if this is the way to it.

    Another thing I found in 'man mpv' was MPV_VERBOSE but I am not sure if it has any relation to journal at all.

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,221

    Default Re: plasmashell flooding journal while mpv is playing

    MPV is not a KDE native app

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,718
    Blog Entries
    15

    Default Re: plasmashell flooding journal while mpv is playing

    Quote Originally Posted by gogalthorp View Post
    MPV is not a KDE native app
    Hi
    Yes, I use mpv here with curseradio and see zero journal entries, likewise if just use mpv standalone. Likely your desktop environment.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10

    Default Re: plasmashell flooding journal while mpv is playing

    @malcolmlewis

    How would you approach the main issue: avoiding only the extra journal messages related to mpv?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •