Results 1 to 4 of 4

Thread: Windows Boot is not found in Grub 2 or starting f12 menu

  1. #1

    Exclamation Windows Boot is not found in Grub 2 or starting f12 menu

    So I installed a fresh version of Opensuse tumbleweed, everything was default install other then the linux installer could not touch windows, the disk was encrypted and LVM was enabled.

    Data I got from "fdisk -l" was


    aRealCyborg@linux-jsh6:~> sudo efibootmgr -v
    [sudo] password for root:
    sudo: efibootmgr: command not found
    aRealCyborg@linux-jsh6:~> efibootmgr -v
    If 'efibootmgr' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf efibootmgr
    aRealCyborg@linux-jsh6:~> fdisk -l
    Absolute path to 'fdisk' is '/usr/sbin/fdisk', so running it may require superuser privileges (eg. root).
    aRealCyborg@linux-jsh6:~> sudo fdisk -l
    Disk /dev/sda: 232.91 GiB, 250059350016 bytes, 488397168 sectors
    Disk model: CT250MX500SSD1
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: 7EE0D701-8BDF-4057-B4A9-8E3D512B6BC2

    Device Start End Sectors Size Type
    /dev/sda1 2048 1085439 1083392 529M Windows recovery environment
    /dev/sda2 1085440 1290239 204800 100M EFI System
    /dev/sda3 1290240 1323007 32768 16M Microsoft reserved
    /dev/sda4 1323008 365518847 364195840 173.7G Microsoft basic data
    /dev/sda5 365518848 365535231 16384 8M BIOS boot
    /dev/sda6 365535232 488397134 122861903 58.6G Linux LVM


    Disk /dev/sdb: 465.78 GiB, 500107862016 bytes, 976773168 sectors
    Disk model: CT500MX500SSD4
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: 3BD7AFEA-A2F8-4A5F-A6C2-83621688D937

    Device Start End Sectors Size Type
    /dev/sdb1 34 32767 32734 16M Microsoft reserved
    /dev/sdb2 32768 976771071 976738304 465.8G Microsoft basic data

    Partition 1 does not start on physical sector boundary.

    Not really sure what to do to get my windows to be boot able again

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,335
    Blog Entries
    3

    Default Re: Windows Boot is not found in Grub 2 or starting f12 menu

    I should have asked you to use a CODE block for that output. But, never mind. I can still read it, even if not formatted as well.

    I'm surirpised that "efibootmgr" is not found. But perhaps it is not installed if you use legacy BIOS booting instead of UEFI booting.

    Here's the problem:

    Windows is installed for UEFI booting.
    If linux is installed for legacy BIOS booting, then it will not be able to boot Windows.

    I am a little surprised that the F12 boot menu does not include Windows. But if you configured your BIOS for legacy BIOS booting (otherwise called CSM), perhaps it won't show UEFI boot options.

    Another check. Can you provide the output from:
    Code:
    grep LOADER_TYPE /etc/sysconfig/bootloader
    And try to use a CODE block this time. You can generate a code block with the "#" icon in the edit window, and just paste the output there.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Post Re: Windows Boot is not found in Grub 2 or starting f12 menu

    I did not know how to make a code block.
    but here you do
    Code:
    aRealCyborg@linux-jsh6:~> grep LOADER_TYPE /etc/sysconfig/bootloader 
    LOADER_TYPE="grub2"
    Doing sudo of the command gives the same out put

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,335
    Blog Entries
    3

    Default Re: Windows Boot is not found in Grub 2 or starting f12 menu

    That confirms that you are using BIOS booting (not UEFI booting) for openSUSE.

    You will need Windows and openSUSE to both boot the same way.

    My advice would be to switch openSUSE to use UEFI booting. You might find it easier to reinstall (booting the installer in UEFI mode).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •