Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Partition in /etc/fstab not mounted automatically at boot

  1. #1

    Default Partition in /etc/fstab not mounted automatically at boot

    Hi All,

    I have an entry in /etc/fstab to mount an existing partition to an existing directory

    UUID=3aa73beb-9e7b-4220-a6f3-bf084538fc74 /scratch ext4 defaults 0 0

    blkid shows the right UUID

    /dev/sda4: UUID="3aa73beb-9e7b-4220-a6f3-bf084538fc74" TYPE="ext4" PARTUUID="96e155b6-b5ec-4437-975e-333943eeb41b"

    The partition is not mounted when I boot the machine. All system partitions like /boot/efi or /root or /opt are mounted. After booting I have to do a

    mount -a

    to mount the partition. I can not find any errors in the logs.

    Any ideas what might be wrong?

    Thank you
    Willi

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,385

    Default Re: Partition in /etc/fstab not mounted automatically at boot

    I have read this earlier, but by searching the forums I can only find similar about Btrfs subvolumes, not about "normal" file sytems. Well, vaguely I remember also an ext4 case.

    In those cases the file system is mounted at boot, but immediatly unmounted again. That can be seen in the loggings though.

    Let us wait for others with better memories

    BTW:

    There is an important, but not easy to find feature on the forums.

    Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

    An example is here: Using CODE tags Around your paste.
    Henk van Velden

  3. #3
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    1,835

    Default Re: Partition in /etc/fstab not mounted automatically at boot

    Quote Originally Posted by wischie View Post
    Code:
    UUID=3aa73beb-9e7b-4220-a6f3-bf084538fc74 /scratch ext4 defaults 0 0
    Any consequence if you change to:
    Code:
    UUID=3aa73beb-9e7b-4220-a6f3-bf084538fc74 /scratch ext4 nofail 0 2
    ???
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 42.3,TW,15.0 & 13.1 on Haswell w/ RAID
    Secondary: eComStation (OS/2)&42.3 on 965P/Radeon
    Tertiary: TW,15.0,42.3,Fedora,Debian,more on Kaby Lake,Q45,Q43,G41,G3X,965G,Cedar,Caicos,Oland,GT218&&&

  4. #4

    Default Re: Partition in /etc/fstab not mounted automatically at boot

    Quote Originally Posted by mrmazda View Post
    Any consequence if you change to:
    Code:
    UUID=3aa73beb-9e7b-4220-a6f3-bf084538fc74 /scratch ext4 nofail 0 2
    ???
    Makes no difference, automatic mount does not work.

    The same partitioning works without problems under Debian and Fedora. So, what does Tumbleweed make different?

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,385

    Default Re: Partition in /etc/fstab not mounted automatically at boot

    Quote Originally Posted by wischie View Post
    Makes no difference, automatic mount does not work.

    The same partitioning works without problems under Debian and Fedora. So, what does Tumbleweed make different?
    It should work on TW likewise. There is some problem.

    Because I remember earlier reports, is your TW up-to-date?
    Henk van Velden

  6. #6

    Default Re: Partition in /etc/fstab not mounted automatically at boot

    Quote Originally Posted by hcvv View Post
    It should work on TW likewise. There is some problem.

    Because I remember earlier reports, is your TW up-to-date?
    I think so

    Code:
    zypper dup
    ...
    Nothing to do.

  7. #7
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    373

    Default Re: Partition in /etc/fstab not mounted automatically at boot

    Quote Originally Posted by wischie View Post
    ... I have an entry in /etc/fstab to mount an existing partition to an existing directory

    UUID=3aa73beb-9e7b-4220-a6f3-bf084538fc74 /scratch ext4 defaults 0 0

    blkid shows the right UUID

    /dev/sda4: UUID="3aa73beb-9e7b-4220-a6f3-bf084538fc74" TYPE="ext4" PARTUUID="96e155b6-b5ec-4437-975e-333943eeb41b"

    The partition is not mounted when I boot the machine. All system partitions like /boot/efi or /root or /opt are mounted. After booting I have to do a

    mount -a

    to mount the partition. I can not find any errors in the logs.
    Please show the result of (done directly after system start-up as root in a console)
    Code:
    # journalctl -b 0 | grep mount
    Regards

    susejunky

  8. #8
    Join Date
    Sep 2012
    Location
    Montreal Canada
    Posts
    60

    Default Re: Partition in /etc/fstab not mounted automatically at boot

    Re using /scratch, I have no issues with doing just that. However, here is an idea.
    umount /scratch
    ls -l / and verify the ownership and properties & permissions.

    Then do the manual mount and reverify them.

    Eventually, because I have separate installations of Suse KDE, SUSE Tumbleweed, and Fedora, I changed the name of my /scratch to /share

    But that should not be an issue at all.
    Here is my fstab entry with a title header
    Code:
    #<file system>                            <mount>   <type>   <options>                   <dmp pass> <xref>          <label/uuid>
    UUID=acefc30a-d7fc-40fb-82c5-e0cae7c85ff0 /share    ext4     defaults,relatime             1  2     #/dev/nvme0n1p5 nvme0n1p5Share


  9. #9

    Default Re: Partition in /etc/fstab not mounted automatically at boot

    Quote Originally Posted by susejunky View Post
    Please show the result of (done directly after system start-up as root in a console)
    Code:
    # journalctl -b 0 | grep mount
    Regards

    susejunky
    Here it is:

    Code:
    Dec 05 07:46:42 sedenko systemd[1]: Condition check resulted in dracut pre-mount hook being skipped.
    Dec 05 07:46:44 sedenko systemd[1]: Condition check resulted in dracut mount hook being skipped.
    Dec 05 07:46:45 sedenko kernel: EXT4-fs (sda4): mounted filesystem with ordered data mode. Opts: (null)
    Dec 05 07:46:46 sedenko systemd[1]: Unmounting /.snapshots...
    Dec 05 07:46:46 sedenko systemd[1]: Unmounting /boot/efi...
    Dec 05 07:46:46 sedenko systemd[1]: Unmounting /boot/grub2/i386-pc...
    Dec 05 07:46:46 sedenko systemd[1]: Unmounting /boot/grub2/x86_64-efi...
    Dec 05 07:46:46 sedenko systemd[1]: Unmounting /opt...
    Dec 05 07:46:46 sedenko systemd[1]: Unmounting /root...
    Dec 05 07:46:46 sedenko systemd[1]: Unmounting /scratch...
    Dec 05 07:46:46 sedenko systemd[1]: Unmounting /srv...
    Dec 05 07:46:46 sedenko systemd[1]: Unmounting /usr/local...
    Dec 05 07:46:46 sedenko systemd[1]: Unmounting /tmp...
    Dec 05 07:46:46 sedenko systemd[1]: \x2esnapshots.mount: Succeeded.
    Dec 05 07:46:46 sedenko systemd[1]: Unmounted /.snapshots.
    Dec 05 07:46:46 sedenko systemd[1]: boot-efi.mount: Succeeded.
    Dec 05 07:46:46 sedenko systemd[1]: Unmounted /boot/efi.
    Dec 05 07:46:46 sedenko systemd[1]: boot-grub2-i386\x2dpc.mount: Succeeded.
    Dec 05 07:46:46 sedenko systemd[1]: Unmounted /boot/grub2/i386-pc.
    Dec 05 07:46:46 sedenko systemd[1]: boot-grub2-x86_64\x2defi.mount: Succeeded.
    Dec 05 07:46:46 sedenko systemd[1]: Unmounted /boot/grub2/x86_64-efi.
    Dec 05 07:46:46 sedenko systemd[1]: opt.mount: Succeeded.
    Dec 05 07:46:46 sedenko systemd[1]: Unmounted /opt.
    Dec 05 07:46:46 sedenko systemd[1]: root.mount: Succeeded.
    Dec 05 07:46:46 sedenko systemd[1]: Unmounted /root.
    Dec 05 07:46:46 sedenko systemd[1]: scratch.mount: Succeeded.
    Dec 05 07:46:46 sedenko systemd[1]: Unmounted /scratch.
    Dec 05 07:46:46 sedenko systemd[1]: srv.mount: Succeeded.
    Dec 05 07:46:46 sedenko systemd[1]: Unmounted /srv.
    Dec 05 07:46:46 sedenko systemd[1]: usr-local.mount: Succeeded.
    Dec 05 07:46:46 sedenko systemd[1]: Unmounted /usr/local.
    Dec 05 07:46:46 sedenko systemd[1]: tmp.mount: Succeeded.
    Dec 05 07:46:46 sedenko systemd[1]: Unmounted /tmp.
    Dec 05 07:46:55 sedenko systemd[1]: tmp.mount: Directory /tmp to mount over is not empty, mounting anyway.
    Dec 05 07:47:00 sedenko systemd[1]: Starting Automounts filesystems on demand...
    Dec 05 07:47:00 sedenko systemd[1]: tmp-autobcyaHg.mount: Succeeded.
    Dec 05 07:47:00 sedenko systemd[1]: tmp-autoD8Ji5c.mount: Succeeded.
    Dec 05 07:47:00 sedenko systemd[1]: Started Automounts filesystems on demand.
    Dec 05 07:47:23 sedenko kernel: EXT4-fs (sdf1): mounted filesystem with ordered data mode. Opts: (null)
    Dec 05 07:47:35 sedenko systemd[1]: run-user-476.mount: Succeeded.
    Dec 05 07:47:35 sedenko systemd[2221]: run-user-476.mount: Succeeded.
    sdf1 is an external usb drive.

  10. #10

    Default Re: Partition in /etc/fstab not mounted automatically at boot

    Quote Originally Posted by lsatenstein View Post
    Re using /scratch, I have no issues with doing just that. However, here is an idea.
    umount /scratch
    ls -l / and verify the ownership and properties & permissions.

    Then do the manual mount and reverify them.

    Eventually, because I have separate installations of Suse KDE, SUSE Tumbleweed, and Fedora, I changed the name of my /scratch to /share

    But that should not be an issue at all.
    Here is my fstab entry with a title header
    Code:
    #<file system>                            <mount>   <type>   <options>                   <dmp pass> <xref>          <label/uuid>
    UUID=acefc30a-d7fc-40fb-82c5-e0cae7c85ff0 /share    ext4     defaults,relatime             1  2     #/dev/nvme0n1p5 nvme0n1p5Share

    Tried changing the name and the permissions
    Code:
    chmod a+wt /scratch
    Still no automatic mount.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •