Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: Leap 15.0 Can't configure network card on install

  1. #1

    Default Leap 15.0 Can't configure network card on install

    I have had to install 15.0 (tried 15.1 but it is broken for my laptop model and won't boot after install), but to my surprise I can't configure the network card for wired connections (I don't have wifi). The message is "Unable to configure the network card because the kernel device (eth0, wlan0) is not present."
    I am using the 15.0 iso image I downloaded today from the archived versions on the openSUSE site.

    How do I get around this problem? I need to be able to download a fix but can't access the network. And I don't know what the fix is.

    Abe

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,456
    Blog Entries
    2

    Default Re: Leap 15.0 Can't configure network card on install

    Pls post the name of your computer make and model, and the network card(s) in your system.

    And,
    - If you have access to another working computer at the same time, which can run any kind of OS (If you have access, a description for that, also).
    - Which installation ISO are you trying to use? Provide either the file name or if that isn't convenient at least the size of the file which will minimally tell us whether it's a DVD or a NET install ISO.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: Leap 15.0 Can't configure network card on install

    Computer: Acer TravelMate B-117
    Network card: Gigabit RTL8153
    The iso is
    openSUSE-Leap-15.0-DVD-x86_64.iso
    and I used a usb card to run the installation from.

    I have a working desktop running Leap 15.1 as well.

    Abe

  4. #4

    Default Re: Leap 15.0 Can't configure network card on install

    Omission: make of the network card is Realtek

    Abe

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,671
    Blog Entries
    1

    Default Re: Leap 15.0 Can't configure network card on install

    Just to clarify further, you've managed to install openSUSE 15.0 successfully on this laptop, but just don't have a working ethernet device? If so, please get us the chipset details
    Code:
    /sbin/lspci -nnk|grep -iA3 net
    You can save the output this to a text file and copy to a memory stick. Then post from an internet-connected machine.
    openSUSE Leap 15.1; KDE Plasma 5

  6. #6

    Default Re: Leap 15.0 Can't configure network card on install

    02:00.0 Network controller [0280]: Intel Corporation Wireless 7265 [8086:095a] (rev 59)
    Subsystem: Interl Corporation Dual BAnd Wireless-AC 7265 [8086:5010]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi

    But I don't see how this relates to my USB-adapter for wired connection. This is the wifi information.

    Abe

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,671
    Blog Entries
    1

    Default Re: Leap 15.0 Can't configure network card on install

    But I don't see how this relates to my USB-adapter for wired connection. This is the wifi information.

    Abe
    Sorry, I missed that you were using a USB-connected ethernet device. Run this instead
    Code:
    usb-devices
    openSUSE Leap 15.1; KDE Plasma 5

  8. #8

    Default Re: Leap 15.0 Can't configure network card on install

    The Realtek device that comes up gives this information:

    T: Bus=02 Lev=01 Prnt=01 Port=04 Cnt=01 Dev#= 3 Spd=5000 MxCh= 0
    D: Ver= 3.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 9 #Cfgs= 2
    P: Vendor=0bda ProdID=8153 Rev=31.00
    S: Manufacturer=Realtek
    S: Product= USB 10/100/1000 LAN
    S: SerialNumber=001000001
    C: #Ifs= 2 Cfg#= 2 Atr=a0 MxPwr=288mA
    I: If#= 0 Alt= 0 #EPs= 1 Cls=02(Commc ) Sub=06 Prot=00 Driver=none
    I: If#= 1 Alt= 0 #EPs= 0 Cls=0a(data ) Sub=00 Prot=00 Driver=none

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,671
    Blog Entries
    1

    Default Re: Leap 15.0 Can't configure network card on install

    Quote Originally Posted by naimab View Post
    The Realtek device that comes up gives this information:

    T: Bus=02 Lev=01 Prnt=01 Port=04 Cnt=01 Dev#= 3 Spd=5000 MxCh= 0
    D: Ver= 3.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 9 #Cfgs= 2
    P: Vendor=0bda ProdID=8153 Rev=31.00
    S: Manufacturer=Realtek
    S: Product= USB 10/100/1000 LAN
    S: SerialNumber=001000001
    C: #Ifs= 2 Cfg#= 2 Atr=a0 MxPwr=288mA
    I: If#= 0 Alt= 0 #EPs= 1 Cls=02(Commc ) Sub=06 Prot=00 Driver=none
    I: If#= 1 Alt= 0 #EPs= 0 Cls=0a(data ) Sub=00 Prot=00 Driver=none
    Ok, so no driver loaded.

    With openSUSE Leap 15.1 I note that the product ID for your device is reported as supprted...
    Code:
     sudo modinfo r8152|grep 8153
    description:    Realtek RTL8152/RTL8153 Based USB Ethernet Adapters
    alias:          usb:v0BDAp8153d*dc*dsc*dp*ic02isc06ip00in*
    alias:          usb:v0BDAp8153d*dc*dsc*dp*icFFisc*ip*in*
    I don't have openSUSE 15.0 installed, but perhaps you could run the same command to see if the kernel supports that particular chipset.
    openSUSE Leap 15.1; KDE Plasma 5

  10. #10

    Default Re: Leap 15.0 Can't configure network card on install

    I get identical output to yours on 15.0.

    So if the chipset is supported, why is the driver not loaded?

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •