Results 1 to 4 of 4

Thread: Display manager doesn't start

  1. #1

    Default Display manager doesn't start

    I thought I was having the usual Optimus problems, which my old thread dealt with, but it seems to be something different. This is a new installation and the GUI has never appeared. I tried following these Bumblebee instructions. After blacklisting Nouveau, my computer still doesn't reboot into a graphical environment, just straight to the command line. startx fails and says to use a display manager.

    SDDM is installed and I enabled it. When I rebooted afterwards, it still booted into the command line as it always does, except it blinked four times. Maybe the computer was trying to start graphics but failed?

    startx gave me the same stuff:
    serverauth does not exist
    failed to set IOPL for I/O (operation not permitted)
    fatal server error: cannot run in framebuffer mode

    I also can't manually start SDDM.

  2. #2
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    373

    Default Re: Display manager doesn't start

    Quote Originally Posted by SceoMyntan View Post
    I thought I was having the usual Optimus problems, which my old thread dealt with, but it seems to be something different.
    I think the root of your problem still is the setup of your graphics.
    Quote Originally Posted by SceoMyntan View Post
    This is a new installation and the GUI has never appeared. I tried following these Bumblebee instructions.
    Do i understand that correctly:

    You did a fresh installation of openSUSE Leap 15.1 (?) and are now stuck after step 6 (of the Bumblebee instructions you refer to) without a graphical login?
    At the moment your system has no bumblebee, suse-prime or any other "Optimus-related" software installed?

    The UEFI of my laptop (Intel HD Graphics 630 / NVIDIA GeForce GTX 1060 Mobile) allows me to choose between

    "NVIDIA"
    only the NVIDIA card will be available and can be used

    "MSHYBRID"
    both cards (Intel and NVIDIA) are active and will be used (aka OPTIMUS setup)

    What options does your UEFI provide and which one did you choose before you started the installation?

    Regards

    susejunky

  3. #3

    Default Re: Display manager doesn't start

    Correct, I'm stopped after step 6 because the graphical environment still doesn't come up.

    I have "Hybrid Graphics" selected as an option in my BIOS.

  4. #4
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    373

    Default Re: Display manager doesn't start

    Quote Originally Posted by SceoMyntan View Post
    Correct, I'm stopped after step 6 because the graphical environment still doesn't come up.

    I have "Hybrid Graphics" selected as an option in my BIOS.
    If your UEFI is still set to "Hybrid Graphics" and you are still after step 6 (of the Bumblebee instructions you refer to) without a graphical login and did not install bumblebee, suse-prime, or any other "Optimus-related" software nor the proprietary NVIDIA-driver i recommend you get the intel graphics up before you look into all the other graphics options your system (probably) can use.

    Here is how i did this on my notebook:

    I created two files

    1.) /etc/modprobe.d/09-blacklist_NVIDIA.conf
    Code:
    # File: "/etc/modprobe.d/09-blacklist_NVIDIA.conf"
    #
    # This will block any NVIDIA card driver to be loaded at system start up so that
    # X can decide which driver to load.
    # 
    
    blacklist nvidia
    blacklist nvidia-drm
    blacklist nvidia-modeset
    blacklist nouveau
    Remove "blacklist nouveau" from "/etc/modprobe.d/50-blacklist.conf" because the new file handles this.

    2.) /etc/X11/xorg.conf.d/20-intel_kms.conf
    Code:
    # File: "/etc/X11/xorg.conf.d/20-intel_kms.conf"
    #
    # Tell X to use the Intel graphics card and the kernel modesetting driver.
    #
    
    Section "Device"
        Identifier "kms"
        Driver "modesetting"
        BusID "PCI:00:02:0"
        Option "Accel" "true"
    EndSection
    To find the BusID used in that file i did (as root in a console)
    Code:
    # lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation ...
    #
    Remove "nouveau.modeset=0" from the kernel command line.

    3.) Rebuild initrd (as root in a console)
    Code:
    # dracut -f
    4.) Reboot system. It should now come up with a graphical login screen.

    If this works then you can try to implement any of the other solutions (bumblebee, suse-prime, ...) depending on your needs.

    Beware this will only work if your system is still in the state which i described at the beginning of this post. I implemented this solution directly after i had installed openSUSE. So there definitely were no left-overs from bumblebee, suse-prime or proprietary NVIDIA driver.

    Regards

    susejunky

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •