Results 1 to 2 of 2

Thread: firefox extensions: systemwide installation: How?

  1. #1

    Default firefox extensions: systemwide installation: How?

    Hi all

    We have quite a few workstations that need to be maintained by myself.
    True for all workstations (as od date of writing):
    • opensuse 15.1 x64, latest updates
    • firefox 68.2.0esr
    • Intended extensions:
      • noscript
      • nogoogleanalytics
      • adblockplus
      • and a few more for a subset of our workstations

    Users should have certain firefox (ff) extensions installed and have them - if possible - automatically updated. According to
    -install-global-extension and -install-global-theme have been removed from Gecko 1.9.2 and upwards.
    . That should be about since ff 3.6 (not really sure about the version), so long ago.

    I unsuccessfully tried to install the extensions according to these references:

    Does anyone have a clue on how to get firefox extension istalled on a systemwide basis?


  2. #2
    Join Date
    Aug 2010
    Chicago suburbs
    Blog Entries

    Default Re: firefox extensions: systemwide installation: How?

    I used to install extensions globally, until that stopped working. That was long ago.

    Since then, I have been using symbolic links. I use several "firefox" profiles. I install the extensions that I want in one of those, and then I symlink to the other profiles.

    Even that does not work as well as before. Previously, it would notice the symlinked extension and offer to use it. Now it ignores the symlinked extension until I go to the add-on screen and then manually activate it.

    When I update the extension on the primary profile, that used to update on symlinked extensions for other profiles -- when I restart "firefox". Now it sometimes takes 2 restarts before it gets the updated profile.

    The Mozilla people seem to be going out of their way to make life difficult for "firefox" users.

    I have only tried symlink with other profiles of the same user. I have not tried for firefox with other users. But that would probably work (as long as read permissions allow it).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts