Quote Originally Posted by dlochrin View Post
Also, I still have 18 Akonadi processes running even after deinstalling Korganizer, Akregator, Knotes, Kjots, so deinstalling these components hasn't simplified things much. The only applications actually being used are KMail & KAddressBook; surely they shouldn't require 18 permanently running, detached processes?
Please note this KDE documentation: <https://techbase.kde.org/KDE_PIM/Ako...adi_startup.3F>
<https://techbase.kde.org/KDE_PIM/Akonadi>
Akonadi will be automatically started by any Akonadi-enabled application . If you don't want to start Akonadi at all, you can't use any of these applications (see the list of Akonadi-enabled applications). Also note, that some Plasma widgets, such as the "Digital Clock" applet uses Akonadi.
And, this: <https://userbase.kde.org/Akonadi#Dis...nadi_subsystem>
<https://userbase.kde.org/Akonadi>
The Akonadi server is started by any Akonadi-enabled application. If you don't want Akonadi to be started after login, you have to ensure that no Akonadi-enabled application is launched at login or thereafter. Remember to check Plasma widgets as well — the Digital Clock widget in the default panel, for instance uses Akonadi to (optionally) display calendar events and this is enabled in its settings by default (see the "Display Events" option) . You must remove any widgets that may start it from your start-up, if you wish Akonadi to start only when you start KMail or other applications.
To ensure that Akonadi is not started, check that no applications require it at login. In particular, open the Plasma clock applet preferences, go to Calendar and uncheck Show events to prevent Plasma from requesting information from Akonadi and thus allowing it to start.
Referring to my previous Post, you may well run into a difficulty with something or other absolutely needing Akonadi, for whatever reason.
  • For such cases, you'll have no option except to avoid starting Akonadi at login, as described above by the KDE folks …