Results 1 to 6 of 6

Thread: Bluetooth headset cannot maintain audio integration

  1. #1

    Default Bluetooth headset cannot maintain audio integration

    With GNOME (pulseaudio), my Bluetooth headsets cannot seem to maintain their connection to the sound input/output. Upon connection, the PC will be able to send and receive sound for a couple of seconds, but then that ability ceases. The Bluetooth connection will remain, but my PC will not send or receive sound to the headset, even though I can select the device in the Sound configuration.

    I believe I remember that upon first installation, my Bluetooth audio did not have this problem, but only after attempting to use Google Hangouts with Firefox for a voice conversation that ended up consuming all of my system's memory, this problem has emerged. This leads me to believe that some vestigial configuration is hiding somewhere, but I can't seem to find where I might need to look.

    I use a Bluetooth mouse with no problems and the Bluetooth connections themselves don't seem to exhibit any issues, just the integration with the session's audio.

    Device (I think it resides with the WiFi card):
    Code:
    02:00.0 Network controller: Qualcomm Atheros AR9462 Wireless Network Adapter (rev 01)
    02:00.0 0280: 168c:0034 (rev 01)

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,120

    Default AW: Bluetooth headset cannot maintain audio integration

    Bluetooth is shown with:
    Code:
    lsusb

  3. #3

    Default Re: AW: Bluetooth headset cannot maintain audio integration

    Quote Originally Posted by Sauerland View Post
    Bluetooth is shown with:
    Code:
    lsusb
    Unless my Bluetooth radio does not reside on USB, right? I don't see anything that looks like a Bluetooth chip:
    Code:
    Bus 002 Device 002: ID 8087:8000 Intel Corp. 
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 002: ID 8087:8008 Intel Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 003 Device 007: ID 04ca:3006 Lite-On Technology Corp. 
    Bus 003 Device 006: ID 0461:4d65 Primax Electronics, Ltd 
    Bus 003 Device 004: ID 04ca:0027 Lite-On Technology Corp. 
    Bus 003 Device 005: ID 05e3:0608 Genesys Logic, Inc. Hub
    Bus 003 Device 003: ID 05e3:0608 Genesys Logic, Inc. Hub
    Bus 003 Device 002: ID 05e3:0606 Genesys Logic, Inc. USB 2.0 Hub / D-Link DUB-H4 USB 2.0 Hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,769
    Blog Entries
    1

    Default Re: Bluetooth headset cannot maintain audio integration

    Quote Originally Posted by palswim View Post
    With GNOME (pulseaudio), my Bluetooth headsets cannot seem to maintain their connection to the sound input/output. Upon connection, the PC will be able to send and receive sound for a couple of seconds, but then that ability ceases. The Bluetooth connection will remain, but my PC will not send or receive sound to the headset, even though I can select the device in the Sound configuration.
    Just in case the following is relevant here...
    https://wiki.archlinux.org/index.php...ting#Bluetooth
    Bluetooth headset replay problems

    Some user reports huge delays or even no sound when the Bluetooth connection does not send any data. This is due to the module-suspend-on-idle module, which automatically suspends sinks/sources on idle. As this can cause problems with headset, the responsible module can be deactivated.
    To disable loading of the module-suspend-on-idle module, comment out the following line in the configuration file in use (~/.config/pulse/default.pa or /etc/pulse/default.pa):
    ~/.config/pulse/default.pa ### Automatically suspend sinks/sources that become idle for too long
    #load-module module-suspend-on-idle
    Finally restart PulseAudio to apply the changes.
    openSUSE Leap 15.1; KDE Plasma 5

  5. #5

    Default Re: Bluetooth headset cannot maintain audio integration

    Quote Originally Posted by deano_ferrari View Post
    Just in case the following is relevant here...
    https://wiki.archlinux.org/index.php...ting#Bluetooth
    This seems to have solved the issue. I was looking throughout the Bluetooth sections to troubleshoot it from that angle, but didn't look through PulseAudio troubleshooting. Thanks!

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,769
    Blog Entries
    1

    Default Re: Bluetooth headset cannot maintain audio integration

    Glad to have been of guidance.
    openSUSE Leap 15.1; KDE Plasma 5

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •