Results 1 to 8 of 8

Thread: Tumbleweed update implications of option decisions not understood

  1. #1

    Default Tumbleweed update implications of option decisions not understood

    This is the first time I have been confronted with difficult options choices when running sudo zypper dup.
    Here is the result of my latest update and I have no idea what I should do or why these packages are here in the first place!:-

    Code:
    :~> sudo zypper dup
    [sudo] password for root: 
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    
    Problem: python3-dask-2.7.0-1.1.noarch requires python3-tornado >= 5, but this requirement cannot be provided
      not installable providers: python3-tornado-6.0-12.1.noarch[http-download.opensuse.org-26afdfe2]
                       python3-tornado5-5.1.1-1.1.i586[http-download.opensuse.org-26afdfe2]
                       python3-tornado5-5.1.1-1.1.x86_64[http-download.opensuse.org-26afdfe2]
                       python3-tornado6-6.0.3-1.1.i586[http-download.opensuse.org-26afdfe2]
                       python3-tornado6-6.0.3-1.1.x86_64[http-download.opensuse.org-26afdfe2]
                       python3-tornado-6.0-12.1.noarch[repo-oss]
                       python3-tornado5-5.1.1-1.1.i586[repo-oss]
                       python3-tornado5-5.1.1-1.1.x86_64[repo-oss]
                       python3-tornado6-6.0.3-1.1.i586[repo-oss]
                       python3-tornado6-6.0.3-1.1.x86_64[repo-oss]
     Solution 1: Following actions will be done:
      deinstallation of python3-dask-1.2.2-1.1.noarch
      deinstallation of python3-distributed-2.4.0-1.1.noarch
     Solution 2: deinstallation of python3-tornado4-4.5.3-2.1.x86_64
     Solution 3: keep obsolete python3-dask-1.2.2-1.1.noarch
     Solution 4: break python3-dask-2.7.0-1.1.noarch by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/3/4/c/d/?] (c):
    It seems to me that either option 1 or 2 are the only ones but which and why to choose..
    Please could somebody who knows more advise?
    Regards,
    Budgie2

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,249
    Blog Entries
    15

    Default Re: Tumbleweed update implications of option decisions not understood

    Hi
    Can you post your repository details in full with zypper lr -d, need to see what this repository is "http-download.opensuse.org-26afdfe2".
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Tumbleweed update implications of option decisions not understood

    Never a dull moment with Tumbleweed. I felt my way through the previous large update of 750 odd files and all ws well until now, a couple of small updates later I now have:-

    Code:
    11 packages to upgrade, 32 to reinstall.
    Overall download size: 4.2 MiB. Already cached: 0 B. After the operation, 40.0 B will be freed.
    Continue? [y/n/v/...? shows all options] (y): y
    Retrieving package perl-Class-Data-Inheritable-0.08-139.27.noarch              (1/43),  15.0 KiB ( 10.8 KiB unpacked)
    Retrieving: perl-Class-Data-Inheritable-0.08-139.27.noarch.rpm ...............................................[error]
    Downloaded data exceeded the expected filesize '15.0 KiB' of 'http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Tumbleweed/noarch/perl-Class-Data-Inheritable-0.08-139.27.noarch.rpm'.
    Abort, retry, ignore? [a/r/i/...? shows all options] (a): r
    Retrieving: perl-Class-Data-Inheritable-0.08-139.27.noarch.rpm ...............................................[error]
    Downloaded data exceeded the expected filesize '15.0 KiB' of 'http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Tumbleweed/noarch/perl-Class-Data-Inheritable-0.08-139.27.noarch.rpm'.
    Abort, retry, ignore? [a/r/i/...? shows all options] (a): a
    Problem occurred during or after installation or removal of packages:
    Installation has been aborted as directed.
    Please see the above error message for a hint.
    alastair@AJBR-W530:~>
    The hint is too subtle for me.
    Here is the response from your last instruction:-

    Code:
    alastair@AJBR-W530:~> zypper lr -d
    # | Alias                               | Name                | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                   | Service
    --+-------------------------------------+---------------------+---------+-----------+---------+----------+--------+---------------------------------------------------------------------------------------+--------
    1 | http-download.opensuse.org-090c69b4 | security            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/security/openSUSE_Tumbleweed/               |        
    2 | http-download.opensuse.org-26afdfe2 | openSUSE:Tumbleweed | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Tumbleweed/standard/              |        
    3 | libdvdcss                           | libdvdcss           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                                   |        
    4 | packman                             | packman             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/                                     |        
    5 | packman-essentials                  | packman-essentials  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/Essentials/                          |        
    6 | perl-modules                        | perl-modules        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Tumbleweed/ |        
    7 | repo-non-oss                        | repo-non-oss        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss                                  |        
    8 | repo-oss                            | repo-oss            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss                                      |        
    9 | repo-update                         | repo-update         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                                       |        
    alastair@AJBR-W530:~>
    Hope this helps.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,249
    Blog Entries
    15

    Default Re: Tumbleweed update implications of option decisions not understood

    Hi
    Likely repository 2 is your issue (remove it) it's just a link to the oss repo, if getting sent to two different mirror it's just asking for trouble if they are out of sync and will confuse the zypper resolver.

    Likewise remove 5, if you have the top level, then essentials is automatically there.

    Perl modules, your on your own, why do you have it present? If there are modules you need, submit to Factory for inclusion.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Tumbleweed update implications of option decisions not understood

    Hi Malcolm,
    Had difficulty getting a perl module needed. Have now removed the repos you suggest including the perl one so I now have:-

    Code:
    alastair@AJBR-W530:~> zypper lr -d
    # | Alias                               | Name         | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                     | Service
    --+-------------------------------------+--------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------+--------
    1 | http-download.opensuse.org-090c69b4 | security     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/security/openSUSE_Tumbleweed/ |        
    2 | libdvdcss                           | libdvdcss    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                     |        
    3 | packman                             | packman      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/                       |        
    4 | repo-non-oss                        | repo-non-oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss                    |        
    5 | repo-oss                            | repo-oss     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss                        |        
    6 | repo-update                         | repo-update  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                         |        
    alastair@AJBR-W530:~>
    Looks more like it should.
    Will report back after I have tried update again.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,249
    Blog Entries
    15

    Default Re: Tumbleweed update implications of option decisions not understood

    Quote Originally Posted by Budgie2 View Post
    Hi Malcolm,
    Had difficulty getting a perl module needed. Have now removed the repos you suggest including the perl one so I now have:-

    Code:
    alastair@AJBR-W530:~> zypper lr -d
    # | Alias                               | Name         | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                     | Service
    --+-------------------------------------+--------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------+--------
    1 | http-download.opensuse.org-090c69b4 | security     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/security/openSUSE_Tumbleweed/ |        
    2 | libdvdcss                           | libdvdcss    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                     |        
    3 | packman                             | packman      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed/                       |        
    4 | repo-non-oss                        | repo-non-oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss                    |        
    5 | repo-oss                            | repo-oss     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss                        |        
    6 | repo-update                         | repo-update  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                         |        
    alastair@AJBR-W530:~>
    Looks more like it should.
    Will report back after I have tried update again.
    Hi
    What about the security one? Are the packages you need in Tumbleweed?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7

    Default Re: Tumbleweed update implications of option decisions not understood

    Hi Malcolm,
    Now looks completely different and more sensible.
    Which option should I select for the new update proposed:-

    Code:
    alastair@AJBR-W530:~> sudo zypper dup
    [sudo] password for root: 
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    40 Problems:
    Problem: problem with installed package perl-B-Hooks-EndOfScope-0.24-36.8.noarch
    Problem: problem with installed package perl-Class-Data-Inheritable-0.08-139.27.noarch
    Problem: problem with installed package perl-Class-Method-Modifiers-2.13-31.1.noarch
    Problem: problem with installed package perl-Class-XSAccessor-1.19-22.60.x86_64
    Problem: problem with installed package perl-Devel-Caller-2.06-15.50.x86_64
    Problem: problem with installed package perl-Devel-GlobalDestruction-0.14-26.23.noarch
    Problem: problem with installed package perl-Devel-LexAlias-0.05-19.49.x86_64
    Problem: problem with installed package perl-Devel-StackTrace-2.04-42.2.noarch
    Problem: problem with installed package perl-Dist-CheckConflicts-0.11-25.26.noarch
    Problem: problem with installed package perl-Eval-Closure-0.14-30.22.noarch
    Problem: problem with installed package perl-Exception-Class-1.44-40.13.noarch
    Problem: problem with installed package perl-File-Copy-Recursive-0.45-16.1.noarch
    Problem: problem with installed package perl-File-HomeDir-1.004-29.7.noarch
    Problem: problem with installed package perl-File-Path-2.160000-14.7.noarch
    Problem: problem with installed package perl-File-Which-1.23-52.4.noarch
    Problem: problem with installed package perl-IPC-System-Simple-1.25-16.27.noarch
    Problem: problem with installed package perl-Log-Dispatch-2.69-65.1.noarch
    Problem: problem with installed package perl-Log-Log4perl-1.49-33.19.noarch
    Problem: problem with installed package perl-MIME-Charset-1.012.2-23.19.noarch
    Problem: problem with installed package perl-MRO-Compat-0.13-32.20.noarch
    Problem: problem with installed package perl-Module-Implementation-0.09-21.26.noarch
    Problem: problem with installed package perl-Module-Runtime-0.016-22.12.noarch
    Problem: problem with installed package perl-Package-Stash-0.38-37.4.noarch
    Problem: problem with installed package perl-Package-Stash-XS-0.29-22.15.x86_64
    Problem: problem with installed package perl-PadWalker-2.3-37.30.x86_64
    Problem: problem with installed package perl-Params-ValidationCompiler-0.30-10.7.noarch
    Problem: problem with installed package perl-Perl-Tidy-20190915-51.1.noarch
    Problem: problem with installed package perl-Role-Tiny-2.001004-35.1.noarch
    Problem: problem with installed package perl-Specio-0.44-15.1.noarch
    Problem: problem with installed package perl-Sub-Exporter-Progressive-0.001013-11.23.noarch
    Problem: problem with installed package perl-Sub-Identify-0.14-43.37.x86_64
    Problem: problem with installed package perl-Sub-Name-0.26-57.3.x86_64
    Problem: problem with installed package perl-Sub-Quote-2.006006-13.1.noarch
    Problem: problem with installed package perl-Test-Fatal-0.014-30.28.noarch
    Problem: problem with installed package perl-Tk-804.034-49.45.x86_64
    Problem: problem with installed package perl-Unicode-LineBreak-2019.001-25.14.x86_64
    Problem: problem with installed package perl-Variable-Magic-0.62-33.34.x86_64
    Problem: problem with installed package perl-YAML-Tiny-1.73-29.8.noarch
    Problem: problem with installed package perl-namespace-autoclean-0.29-31.1.noarch
    Problem: problem with installed package perl-namespace-clean-0.27-33.23.noarch
    
    Problem: problem with installed package perl-B-Hooks-EndOfScope-0.24-36.8.noarch
     Solution 1: install perl-B-Hooks-EndOfScope-0.24-1.5.noarch (with vendor change)
      obs://build.opensuse.org/devel:languages:perl  -->  openSUSE
     Solution 2: keep obsolete perl-B-Hooks-EndOfScope-0.24-36.8.noarch
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c/d/?] (c): ^[[C^[[C
    Still having fun.

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,249
    Blog Entries
    15

    Default Re: Tumbleweed update implications of option decisions not understood

    Quote Originally Posted by Budgie2 View Post
    Hi Malcolm,
    Now looks completely different and more sensible.
    Which option should I select for the new update proposed:-

    Code:
    alastair@AJBR-W530:~> sudo zypper dup
    [sudo] password for root: 
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Computing distribution upgrade...
    40 Problems:
    Problem: problem with installed package perl-B-Hooks-EndOfScope-0.24-36.8.noarch
    Problem: problem with installed package perl-Class-Data-Inheritable-0.08-139.27.noarch
    Problem: problem with installed package perl-Class-Method-Modifiers-2.13-31.1.noarch
    Problem: problem with installed package perl-Class-XSAccessor-1.19-22.60.x86_64
    Problem: problem with installed package perl-Devel-Caller-2.06-15.50.x86_64
    Problem: problem with installed package perl-Devel-GlobalDestruction-0.14-26.23.noarch
    Problem: problem with installed package perl-Devel-LexAlias-0.05-19.49.x86_64
    Problem: problem with installed package perl-Devel-StackTrace-2.04-42.2.noarch
    Problem: problem with installed package perl-Dist-CheckConflicts-0.11-25.26.noarch
    Problem: problem with installed package perl-Eval-Closure-0.14-30.22.noarch
    Problem: problem with installed package perl-Exception-Class-1.44-40.13.noarch
    Problem: problem with installed package perl-File-Copy-Recursive-0.45-16.1.noarch
    Problem: problem with installed package perl-File-HomeDir-1.004-29.7.noarch
    Problem: problem with installed package perl-File-Path-2.160000-14.7.noarch
    Problem: problem with installed package perl-File-Which-1.23-52.4.noarch
    Problem: problem with installed package perl-IPC-System-Simple-1.25-16.27.noarch
    Problem: problem with installed package perl-Log-Dispatch-2.69-65.1.noarch
    Problem: problem with installed package perl-Log-Log4perl-1.49-33.19.noarch
    Problem: problem with installed package perl-MIME-Charset-1.012.2-23.19.noarch
    Problem: problem with installed package perl-MRO-Compat-0.13-32.20.noarch
    Problem: problem with installed package perl-Module-Implementation-0.09-21.26.noarch
    Problem: problem with installed package perl-Module-Runtime-0.016-22.12.noarch
    Problem: problem with installed package perl-Package-Stash-0.38-37.4.noarch
    Problem: problem with installed package perl-Package-Stash-XS-0.29-22.15.x86_64
    Problem: problem with installed package perl-PadWalker-2.3-37.30.x86_64
    Problem: problem with installed package perl-Params-ValidationCompiler-0.30-10.7.noarch
    Problem: problem with installed package perl-Perl-Tidy-20190915-51.1.noarch
    Problem: problem with installed package perl-Role-Tiny-2.001004-35.1.noarch
    Problem: problem with installed package perl-Specio-0.44-15.1.noarch
    Problem: problem with installed package perl-Sub-Exporter-Progressive-0.001013-11.23.noarch
    Problem: problem with installed package perl-Sub-Identify-0.14-43.37.x86_64
    Problem: problem with installed package perl-Sub-Name-0.26-57.3.x86_64
    Problem: problem with installed package perl-Sub-Quote-2.006006-13.1.noarch
    Problem: problem with installed package perl-Test-Fatal-0.014-30.28.noarch
    Problem: problem with installed package perl-Tk-804.034-49.45.x86_64
    Problem: problem with installed package perl-Unicode-LineBreak-2019.001-25.14.x86_64
    Problem: problem with installed package perl-Variable-Magic-0.62-33.34.x86_64
    Problem: problem with installed package perl-YAML-Tiny-1.73-29.8.noarch
    Problem: problem with installed package perl-namespace-autoclean-0.29-31.1.noarch
    Problem: problem with installed package perl-namespace-clean-0.27-33.23.noarch
    
    Problem: problem with installed package perl-B-Hooks-EndOfScope-0.24-36.8.noarch
     Solution 1: install perl-B-Hooks-EndOfScope-0.24-1.5.noarch (with vendor change)
      obs://build.opensuse.org/devel:languages:perl  -->  openSUSE
     Solution 2: keep obsolete perl-B-Hooks-EndOfScope-0.24-36.8.noarch
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c/d/?] (c): ^[[C^[[C
    Still having fun.
    Hi
    Not really, select Solution 1 to switch back to the openSUSE Tumbleweed release rather than devel:languageserl
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •