Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: BOINC not connecting

  1. #1

    Default BOINC not connecting

    I installed boinc-client and boing manager and the manager is not connection to boinc. The boinc-client is running:

    systemctl status boinc-client
    ● boinc-client.service - Berkeley Open Infrastructure Network Computing Client
    Loaded: loaded (/usr/lib/systemd/system/boinc-client.service; disabled; vendor preset: disabled)
    Active: active (running) since Mon 2019-11-18 08:33:55 MST; 34min ago
    Docs: man:boinc(1)
    Process: 20713 ExecStopPost=/bin/rm -f $BOINC_BOINC_DIR/lockfile (code=exited, status=0/SUCCESS)
    Process: 20698 ExecStop=/usr/bin/boinccmd --quit (code=exited, status=1/FAILURE)
    Main PID: 20714 (boinc)
    Tasks: 20 (limit: 4915)
    CGroup: /background.slice/boinc-client.service
    ├─20714 /usr/bin/boinc --dir /var/lib/boinc
    └─20914 /bin/sh /usr/bin/VBoxManage --version

    I tried also the command line and received the following:

    boinccmd -p abc123
    can't connect to local host

    Next I also tried the following command:

    nc -v localhost 31416
    nc: connect to localhost port 31416 (tcp) failed: Connection refused
    nc: connect to localhost port 31416 (tcp) failed: Connection refused


    How can I solve this issue? Any one has any ideas what to do next?

    thank you

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,875
    Blog Entries
    2

    Default Re: BOINC not connecting

    Quote Originally Posted by msjbanyan View Post

    Next I also tried the following command:

    nc -v localhost 31416
    nc: connect to localhost port 31416 (tcp) failed: Connection refused
    nc: connect to localhost port 31416 (tcp) failed: Connection refused


    How can I solve this issue? Any one has any ideas what to do next?

    thank you
    "Connection refused" means that the connection is actively rejected... Which generally means that your firewall is blocking.
    Solution:
    Open the port (or defined service)

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,878
    Blog Entries
    15

    Default Re: BOINC not connecting

    Quote Originally Posted by msjbanyan View Post
    I installed boinc-client and boing manager and the manager is not connection to boinc. The boinc-client is running:

    systemctl status boinc-client
    ● boinc-client.service - Berkeley Open Infrastructure Network Computing Client
    Loaded: loaded (/usr/lib/systemd/system/boinc-client.service; disabled; vendor preset: disabled)
    Active: active (running) since Mon 2019-11-18 08:33:55 MST; 34min ago
    Docs: man:boinc(1)
    Process: 20713 ExecStopPost=/bin/rm -f $BOINC_BOINC_DIR/lockfile (code=exited, status=0/SUCCESS)
    Process: 20698 ExecStop=/usr/bin/boinccmd --quit (code=exited, status=1/FAILURE)
    Main PID: 20714 (boinc)
    Tasks: 20 (limit: 4915)
    CGroup: /background.slice/boinc-client.service
    ├─20714 /usr/bin/boinc --dir /var/lib/boinc
    └─20914 /bin/sh /usr/bin/VBoxManage --version

    I tried also the command line and received the following:

    boinccmd -p abc123
    can't connect to local host

    Next I also tried the following command:

    nc -v localhost 31416
    nc: connect to localhost port 31416 (tcp) failed: Connection refused
    nc: connect to localhost port 31416 (tcp) failed: Connection refused


    How can I solve this issue? Any one has any ideas what to do next?

    thank you
    Hi and welcome to the Forum

    Why is this running?

    Code:
    └─20914 /bin/sh /usr/bin/VBoxManage --version
    All working fine here in a KVM machine with Nvidia GPU...

    I normally just run the boinc-gui command...

    Code:
    systemctl status boinc-client.service 
    
    ● boinc-client.service - Berkeley Open Infrastructure Network Computing Client
       Loaded: loaded (/usr/lib/systemd/system/boinc-client.service; disabled; vendor preset: disabled)
       Active: active (running) since Mon 2019-11-18 19:43:19 CST; 1s ago
      Process: 6184 ExecStopPost=/bin/rm -f $BOINC_BOINC_DIR/lockfile (code=exited, status=0/SUCCESS)
     Main PID: 6193 (boinc)
        Tasks: 1 (limit: 4915)
       CGroup: /background.slice/boinc-client.service
               └─6193 /usr/bin/boinc --dir /var/lib/boinc
    
    Nov 18 19:43:19 grover-os151.homelinux.org boinc[6193]: 18-Nov-2019 19:43:19 [---] Disk: 57.51 GB total, 38.52 GB free
    ....
    Click image for larger version. 

Name:	Screenshot from 2019-11-18 19-50-06.png 
Views:	13 
Size:	291.5 KB 
ID:	877
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4
    Join Date
    Apr 2009
    Location
    South Africa
    Posts
    11

    Default Re: BOINC not connecting

    Quote Originally Posted by tsu2 View Post
    "Connection refused" means that the connection is actively rejected... Which generally means that your firewall is blocking.
    Solution:
    Open the port (or defined service)

    TSU
    The thing is I do not know where and how the open this port....... I tried but obviously Im doing something wrong?

    Regards
    Frik Brits

  5. #5
    Join Date
    Apr 2009
    Location
    South Africa
    Posts
    11

    Default Re: BOINC not connecting

    Quote Originally Posted by malcolmlewis View Post
    Hi and welcome to the Forum

    Why is this running?

    Code:
    └─20914 /bin/sh /usr/bin/VBoxManage --version
    All working fine here in a KVM machine with Nvidia GPU...

    I normally just run the boinc-gui command...

    Code:
    systemctl status boinc-client.service 
    
    ● boinc-client.service - Berkeley Open Infrastructure Network Computing Client
       Loaded: loaded (/usr/lib/systemd/system/boinc-client.service; disabled; vendor preset: disabled)
       Active: active (running) since Mon 2019-11-18 19:43:19 CST; 1s ago
      Process: 6184 ExecStopPost=/bin/rm -f $BOINC_BOINC_DIR/lockfile (code=exited, status=0/SUCCESS)
     Main PID: 6193 (boinc)
        Tasks: 1 (limit: 4915)
       CGroup: /background.slice/boinc-client.service
               └─6193 /usr/bin/boinc --dir /var/lib/boinc
    
    Nov 18 19:43:19 grover-os151.homelinux.org boinc[6193]: 18-Nov-2019 19:43:19 [---] Disk: 57.51 GB total, 38.52 GB free
    ....
    Click image for larger version. 

Name:	Screenshot from 2019-11-18 19-50-06.png 
Views:	13 
Size:	291.5 KB 
ID:	877
    So how to get that port opened, the firewall does not open it, the boinc client is not in the list of services either??

    Regards
    Frik Brits

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,878
    Blog Entries
    15

    Default Re: BOINC not connecting

    Quote Originally Posted by britsfp View Post
    So how to get that port opened, the firewall does not open it, the boinc client is not in the list of services either??

    Regards
    Frik Brits
    Hi
    There is no port that requires to be opened.... your connecting to localhost which is not affected...

    If a service cannot connect to the localhost then the service is not running or died....

    So if you have the boinc-client systemd service running stop it, then as your user run the command;

    Code:
    boinc-gui
    Does this work, show a gui and say connected to localhost?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,131

    Default Re: BOINC not connecting

    Quote Originally Posted by malcolmlewis View Post
    Hi
    There is no port that requires to be opened.... your connecting to localhost which is not affected...

    If a service cannot connect to the localhost then the service is not running or died....

    So if you have the boinc-client systemd service running stop it, then as your user run the command;

    Code:
    boinc-gui
    Does this work, show a gui and say connected to localhost?
    Sorry to jump into the thread. My problem is the same. I ran the command and the boinc manager launches but fails to connect to localhost. I can launch the gui from the menu but cannot launch it from the root command line which has always been the only way I could connect to localhost previous to today. Today's zypper dup apparently has caused the problem. I updated boinc unconditionally through yast but that did nothing.
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,878
    Blog Entries
    15

    Default Re: BOINC not connecting

    Quote Originally Posted by Prexy View Post
    Sorry to jump into the thread. My problem is the same. I ran the command and the boinc manager launches but fails to connect to localhost. I can launch the gui from the menu but cannot launch it from the root command line which has always been the only way I could connect to localhost previous to today. Today's zypper dup apparently has caused the problem. I updated boinc unconditionally through yast but that did nothing.
    Hi
    This is Leap 15.1, zypper dup? Or did you mean zypper up.....

    I see;
    Code:
     
    zypper se -si boinc-manager boinc-client
    
    S  | Name          | Type    | Version         | Arch   | Repository     
    ---+---------------+---------+-----------------+--------+----------------
    i+ | boinc-client  | package | 7.8.3-lp151.2.7 | x86_64 | Main Repository
    i+ | boinc-manager | package | 7.8.3-lp151.2.7 | x86_64 | Main Repository
    
    systemctl status boinc-client.service 
    ● boinc-client.service - Berkeley Open Infrastructure Network Computing Client
       Loaded: loaded (/usr/lib/systemd/system/boinc-client.service; disabled; vendor preset: disabled)
       Active: inactive (dead)
    All works fine here running as my user qemu machine, GNOME DE.....

    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  9. #9
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,131

    Default Re: BOINC not connecting

    Quote Originally Posted by malcolmlewis View Post
    Hi
    This is Leap 15.1, zypper dup? Or did you mean zypper up.....

    I see;
    Code:
     
    zypper se -si boinc-manager boinc-client
    
    S  | Name          | Type    | Version         | Arch   | Repository     
    ---+---------------+---------+-----------------+--------+----------------
    i+ | boinc-client  | package | 7.8.3-lp151.2.7 | x86_64 | Main Repository
    i+ | boinc-manager | package | 7.8.3-lp151.2.7 | x86_64 | Main Repository
    
    systemctl status boinc-client.service 
    ● boinc-client.service - Berkeley Open Infrastructure Network Computing Client
       Loaded: loaded (/usr/lib/systemd/system/boinc-client.service; disabled; vendor preset: disabled)
       Active: inactive (dead)
    All works fine here running as my user qemu machine, GNOME DE.....

    malcomlewis, sorry for any confusion. I'm running Tumbleweed and my reference was to the failure to get the boinc gui to run after the last zypper dup, earlier this week. I did not try to zypper in boinc but I did run the other command.
    Code:
     boinc-client.service - Berkeley Open Infrastructure Network Computing Client
       Loaded: loaded (/usr/lib/systemd/system/boinc-client.service; enabled; vendor preset: disabled)
       Active: failed (Result: exit-code) since Fri 2020-01-17 19:20:46 EST; 17h ago
         Docs: man:boinc(1)
     Main PID: 727 (code=exited, status=108)
    
    Jan 17 19:20:34 linux systemd[1]: Started Berkeley Open Infrastructure Network Computing Client.
    Jan 17 19:20:36 linux boinc[727]: 17-Jan-2020 19:20:36 [---] cc_config.xml not found - using defaults
    Jan 17 19:20:46 linux boinc[727]: 17-Jan-2020 19:20:46 Another instance of BOINC is running.
    Jan 17 19:20:46 linux systemd[1]: boinc-client.service: Main process exited, code=exited, status=108/n/a
    Jan 17 19:20:46 linux systemd[1]: boinc-client.service: Failed with result 'exit-code'.
    
    
    As I said, I updated all boinc unconditionally via yast. I will try the cmd line install now. If it makes a difference, I will post back.
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,878
    Blog Entries
    15

    Default Re: BOINC not connecting

    Quote Originally Posted by Prexy View Post
    malcomlewis, sorry for any confusion. I'm running Tumbleweed and my reference was to the failure to get the boinc gui to run after the last zypper dup, earlier this week. I did not try to zypper in boinc but I did run the other command.
    Code:
     boinc-client.service - Berkeley Open Infrastructure Network Computing Client
       Loaded: loaded (/usr/lib/systemd/system/boinc-client.service; enabled; vendor preset: disabled)
       Active: failed (Result: exit-code) since Fri 2020-01-17 19:20:46 EST; 17h ago
         Docs: man:boinc(1)
     Main PID: 727 (code=exited, status=108)
    
    Jan 17 19:20:34 linux systemd[1]: Started Berkeley Open Infrastructure Network Computing Client.
    Jan 17 19:20:36 linux boinc[727]: 17-Jan-2020 19:20:36 [---] cc_config.xml not found - using defaults
    Jan 17 19:20:46 linux boinc[727]: 17-Jan-2020 19:20:46 Another instance of BOINC is running.
    Jan 17 19:20:46 linux systemd[1]: boinc-client.service: Main process exited, code=exited, status=108/n/a
    Jan 17 19:20:46 linux systemd[1]: boinc-client.service: Failed with result 'exit-code'.
    
    
    As I said, I updated all boinc unconditionally via yast. I will try the cmd line install now. If it makes a difference, I will post back.
    Hi
    If Tumbleweed related, then suggest you please start a new thread (can point to this thread if you like), you should only use zypper dup for Tumbleweed...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •