Results 1 to 7 of 7

Thread: Can no longer mount SMB volumes

  1. #1

    Default Can no longer mount SMB volumes

    Booted the computer today. It announced that it could no longer mount the two SMB volumes. Delving into the system journal found this pearl:
    Code:
    2019-11-14T13:37:28-0700 sma-station14l kernel: CIFS: Attempting to mount //sma-nas-02/pub-data
    2019-11-14T13:37:28-0700 sma-station14l kernel: No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
    2019-11-14T13:37:35-0700 sma-station14l kernel: CIFS VFS: Error connecting to socket. Aborting operation.
    2019-11-14T13:37:35-0700 sma-station14l kernel: CIFS VFS: cifs_mount failed w/return code = -2
    The volumes are located on a NAS. The computer has been mounting these volumes for at least 5 years now.

    I checked the SMB options at the NAS. The max version offered is SMB3, the min version is SMB1. Which, if my math is correct, allows SMB2.1. The implication is stupidity on the host's part.

    I note that SMB was updated a couple of days ago; the NAS has not had a recent update (although one is pending).

    Is this a defect in the host's SMB?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,477
    Blog Entries
    2

    Default Re: Can no longer mount SMB volumes

    Try either setting the MIN level to SMBv2 or enforcing SMBv2 as both min and max.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default SOLVED Re: Can no longer mount SMB volumes

    Apparently just an opensuse brain fart.

    I booted again and SMB volumes mounted without a problem.

  4. #4

    Default Re: Can no longer mount SMB volumes

    Not solved. :-(

    It is hit or miss, about 50/50 chance, that one or both volumes do not mount. If the mount fails, it will never succeed until, maybe, during a reboot.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,708
    Blog Entries
    1

    Default Re: Can no longer mount SMB volumes

    Quote Originally Posted by jimoe666 View Post
    Not solved. :-(

    It is hit or miss, about 50/50 chance, that one or both volumes do not mount. If the mount fails, it will never succeed until, maybe, during a reboot.
    Speculating here, but it might be that the mount is being attempted before your network is up. Can you show us your defined morunts in /etc/fstab please? The '_netdev' option may be needed for example. From 'man mount'...

    _netdev
    The filesystem resides on a device that requires network access (used to prevent the system from attempting to mount
    these filesystems until the network has been enabled on the system).
    In addition to that there are systemd options such as 'x-systemd.after=network-online.target' that can be used to ensure that a shared file-system is mounted after the specified unit is reached/started etc.

    More info here
    https://www.freedesktop.org/software...emd.mount.html
    https://wiki.archlinux.org/index.php/fstab
    openSUSE Leap 15.1; KDE Plasma 5

  6. #6

    Default Re: Can no longer mount SMB volumes

    I decided to move this to a new thread. There is more info there:
    https://forums.opensuse.org/showthread.php/538230-Mounting-SMB-is-now-sporadic


  7. #7

    Default SOLVED - Re: Can no longer mount SMB volumes

    Yes, indeed, the DHCP failure was the problem.
    I configured another host to offer the DHCP service. And, Voila!, both NFS and SMB volumes mounted as expected.

    The DHCP thread: https://forums.opensuse.org/showthre...ecided-to-quit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •