Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: A proxy setting was disabled yet HTTP_PROXY persists

  1. #21

    Default Re: A proxy setting was disabled yet HTTP_PROXY persists

    Quote Originally Posted by arvidjaar View Post
    Start with plain text mode logon on tty, this will eliminate most of the complexity associated with GUI. If this variable is not set, this is likely something in GUI part indeed.
    I ssh'd to the problem host from another host. HTTP_PROXY was unset.

  2. #22
    Join Date
    Sep 2012
    Posts
    5,233

    Default Re: A proxy setting was disabled yet HTTP_PROXY persists

    Quote Originally Posted by jimoe666 View Post
    I ssh'd to the problem host from another host. HTTP_PROXY was unset.
    I understand you are on GNOME? Go to Settings - Network, there you find Network Proxy item. If I change it, it does set HTTP_PROXY variable.

  3. #23

    Default Re: A proxy setting was disabled yet HTTP_PROXY persists

    gnome v3.26.2
    Quote Originally Posted by arvidjaar View Post
    I understand you are on GNOME? Go to Settings - Network, there you find Network Proxy item. If I change it, it does set HTTP_PROXY variable.
    If it were that simple, I would not have started this thread. The Gnome Settings :: Network page refers the user to the system Proxy settings: "Please use YaST2 to configure your network." I have done so, repeatedly. And here we are.

  4. #24
    Join Date
    Sep 2012
    Posts
    5,233

    Default Re: A proxy setting was disabled yet HTTP_PROXY persists

    Quote Originally Posted by jimoe666 View Post
    The Gnome Settings :: Network page refers the user to the system Proxy settings: "Please use YaST2 to configure your network."
    Are you using wicked? What is output of "gsettings list-recursively org.gnome.system.proxy"?

  5. #25

    Default Re: A proxy setting was disabled yet HTTP_PROXY persists

    Quote Originally Posted by arvidjaar View Post
    Are you using wicked? What is output of "gsettings list-recursively org.gnome.system.proxy"?
    Yes.
    Bingo!
    Code:
    $ gsettings list-recursively org.gnome.system.proxy
    org.gnome.system.proxy use-same-proxy false
    org.gnome.system.proxy mode 'manual'
    org.gnome.system.proxy autoconfig-url ''
    org.gnome.system.proxy ignore-hosts ['localhost', '127.0.0.1', '.sma.com']
    org.gnome.system.proxy.ftp host 'proxy1.sma.com'
    org.gnome.system.proxy.ftp port 3128
    org.gnome.system.proxy.socks host 'proxy1.sma.com'
    org.gnome.system.proxy.socks port 3128
    org.gnome.system.proxy.http host 'proxy1.sma.com'
    org.gnome.system.proxy.http port 3128
    org.gnome.system.proxy.http use-authentication false
    org.gnome.system.proxy.http authentication-password ''
    org.gnome.system.proxy.http authentication-user ''
    org.gnome.system.proxy.http enabled true
    org.gnome.system.proxy.https host 'proxy1.sma.com'
    org.gnome.system.proxy.https port 3128
    How do I change those?

  6. #26
    Join Date
    Sep 2012
    Posts
    5,233

    Default Re: A proxy setting was disabled yet HTTP_PROXY persists

    Quote Originally Posted by jimoe666 View Post
    How do I change those?
    gsettings set org.gnome.system.proxy mode none

  7. #27

    Default Re: A proxy setting was disabled yet HTTP_PROXY persists

    Quote Originally Posted by arvidjaar View Post
    gsettings set org.gnome.system.proxy mode none
    Thank you!
    That cleared the value given to HTTP_PROXY. Google-Chrome is much happier now.

    This leaves the questions:
    1. How did it get set originally?
    2. Why was it not changed when the system values were changed?

  8. #28
    Join Date
    Sep 2012
    Posts
    5,233

    Default Re: A proxy setting was disabled yet HTTP_PROXY persists

    Quote Originally Posted by jimoe666 View Post
    How did it get set originally?
    How should we know? You may have been using NetworkManager in the past and configured it, then switched to wicked.
    Why was it not changed when the system values were changed?
    Because it is not system, but per-user setting, moreover it is setting of specific DE.

    The actual bug here is that changing proxy is not possible after switch to wicked even though the last configured value still takes effect. Care to open bug report?

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •