Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: reboot / shutdown hangs for 99 seconds at 'Reached target Shutdown'

  1. #1

    Default reboot / shutdown hangs for 99 seconds at 'Reached target Shutdown'

    Hi, Im having problem with my fresh installation of opensuse (server minimal install). I have found some old bug related to this issue and swap, but I don't have swap at all. I tried all the proposals, including shortening DefaultTimeoutStopSec=90s to 20s in systemd conf, commenting GRUB_TERMINAL="console" in grub, but nothing works, I'm on nvme and boot is very fast, but every reboot or shutdown takes exactly 99 seconds, that's so annoying

    Maybe someone experienced the same problem in here? How can I turn on detailed logs, or how can I look into existing logs, to see what is happening? journalctl shows only logs from actual boot, not what happened prior reboot. Thank you.

  2. #2

    Default Re: reboot / shutdown hangs for 99 seconds at 'Reached target Shutdown'

    It looks related to the old bug. After I changed my custom grub:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="nosplash mitigations=off consoleblank=30"
    GRUB_CMDLINE_LINUX="text"
    GRUB_TERMINAL="console"
    to this:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="mitigations=off consoleblank=30"
    GRUB_CMDLINE_LINUX=""
    #GRUB_TERMINAL="console"
    It reboots quickly.

    Any idea, why modern opensuse does not like old text console? And I it must have been 90s timeout, sudo reboot to actual bios screen takes 9 seconds now.

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,882
    Blog Entries
    3

    Default Re: reboot / shutdown hangs for 99 seconds at 'Reached target Shutdown'

    I'm glad things are now working better.

    I do not know why that change to the boot command line would affect boot time. I'm guessing that there was some other reason for the delay, but it happens to have cured itself.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4

    Default Re: reboot / shutdown hangs for 99 seconds at 'Reached target Shutdown'

    There is a problem with the lvm2 services causing shutdown delays with no associated error logs. You can either disable all lvm2 services, or uninstall it (as long as you're not using LVM, of course).

  5. #5

    Default Re: reboot / shutdown hangs for 99 seconds at 'Reached target Shutdown'

    Thanks guys. Today it returned, those grub parameters were probably coincidence, I'm experiencing long reboots again, without me changing anything

    @z2, you're probably right, I have disabled 3 running lvm2-related services:

    Code:
    lvm2-monitor.service                         disabled       
    lvm2-lvmetad.socket                          disabled       
    lvm2-lvmpolld.socket                         disabled
    And reboots seem to be fast again. I hope it will not return after some longer uptime. When I stop them using systemctl stop, they're stopped quickly, why are they terminating so long on reboot? I'm using btrfs on one of my partitions and I'm planning to use snapshots. Will I need these services for btrfs snapshots?

    Btw. I'm not having them on my desktop machine with tumbleweed at all.

  6. #6

    Default Re: reboot / shutdown hangs for 99 seconds at 'Reached target Shutdown'

    I don't know what is causing the problem on some systems and not others. Not everyone here has experienced this problem, but it was happening on my laptop shortly after I upgraded to 15.1. I think it was also the cause of some random system freezes that would happen occasionally, and almost always when running a VM. Since disabling all of the lvm2 services, the issue has disappeared. Although, I also switched to the tumbleweed kernel so I'm not 100% certain if it was lvm2 or the older leap kernel or some combination of the two that was causing the problem. But, I have a functional system now so I'm not going to mess with it.

    Since you have standard partitions, btrfs, ext4, etc., you can leave lvm2 disabled without affecting anything else on your system.

  7. #7

    Default Re: reboot / shutdown hangs for 99 seconds at 'Reached target Shutdown'

    Thank you, you helped me a lot, I have fast reboots now. So I'll leave lvm2 disabled for now, my OS15.1 is not running in VM, so I hope I won't need lvm and maybe in 15.2 they will fix it. I was afraid to install tumbleweed on "production" system, but on my pc I'm happy with tumbleweed too.

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,043
    Blog Entries
    14

    Default Re: reboot / shutdown hangs for 99 seconds at 'Reached target Shutdown'

    Quote Originally Posted by pruda View Post
    Thank you, you helped me a lot, I have fast reboots now. So I'll leave lvm2 disabled for now, my OS15.1 is not running in VM, so I hope I won't need lvm and maybe in 15.2 they will fix it. I was afraid to install tumbleweed on "production" system, but on my pc I'm happy with tumbleweed too.
    lvm2 has nothing to do with VMs. LVM = Logical Volume Manager. In short has to do with disk management / use. And, if you don't use LVM, it's no problem to disable the services, even remove and lock the packages.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,882
    Blog Entries
    3

    Default Re: reboot / shutdown hangs for 99 seconds at 'Reached target Shutdown'

    Quote Originally Posted by Knurpht View Post
    lvm2 has nothing to do with VMs. LVM = Logical Volume Manager. In short has to do with disk management / use. And, if you don't use LVM, it's no problem to disable the services, even remove and lock the packages.
    Just an added comment.

    I do use LVMs. I install to an encrypted LVM.

    I am not seeing this problem at all.

    My impression, from reading these reports and comparing to what I see, is that this appears to be a problem for an LVM service that is not actually used.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  10. #10
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,118

    Default Re: reboot / shutdown hangs for 99 seconds at 'Reached target Shutdown'

    Quote Originally Posted by nrickert View Post
    Just an added comment.

    I do use LVMs. I install to an encrypted LVM.

    I am not seeing this problem at all.

    My impression, from reading these reports and comparing to what I see, is that this appears to be a problem for an LVM service that is not actually used.
    IMHO this should not happen. On the other hand the fix is easy: Make sure you have none installed.

    Code:
    erlangen:~ # zypper se lvm2
    Loading repository data...
    Reading installed packages...
    
    S | Name              | Summary                                    | Type   
    --+-------------------+--------------------------------------------+--------
      | libbd_lvm2        | The LVM plugin for the LibBlockDev library | package
      | liblvm2cmd2_03    | LVM2 command line library                  | package
      | libudisks2-0_lvm2 | UDisks module for LVM2                     | package
      | lvm2              | Logical Volume Manager Tools               | package
      | lvm2-devel        | Development files for LVM2                 | package
      | lvm2-lockd        | LVM locking daemon                         | package
      | lvm2-testsuite    | LVM2 Testsuite                             | package
    erlangen:~ #
    Installing them if needed is not a big deal. Perhaps Tumbleweed should default to not select them when running the system installer.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •