Results 1 to 5 of 5

Thread: Dell Inspiron wireless not going to places

  1. #1

    Default Dell Inspiron wireless not going to places

    I finally have wlan0 up, but I get nowhere with it. I have to use eth0, like right now. This is a new/clean install

    Code:
    sudo journalctl |grep wlan0
    [sudo] password for root: 
    
    Nov 11 20:38:29 tadpole wickedd-dhcp4[1109]: wlan0: Request to acquire DHCPv4 lease with UUID 4537ca5d-f2de-0c00-c604-000006000000
    Nov 11 20:38:30 tadpole kernel: wlan0: authenticate with 7c:8b:ca:a5:53:5d
    Nov 11 20:38:30 tadpole kernel: wlan0: send auth to 7c:8b:ca:a5:53:5d (try 1/3)
    Nov 11 20:38:30 tadpole kernel: wlan0: authenticated
    Nov 11 20:38:30 tadpole kernel: wlan0: associate with 7c:8b:ca:a5:53:5d (try 1/3)
    Nov 11 20:38:30 tadpole kernel: wlan0: RX AssocResp from 7c:8b:ca:a5:53:5d (capab=0x431 status=0 aid=1)
    Nov 11 20:38:30 tadpole kernel: wlan0: associated
    Nov 11 20:38:36 tadpole wickedd-dhcp4[1109]: wlan0: Committed DHCPv4 lease with address 192.168.1.68 (lease time 86400 sec, renew in 43200 sec, rebind in 75600 sec)
    Nov 11 20:38:36 tadpole avahi-daemon[1073]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.1.68.
    Nov 11 20:38:36 tadpole avahi-daemon[1073]: New relevant interface wlan0.IPv4 for mDNS.
    Nov 11 20:38:36 tadpole avahi-daemon[1073]: Registering new address record for 192.168.1.68 on wlan0.IPv4.
    Nov 11 20:38:37 tadpole wicked[1296]: wlan0           up
    Notice that it uses wicked. I thought that it's supposed to default to network manager.
    I get an ip address but the routing is missing. The wireless network I'm trying to connect to is hidden. I have entered the SSID and the wpa key in yast/network config.

    Code:
    > ip addr
    
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 28:f1:0e:38:58:6a brd ff:ff:ff:ff:ff:ff
        inet 192.168.1.69/24 brd 192.168.1.255 scope global eth0
           valid_lft forever preferred_lft forever
    3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
        link/ether 40:49:0f:bd:d1:13 brd ff:ff:ff:ff:ff:ff
        inet 192.168.1.68/24 brd 192.168.1.255 scope global wlan0
           valid_lft forever preferred_lft forever
    Here's my inxi

    Code:
    > inxi -Fxxxz                
    Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
    System:    Host: tadpole Kernel: 4.12.14-lp151.28.25-default x86_64 bits: 64 gcc: 7.4.1
               Desktop: KDE Plasma 5.12.8 (Qt 5.9.7) dm: sddm,sddm Distro: openSUSE Leap 15.1   
    Machine:   Device: portable System: Dell product: Inspiron 5555 v: A12 serial: N/A          
               Mobo: Dell model: 0CHHXW v: A00 serial: N/A                                      
               UEFI [Legacy]: Dell v: A12 date: 08/30/2016
               Chassis: type: 8 v: A12 serial: N/A
    CPU:       Quad core AMD A10-8700P Radeon R6 10 Compute Cores 4C+6G (-MCP-) 
               arch: Excavator rev.1 cache: 4096 KB
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 14373
               clock speeds: max: 1796 MHz 1: 1796 MHz 2: 1796 MHz 3: 1796 MHz 4: 1796 MHz
    Graphics:  Card: Advanced Micro Devices [AMD/ATI] Wani [Radeon R5/R6/R7 Graphics]
               bus-ID: 00:01.0 chip-ID: 1002:9874
               Display Server: x11 (X.org 1.20.3 )
               drivers: ati,amdgpu (unloaded: modesetting,fbdev,vesa)
               tty size: 92x34
    Audio:     Card-1 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
               driver: snd_hda_intel bus-ID: 00:01.1 chip-ID: 1002:9840
               Card-2 Advanced Micro Devices [AMD] Family 15h (Models 60h-6fh) Audio Controller
               driver: snd_hda_intel bus-ID: 00:09.2 chip-ID: 1022:157a
               Sound: Advanced Linux Sound Architecture v: k4.12.14-lp151.28.25-default
    Network:   Card-1: Realtek RTL810xE PCIE Fast Ethernet controller
               driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 01:00.0 chip-ID: 10ec:8136
               IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
               Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
               driver: ath9k bus-ID: 02:00.0 chip-ID: 168c:0036
               IF: wlan0 state: up mac: <filter>
               Card-3: Qualcomm Atheros usb-ID: 001-004 chip-ID: 0cf3:e005
               IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
    Drives:    HDD Total Size: 1000.2GB (3.9% used)
               ID-1: /dev/sda model: TOSHIBA_MQ01ABD1 size: 1000.2GB serial: <filter>
    Partition: ID-1: / size: 298G used: 5.8G (3%) fs: ext4 dev: /dev/sda2
               ID-2: /home size: 616G used: 29G (5%) fs: ext4 dev: /dev/sda3
               ID-3: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda4
    Sensors:   None detected - is lm-sensors installed and configured?
    Info:      Processes: 192 Uptime: 0:13 Memory: 936.8/11443.0MB
               Init: systemd v: 234 runlevel: 5 default: graphical.target Gcc sys: N/A
               Client: Shell (bash 4.4.231 running in konsole) inxi: 2.3.40
    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,699
    Blog Entries
    1

    Default Re: Dell Inspiron wireless not going to places

    Quote Originally Posted by elfroggio View Post
    I finally have wlan0 up, but I get nowhere with it. I have to use eth0, like right now. This is a new/clean install

    Notice that it uses wicked. I thought that it's supposed to default to network manager.
    That's easy enough to switch via YaST Network settings > Global Options.

    I get an ip address but the routing is missing. The wireless network I'm trying to connect to is hidden. I have entered the SSID and the wpa key in yast/network config.
    You're getting an IP address via DHCP ok. You should capture and post the routing table when connected via wifi. If necessary, copy to a text file so that you can then post it when connected via a working ethernet connection. Also, check that name resolution is working in that situation. Show us /etc/resolv.conf when connected wirelessly (and no concurrent wired ethernet connection). Best not to leave us to guess the details.
    openSUSE Leap 15.1; KDE Plasma 5

  3. #3

    Cool Re: Dell Inspiron wireless not going to places

    Quote Originally Posted by deano_ferrari View Post
    That's easy enough to switch via YaST Network settings > Global Options.
    Will do

    Quote Originally Posted by deano_ferrari View Post
    You're getting an IP address via DHCP ok. You should capture and post the routing table when connected via wifi. If necessary, copy to a text file so that you can then post it when connected via a working ethernet connection. Also, check that name resolution is working in that situation. Show us /etc/resolv.conf when connected wirelessly (and no concurrent wired ethernet connection). Best not to leave us to guess the details.
    Problem solved. Now it's working after a couple of reboots due to packages upgrades and installs. I have no idea what did it.

    BTW1, how do I capture the routing table?
    BTW2, how do I check that name resolution is working ?

    Thanks

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,699
    Blog Entries
    1

    Default Re: Dell Inspiron wireless not going to places

    Quote Originally Posted by elfroggio View Post
    Will do



    Problem solved. Now it's working after a couple of reboots due to packages upgrades and installs. I have no idea what did it.
    Thanks for the update.

    BTW1, how do I capture the routing table?
    With
    Code:
    ip route
    BTW2, how do I check that name resolution is working ?

    Thanks
    A simple check is to try pinging an internet address by name eg
    Code:
    ping google.com
    Query DNS...
    Code:
    host google.com
    Code:
    dig google.com
    You can see see any defined name servers with
    Code:
    grep name /etc/resolv.conf
    openSUSE Leap 15.1; KDE Plasma 5

  5. #5

    Default Re: Dell Inspiron wireless not going to places

    Thanks for the info. Next time, I will be using it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •