You suggested to move the entire python2.7 folder to python2.7.old. Apparently YaST and zypp can deal with this today ( wasn't like that before, one had do use --force ). But what happens to apps that have dependencies in this folder. Honestly, you're breaking the system that way. In Budgie2's case, it would mean that a package depending on python2-zoneinfo would install ( python2-zoneinfo is installed ) but would not work ( files belonging to the package are no longer there ). This is also the danger of using 'pip' as root. The rpmdb has know info about the files/modules/packages installed by pip.