Results 1 to 5 of 5

Thread: Upgrading WSL question

  1. #1

    Default Upgrading WSL question

    Hi,
    I have a openSUSE Leap 15 in Windows Subsytem for Linux that I want to upgrade to 15.1.
    I can mention that it originally was openSUSE 42 that was upgraded to 15 last year.

    Anyway I'm trying to follow the instructions here:
    https://en.opensuse.org/SDB:System_upgrade

    I have the following repos:

    zypper repos --uri
    Repository priorities are without effect. All enabled repositories share the same priority.

    # | Alias | Name | Enabled | GPG Check | Refresh | URI
    --+---------------------+-------------------------------------+---------+-----------+---------+-----------------------------------------------------------------------
    1 | repo-non-oss | repo-non-oss | Yes | (r ) Yes | Yes | https://download.opensuse.org/distri.../repo/non-oss/
    2 | repo-oss | repo-oss | Yes | (r ) Yes | Yes | https://download.opensuse.org/distri...15.1/repo/oss/
    3 | repo-update | repo-update | Yes | (r ) Yes | Yes | https://download.opensuse.org/update/leap/15.1/oss/
    4 | repo-update-non-oss | repo-update-non-oss | Yes | (r ) Yes | Yes | https://download.opensuse.org/update/leap/15.1/non-oss/
    5 | security | Security tools (openSUSE_Leap_15.1) | Yes | (r ) Yes | No | http://download.opensuse.org/reposit...USE_Leap_15.1/




    When I run zypper dup it tells me that it can't find packages, for example the first one it's complaining about is something called file-magic:

    Plase check the paste for more info here:
    https://paste.opensuse.org/67039741

    I'm not sure what to do, if I ignore it it complains about the next package (
    libX11-data-1.6.5-lp150.1.19.noarch) and so on.

    Any suggestions?

    Thanks




  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,972
    Blog Entries
    14

    Default Re: Upgrading WSL question

    Please leave out formatting except for CODE tags ( the # in the editor ). Use f.e. Ctrl-Shift-V for pasting text if you write in some other editor.

    What happens if you run
    Code:
    zypper clean
    zypper ref
    zypper dup
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Upgrading WSL question

    Sorry about the formatting.

    I tried those commands, it's the same result.

    Code:
    130 packages to upgrade, 101 to downgrade, 5 new, 8  to change vendor.
    Overall download size: 233.4 MiB. Already cached: 0 B. After the operation, additional 12.5 MiB will be used.
    
        Note: System reboot required.
    Continue? [y/n/v/...? shows all options] (y):
    Retrieving package file-magic-5.32-lp150.5.17.noarch                                                                                                                                                                                               (1/236), 411.2 KiB (  5.6 MiB unpacked)Media source 'https://download.opensuse.org/distribution/leap/15.1/repo/oss/' does not contain the desired medium
    Abort, retry, ignore? [a/r/i/...? shows all options] (a):

  4. #4
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,144

    Default Re: Upgrading WSL question

    236 packages does not seem enough for the upgrade of even a minimalist useful system. there is probably something wrong with the repositories you are using. Sometimes the mirror system temporarily connects to a mirror that is not ready for use. If you indicated where in the world you are, a direct link to a nearby mirror could be suggested.

    Please show the following command for your system:
    Code:
    rayh@yoga3:~> zypper lr -Eu
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias         | Name             | Enabled | GPG Check | Refresh | URI                                                          
    ---+---------------+------------------+---------+-----------+---------+--------------------------------------------------------------
     1 | 15.1-packman  | 15.1-packman     | Yes     | (r ) Yes  | Yes     | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_15.1/
     2 | 15.1-repo-oss | 15.1-repo-oss    | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/15.1/repo/oss/
     3 | 15.1-update   | 15.1-update.gwdg | Yes     | (r ) Yes  | Yes     | https://ftp.gwdg.de/pub/opensuse/update/leap/15.1/oss/       
    rayh@yoga3:~>
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,366
    Blog Entries
    2

    Default Re: Upgrading WSL question

    A quick search of documentation turns up nothing (because it should be noted that upgrading on DEB systems is the same as our update, so those articles aren't relevant),

    But based on my circumstantial observations, I highly doubt that you can upgrade a WSL... your elevated permissions just won't be able to touch the core Linux processes that are required to do an upgrade. You'll notice in WSL with elevated permissions for the most part you only have access to system management (eg systemctl commands) and User space including the file system.

    Recommend you simply deploy a new WSL instance and re-install and configure your apps.
    Is why it might also be useful to script your install so re-deploying can be nearly "one-click"

    Note...
    I found that no matter what the version says in the Microsoft Store, you should always install the latest version of openSUSE (currently 15.1) regardless.
    So, if you created and installed your WSL reasonably recently, there's a good chance it's already running on 15.1, no need to upgrade.

    Check your version(or inspect your repositories)
    Code:
    cat /etc/os-release
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •