Results 1 to 3 of 3

Thread: Install xml.sax

  1. #1
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,356

    Default Install xml.sax

    While trying to install CroosOver I get the following error...

    Code:
    > ./install-crossover-17.0.0.sh
    install
    Traceback (most recent call last):
      File "/home/ion/cxoffice/bin/cxtie", line 89, in <module>
        import cxtiemain
      File "/home/ion/cxoffice/lib/python/cxtiemain.py", line 6, in <module>
        import c4parser
      File "/home/ion/cxoffice/lib/python/c4parser.py", line 7, in <module>
        import xml.sax
    ImportError: No module named xml.sax
    When I try to download xml.sax from https://opensuse.pkgs.org/15.1/opens...86_64.rpm.html I get a
    Code:
    404 Not Found
    Any suggestions would be appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,126
    Blog Entries
    15

    Default Re: Install xml.sax

    Hi
    Don't download packages from a third party/unknown source.....

    They should be installed by default;

    Code:
    zypper se -i sax
    
    S | Name               | Summary                             | Type   
    --+--------------------+-------------------------------------+--------
    i | perl-XML-SAX       | XML::SAX Perl Module                | package
    i | perl-XML-SAX-Base  | Base class SAX Drivers and Filters  | package
    i | perl-XML-SAX-Expat | SAX2 Driver for Expat (XML::Parser) | package
    Not sure when it's python your looking at a perl module?? You need to install python-xml.....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,356

    Default Re: Install xml.sax

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Don't download packages from a third party/unknown source.....

    They should be installed by default;

    Code:
    zypper se -i sax
    
    S | Name               | Summary                             | Type   
    --+--------------------+-------------------------------------+--------
    i | perl-XML-SAX       | XML::SAX Perl Module                | package
    i | perl-XML-SAX-Base  | Base class SAX Drivers and Filters  | package
    i | perl-XML-SAX-Expat | SAX2 Driver for Expat (XML::Parser) | package
    Not sure when it's python your looking at a perl module?? You need to install python-xml.....
    When I saw the error I carelessly assumed xml.sax was missing. Incorrect. It had been installed properly at 15.1 installation. Installing python-xml cleared the problem. Many thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •