Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Upgraded to 15.1 Plasma/KDE/KDE Wayland and AMDGPU

  1. #1

    Angry Upgraded to 15.1 Plasma/KDE/KDE Wayland and AMDGPU

    How do I get my graphics card working/stable with:
    KDE Plasma (very buggy)
    KDE Plasma Wayland (semi-buggy, virtual desktops does not work)

    Graphics card: AMD Radeon R7
    Kernel: 4.12.14-lp151.28.20
    Opensuse 15.1

    Changing from xrenderer to OpenGL 2.0/3.1 causes plasma/KDE to crash.

    How do I get this working?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,105
    Blog Entries
    15

    Default Re: Upgraded to 15.1 Plasma/KDE/KDE Wayland and AMDGPU

    Hi
    What is the exact model R7, can you post the output from;

    Code:
    /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,767
    Blog Entries
    3

    Default Re: Upgraded to 15.1 Plasma/KDE/KDE Wayland and AMDGPU

    Quote Originally Posted by cablsm View Post
    How do I get my graphics card working/stable with:
    KDE Plasma (very buggy)
    KDE Plasma Wayland (semi-buggy, virtual desktops does not work)
    For me, with Leap 15.1, Plasma Wayland is buggy. The virtual desktop pager does not work. But virtual desktops do work. I have shortcut keys defined to switch desktops.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4

    Default Re: Upgraded to 15.1 Plasma/KDE/KDE Wayland and AMDGPU

    Quote Originally Posted by malcolmlewis View Post
    Hi What is the exact model R7, can you post the output from;
    Code:
     /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    Code:
    00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Carrizo [1002:9874] (rev c8)         
    Subsystem: ASUSTeK Computer Inc. Device [1043:1931]         
    Kernel driver in use: amdgpu         
    Kernel modules: amdgpu
    I am uncertain which to use:
    KDE Plasma: all buggy with: OpenGL 2/3.1 xrenderer
    KDE Plasma Wayland: semi-buggy with: OpenGL 2, xrenderer

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,105
    Blog Entries
    15

    Default Re: Upgraded to 15.1 Plasma/KDE/KDE Wayland and AMDGPU

    Quote Originally Posted by cablsm View Post
    Code:
    00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Carrizo [1002:9874] (rev c8)         
    Subsystem: ASUSTeK Computer Inc. Device [1043:1931]         
    Kernel driver in use: amdgpu         
    Kernel modules: amdgpu
    I am uncertain which to use:
    KDE Plasma: all buggy with: OpenGL 2/3.1 xrenderer
    KDE Plasma Wayland: semi-buggy with: OpenGL 2, xrenderer
    Hi
    You could try adding the kernel boot option (YaST -> Bootloader) and add amdgpu.dc=0 and see if that helps. I have the same card here, but opted for Tumbleweed as the gpus worked better with the later kernel.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: Upgraded to 15.1 Plasma/KDE/KDE Wayland and AMDGPU

    Quote Originally Posted by malcolmlewis View Post
    Hi
    You could try adding the kernel boot option (YaST -> Bootloader) and add amdgpu.dc=0 and see if that helps. I have the same card here, but opted for Tumbleweed as the gpus worked better with the later kernel.
    I suppose it is a waiting game till more stability is provided Plasma?

    What does amdgpu.dc=0 do exactly? Tell amdgpu not to use a Display Manager?

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,105
    Blog Entries
    15

    Default Re: Upgraded to 15.1 Plasma/KDE/KDE Wayland and AMDGPU

    Quote Originally Posted by cablsm View Post
    I suppose it is a waiting game till more stability is provided Plasma?

    What does amdgpu.dc=0 do exactly? Tell amdgpu not to use a Display Manager?
    Hi
    Display Core is off.... More info here: https://www.kernel.org/doc/html/latest/gpu/amdgpu.html

    Aside from any DE issues, sometimes the newer gpu's have issues with the older kernel drivers.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8

    Default Re: Upgraded to 15.1 Plasma/KDE/KDE Wayland and AMDGPU

    Is there any way/program to debug/troubleshoot the performance of this card beside dmesg/journalctl ???

  9. #9

    Default Re: Upgraded to 15.1 Plasma/KDE/KDE Wayland and AMDGPU

    Try to replace Mesa 3D drivers with an AMD drivers.

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,105
    Blog Entries
    15

    Default Re: Upgraded to 15.1 Plasma/KDE/KDE Wayland and AMDGPU

    Quote Originally Posted by Svyatko View Post
    Try to replace Mesa 3D drivers with an AMD drivers.
    Hi
    That all depends if the OP has a stand alone GPU or it's integrated (APU), it maynot work. Besides downgrading the graphics stack seems like a kludge.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •