Results 1 to 5 of 5

Thread: google-earth-pro-stable 64bit version needs realy a bunch of 32bit libs?

  1. #1
    Join Date
    Sep 2008
    Location
    Argentina
    Posts
    156

    Default google-earth-pro-stable 64bit version needs realy a bunch of 32bit libs?

    google-earth-pro-stable-7.3.2.5776-0.x86_64 version does really need libGLU1-32bit version?
    This will install a whole bunch of 32bit libs.
    On leap 15.0 this was not so.
    Is this a google-earth or libGLU1-32bit "problem"?


    Code:
    
    
    Code:
     The following 83 NEW packages are going to be installed:
      glibc-32bit gnome-keyring-32bit gnome-keyring-pam-32bit krb5-32bit libGLU1-32bit libX11-6-32bit libXau6-32bit libacl1-32bit libargon2-1-32bit libattr1-32bit libaudit1-32bit libavahi-client3-32bit libavahi-common3-32bit libblkid1-32bit
      libcap2-32bit libcom_err2-32bit libcrack2-32bit libcryptsetup12-32bit libcups2-32bit libdbus-1-3-32bit libdcerpc-binding0-32bit libdcerpc0-32bit libdevmapper1_03-32bit libfam0-gamin-32bit libffi7-32bit libgcc_s1-32bit
      libgcrypt20-32bit libglvnd-32bit libgmp10-32bit libgnutls30-32bit libgpg-error0-32bit libhogweed4-32bit libidn2-0-32bit libjansson4-32bit libjson-c3-32bit libkeyutils1-32bit libldap-2_4-2-32bit libldb1-32bit liblz4-1-32bit
      liblzma5-32bit libndr-krb5pac0-32bit libndr-nbt0-32bit libndr-standard0-32bit libndr0-32bit libnetapi0-32bit libnettle6-32bit libnscd1-32bit libnsl2-32bit libopenssl1_1-32bit libp11-kit0-32bit libpcre1-32bit libpopt0-32bit
      libsamba-credentials0-32bit libsamba-errors0-32bit libsamba-hostconfig0-32bit libsamba-passdb0-32bit libsamba-util0-32bit libsamdb0-32bit libsasl2-3-32bit libseccomp2-32bit libselinux1-32bit libsmbconf0-32bit libsmbldap2-32bit
      libstdc++6-32bit libsystemd0-32bit libtalloc2-32bit libtasn1-6-32bit libtdb1-32bit libtevent-util0-32bit libtevent0-32bit libtirpc3-32bit libudev1-32bit libunistring2-32bit libuuid1-32bit libverto1-32bit libwbclient0-32bit
      libxcb1-32bit libz1-32bit nss-mdns-32bit pam-32bit samba-client-32bit samba-libs-32bit systemd-32bit
    
    


  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,079
    Blog Entries
    15

    Default Re: google-earth-pro-stable 64bit version needs realy a bunch of 32bit libs?

    Hi
    Nope.... ignore the dependency (select Solution 2) and ensure libGLU1 is installed.

    Code:
    Problem: nothing provides mesa-libGLU needed by google-earth-pro-stable-7.3.2.5776-0.x86_64
     Solution 1: do not install google-earth-pro-stable-7.3.2.5776-0.x86_64
     Solution 2: break google-earth-pro-stable-7.3.2.5776-0.x86_64 by ignoring some of its dependencies
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Sep 2008
    Location
    Argentina
    Posts
    156

    Default Re: google-earth-pro-stable 64bit version needs realy a bunch of 32bit libs?

    Ok thanks

    Is it possible to ignore this with zypper? I've not found anything only plain rpm
    and I want to automate whole install with scripts and zypper.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,079
    Blog Entries
    15

    Default Re: google-earth-pro-stable 64bit version needs realy a bunch of 32bit libs?

    Quote Originally Posted by tkmbe View Post
    Ok thanks

    Is it possible to ignore this with zypper? I've not found anything only plain rpm
    and I want to automate whole install with scripts and zypper.
    Hi
    Yes, use -y or --no-confirm, see zypper se -i --help for more options. Just make sure it's only for that rpm though....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Sep 2008
    Location
    Argentina
    Posts
    156

    Default Re: google-earth-pro-stable 64bit version needs realy a bunch of 32bit libs?

    -y does only work as yes but not to ignore dependency problems already tried
    Nevertheless I use rpm for this packages but I must download it an specify with full name...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •