Results 1 to 10 of 10

Thread: Problem mit DVD-Wiedergabe

  1. #1

    Default Problem mit DVD-Wiedergabe

    Hallo,
    mittels diesem Tutorial habe ich die Multimediafunktionalität meines Rechners ausgebaut. Was noch nicht funktionieren will ist die Wiedergabe von DVDs. Egal ob kopiergeschützt oder nicht, die "Videos" Anwendung gibt den folgenden Fehler aus "Zum Abspielen dieses Videos wird die nicht installierte Erweiterung DVD-Quelle benötigt." Weiß jemand, wie das Paket genau heißt, bzw. unter welchem Namen ich es finden kann? Manchmal ist in der Fehlermeldung der Softwarecenter verlinkt. Der zeigt aber leider nur "Could not find package".

    Danke schon mal.

  2. #2
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    384

    Default AW: Problem mit DVD-Wiedergabe

    gstreamer-plugins-ugly

    Ansonsten mal die Ergebnisse folgender Befehle hier vorführen:
    Code:
    zypper lr -d
    Code:
    zypper se -si totem dvd
    Code:
    zypper se -si gst

  3. #3

    Default Re: Problem mit DVD-Wiedergabe

    Danke für die schnelle Antwort!
    gstreamer-plugins-ugly ist bereits installiert.

    Hier die Ergebnisse der Konsolenanalyse:

    Code:
    user@linux-p77h:~> zypper lr -d
    #  | Alias                     | Name                                                    | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ    | URI                                                                      | Dienst
    ---+---------------------------+---------------------------------------------------------+-----------+-----------------+----------------+-----------+--------+--------------------------------------------------------------------------+-------
     1 | dvd                       | dvd                                                     | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.1/                       |       
     2 | openSUSE-Leap-15.1-1      | openSUSE-Leap-15.1-1                                    | Nein      | ----            | ----           |   99      | rpm-md | cd:/?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_SH-224FB_S16S6YCG800M3Y |       
     3 | packman                   | packman                                                 | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.1/                         |       
     4 | repo-debug                | Debug Repository                                        | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/distribution/leap/15.1/repo/oss/      |       
     5 | repo-debug-non-oss        | Debug Repository (Non-OSS)                              | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/distribution/leap/15.1/repo/non-oss/  |       
     6 | repo-debug-update         | Update Repository (Debug)                               | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/update/leap/15.1/oss/                 |       
     7 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS)                      | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/debug/update/leap/15.1/non-oss/             |       
     8 | repo-non-oss              | Non-OSS Repository                                      | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/        |       
     9 | repo-oss                  | Haupt-Repository                                        | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/oss/            |       
    10 | repo-source               | Source Repository                                       | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/15.1/repo/oss/     |       
    11 | repo-source-non-oss       | Source Repository (Non-OSS)                             | Nein      | ----            | ----           |   99      | NONE   | http://download.opensuse.org/source/distribution/leap/15.1/repo/non-oss/ |       
    12 | repo-update               | Hauptaktualisierungs-Repository                         | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/leap/15.1/oss                        |       
    13 | repo-update-non-oss       | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Ja        | (r ) Ja         | Ja             |   99      | rpm-md | http://download.opensuse.org/update/leap/15.1/non-oss/                   |       
    user@linux-p77h:~> zypper se -si totem dvd
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    
    S  | Name                          | Typ   | Version          | Arch   | Repository      
    ---+-------------------------------+-------+------------------+--------+-----------------
    i  | dvd+rw-tools                  | Paket | 7.1-lp151.2.4    | x86_64 | Haupt-Repository
    i+ | libdvdcss2                    | Paket | 1.4.2-lp150.1.2  | x86_64 | dvd             
    i  | libdvdnav4                    | Paket | 6.0.0-lp151.2.3  | x86_64 | Haupt-Repository
    i  | libdvdread4                   | Paket | 6.0.0-lp151.2.3  | x86_64 | Haupt-Repository
    i  | libtotem-plparser-mini18      | Paket | 3.26.0-lp151.3.4 | x86_64 | Haupt-Repository
    i  | libtotem-plparser18           | Paket | 3.26.0-lp151.3.4 | x86_64 | Haupt-Repository
    i  | nautilus-totem                | Paket | 3.26.0-lp151.8.5 | x86_64 | Haupt-Repository
    i  | openSUSE-release-dvd          | Paket | 15.1-lp151.298.1 | x86_64 | (Systempakete)  
    i  | totem                         | Paket | 3.26.0-lp151.8.5 | x86_64 | Haupt-Repository
    i  | totem-lang                    | Paket | 3.26.0-lp151.8.5 | noarch | Haupt-Repository
    i  | totem-pl-parser               | Paket | 3.26.0-lp151.3.4 | x86_64 | Haupt-Repository
    i  | totem-pl-parser-lang          | Paket | 3.26.0-lp151.3.4 | noarch | Haupt-Repository
    i  | totem-plugin-brasero          | Paket | 3.26.0-lp151.8.5 | x86_64 | Haupt-Repository
    i  | totem-plugins                 | Paket | 3.26.0-lp151.8.5 | x86_64 | Haupt-Repository
    i  | typelib-1_0-TotemPlParser-1_0 | Paket | 3.26.0-lp151.3.4 | x86_64 | Haupt-Repository
    user@linux-p77h:~> zypper se -si gst
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    
    S  | Name                              | Typ   | Version             | Arch   | Repository                     
    ---+-----------------------------------+-------+---------------------+--------+--------------------------------
    i  | PackageKit-gstreamer-plugin       | Paket | 1.1.10-lp151.8.3.1  | x86_64 | Hauptaktualisierungs-Repository
    i  | gstreamer                         | Paket | 1.12.5-lp151.2.5    | x86_64 | Haupt-Repository               
    i  | gstreamer-lang                    | Paket | 1.12.5-lp151.2.5    | noarch | Haupt-Repository               
    i  | gstreamer-libnice                 | Paket | 0.1.14-lp151.2.3    | x86_64 | Haupt-Repository               
    i  | gstreamer-plugin-cluttergst3      | Paket | 3.0.26-lp151.2.3    | x86_64 | Haupt-Repository               
    i+ | gstreamer-plugins-bad             | Paket | 1.12.5-lp151.4.6    | x86_64 | packman                        
    i  | gstreamer-plugins-bad-lang        | Paket | 1.12.5-lp151.4.6    | noarch | packman                        
    i  | gstreamer-plugins-base            | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | gstreamer-plugins-base-lang       | Paket | 1.12.5-lp151.2.4    | noarch | Haupt-Repository               
    i  | gstreamer-plugins-cogl            | Paket | 1.22.2-lp151.3.6    | x86_64 | Haupt-Repository               
    i  | gstreamer-plugins-farstream       | Paket | 0.2.8-lp151.2.3     | x86_64 | Haupt-Repository               
    i  | gstreamer-plugins-good            | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | gstreamer-plugins-good-lang       | Paket | 1.12.5-lp151.2.4    | noarch | Haupt-Repository               
    i+ | gstreamer-plugins-libav           | Paket | 1.12.5-lp151.5.2    | x86_64 | packman                        
    i+ | gstreamer-plugins-ugly            | Paket | 1.12.5-lp151.3.3    | x86_64 | packman                        
    i  | gstreamer-plugins-ugly-lang       | Paket | 1.12.5-3.2          | noarch | packman                        
    i+ | gstreamer-plugins-ugly-orig-addon | Paket | 1.12.5-lp151.3.3    | x86_64 | packman                        
    i  | gstreamer-utils                   | Paket | 1.12.5-lp151.2.5    | x86_64 | Haupt-Repository               
    i  | libclutter-gst-3_0-0              | Paket | 3.0.26-lp151.2.3    | x86_64 | Haupt-Repository               
    i  | libgstadaptivedemux-1_0-0         | Paket | 1.12.5-lp151.4.6    | x86_64 | packman                        
    i  | libgstallocators-1_0-0            | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | libgstapp-1_0-0                   | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | libgstaudio-1_0-0                 | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | libgstbadaudio-1_0-0              | Paket | 1.12.5-lp151.4.6    | x86_64 | packman                        
    i  | libgstbadbase-1_0-0               | Paket | 1.12.5-lp151.4.6    | x86_64 | packman                        
    i  | libgstbadvideo-1_0-0              | Paket | 1.12.5-lp151.4.6    | x86_64 | packman                        
    i  | libgstbasecamerabinsrc-1_0-0      | Paket | 1.12.5-lp151.4.6    | x86_64 | packman                        
    i  | libgstcodecparsers-1_0-0          | Paket | 1.12.5-lp151.4.6    | x86_64 | packman                        
    i  | libgstfft-1_0-0                   | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | libgstgl-1_0-0                    | Paket | 1.12.5-lp151.4.6    | x86_64 | packman                        
    i  | libgstmpegts-1_0-0                | Paket | 1.12.5-lp151.4.6    | x86_64 | packman                        
    i  | libgstpbutils-1_0-0               | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | libgstphotography-1_0-0           | Paket | 1.12.5-lp151.4.6    | x86_64 | packman                        
    i  | libgstreamer-1_0-0                | Paket | 1.12.5-lp151.2.5    | x86_64 | Haupt-Repository               
    i  | libgstriff-1_0-0                  | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | libgstrtp-1_0-0                   | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | libgstrtsp-1_0-0                  | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | libgstsdp-1_0-0                   | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | libgsttag-1_0-0                   | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | libgsturidownloader-1_0-0         | Paket | 1.12.5-lp151.4.6    | x86_64 | packman                        
    i  | libgstvideo-1_0-0                 | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | libgstwayland-1_0-0               | Paket | 1.12.5-lp151.4.6    | x86_64 | packman                        
    i  | libgupnp-dlna-backend-gstreamer   | Paket | 0.10.5-lp151.2.3    | x86_64 | Haupt-Repository               
    i  | typelib-1_0-ClutterGst-3_0        | Paket | 3.0.26-lp151.2.3    | x86_64 | Haupt-Repository               
    i  | typelib-1_0-Gst-1_0               | Paket | 1.12.5-lp151.2.5    | x86_64 | Haupt-Repository               
    i  | typelib-1_0-GstAudio-1_0          | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | typelib-1_0-GstPbutils-1_0        | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | typelib-1_0-GstTag-1_0            | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | typelib-1_0-GstVideo-1_0          | Paket | 1.12.5-lp151.2.4    | x86_64 | Haupt-Repository               
    i  | vlc-codec-gstreamer               | Paket | 3.0.7.1-lp151.6.5.3 | x86_64 | packman

  4. #4
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    384

    Default AW: Problem mit DVD-Wiedergabe

    Falls nach der Installation des Paketes gstreamer-plugins-bad-orig-addon keine Verbesserung auftritt, dann starte die Anwendung Videos (Totem) aus dem gnome-terminal heraus und führe hier die Meldungen vor.

    gstreamer-plugins-good-extra ist auch nicht installiert, ist hier aber unwichtig, da es nichts enthält um Filme von DVDs zu schauen.

  5. #5

    Default Re: Problem mit DVD-Wiedergabe

    Habe eben mal beide Pakete installiert. Nun klappt das Abspielen von DVDs ohne Kopierschutz problemlos. Danke dafür!
    Gibt es eigentlich für kopiergeschützte DVDs mittlerweile eine Lösung? Früher hatte ich OnePlay gekauft und installiert; allerdings gibt es die Software nicht mehr für OpenSuse.

  6. #6
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    384

    Default AW: Re: Problem mit DVD-Wiedergabe

    Quote Originally Posted by Sep95 View Post
    Habe eben mal beide Pakete installiert. Nun klappt das Abspielen von DVDs ohne Kopierschutz problemlos. Danke dafür!
    Und „kopiergeschützte“ DVDs können noch immer nicht abgespielt werden?


    Quote Originally Posted by Sep95 View Post
    Gibt es eigentlich für kopiergeschützte DVDs mittlerweile eine Lösung? Früher hatte ich OnePlay gekauft und installiert; allerdings gibt es die Software nicht mehr für OpenSuse.
    Mir ist auch nur noch der ONEPLAY DVD Player von Fluendo bekannt, dieser sollte, laut Beschreibung eines Online-Shop (ixsoft), auch mit openSUSE funktionieren. LinDVD gibt es ja nicht mehr. Ich habe aber auch keine Probleme Filme von DVDs und Blu-ray Discs mittels des VLC zu schauen, daher interessieren mich die „legalen“ Angebote auch nicht.

  7. #7

    Default Re: AW: Re: Problem mit DVD-Wiedergabe

    Quote Originally Posted by tomm_fa View Post
    Und „kopiergeschützte“ DVDs können noch immer nicht abgespielt werden?
    Zumindest nicht alle. In den meisten Fällen bleibt dann einfach das Bild in Totem schwarz und es gibt keinen Ton. Beim VLC ist das entweder genauso, oder er stürzt kurze Zeit später ab.


    Quote Originally Posted by tomm_fa View Post
    Mir ist auch nur noch der ONEPLAY DVD Player von Fluendo bekannt, dieser sollte, laut Beschreibung eines Online-Shop (ixsoft), auch mit openSUSE funktionieren. LinDVD gibt es ja nicht mehr. Ich habe aber auch keine Probleme Filme von DVDs und Blu-ray Discs mittels des VLC zu schauen, daher interessieren mich die „legalen“ Angebote auch nicht.
    Wenn ich die kopiergeschützten DVDs auch so sehen könnte, interessieren mich die kostenpflichtigen Angebote auch nicht.

  8. #8
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    384

    Default AW: Problem mit DVD-Wiedergabe

    Zu Totem (die Anwendung Videos) fällt mir nichts mehr ein, von den benötigten Paketen sollte alles passen. Zu VLC könntest du noch die Ausgabe von
    Code:
    zypper se -si vlc
    hier vorführen.
    Mit den Regionalcodes passt alles?
    Hardware?
    Ansonsten noch:
    Quote Originally Posted by mir
    … dann starte die Anwendung Videos (Totem) aus dem gnome-terminal heraus und führe hier die Meldungen vor.

  9. #9

    Default Re: AW: Problem mit DVD-Wiedergabe

    Quote Originally Posted by tomm_fa View Post
    Mit den Regionalcodes passt alles?
    Hardware?
    Ich habe keine manuelle Einstellung der Regionalcodes vorgenommen.
    Die Hardware sollte kein Problem sein: i3-4130 CPU, 8 GB RAM, keine dezidierte Garfikkarte (stattdessen Intel-HD).

    Totem zeigt im Terminal folgendes, wenn ich versuche, eine kopiergeschützte DVD abzuspielen:

    Code:
    (totem:3691): GLib-CRITICAL **: g_key_file_load_from_file: assertion 'file != NULL' failed
    libdvdread: Attempting to use device /dev/sr0 mounted on /run/media/familie/RABE_SOCKE for CSS authentication
    libdvdnav: Using dvdnav version 6.0.0
    libdvdread: Attempting to use device /dev/sr0 mounted on /run/media/familie/RABE_SOCKE for CSS authentication
    libdvdnav: Can't read name block. Probably not a DVD-ROM device.
    libdvdnav: vm: dvd_read_name failed
    libdvdnav: DVD disk reports itself with Region mask 0x00fd0000. Regions: 2
    
    libdvdread: Attempting to retrieve all CSS keys
    libdvdread: This can take a _long_ time, please be patient
    
    libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x00000124
    libdvdread: Elapsed time 0
    libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x00002e42
    libdvdread: Elapsed time 0
    libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x00007a2c
    libdvdread: Elapsed time 0
    libdvdread: Found 1 VTS's
    libdvdread: Elapsed time 0
    
    (totem:3691): Gtk-WARNING **: Drawing a gadget with negative dimensions. Did you forget to allocate a size? (node slider owner GtkScale)

  10. #10
    Join Date
    Jan 2010
    Location
    Ostwestfalen (Germany)
    Posts
    384

    Default AW: Problem mit DVD-Wiedergabe

    Mir fällt zurzeit nichts mehr ein, bin ratlos.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •