Results 1 to 7 of 7

Thread: Netflix nolonger working after upgrade

  1. #1

    Default Netflix nolonger working after upgrade

    Upgraded from leap 42.3 to leap 15.1 and Netflix no longer runs in firefox.

    I get the "Oops, something went wrong ..." with an error code F7355.

    • I have DRM enabled
    • Open H264 Video Codec installed and enabled.
    • Widevine installed and enabled.


    I had this problem originally in 42.3, but cannot remember what I did to resolve it. Any help would be much appreciated.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,765
    Blog Entries
    3

    Default Re: Netflix nolonger working after upgrade

    I'm not using Netflix, so I probably can't help much.

    As far as I know, this mostly depends on having all of the needed packman packages. So make sure that the packman repo is configured. Then try:
    Code:
    zypper dup --from "packman" --allow-vendor-change
    Replace "packman" with the name or alias of the packman repo, and use quotes if there are spaces in the name.

    If that does not solve the problem, then you may need to manually install a few additional packman packages.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: Netflix nolonger working after upgrade

    I enabled the packman repos and through Yast performed "Extras->Install All Matching Recommended Packages"; sort of assumed that would install all necessary codec.

  4. #4

    Default Re: Netflix nolonger working after upgrade

    I still have leap 42.3 running on PVR machine; performed a comparison of the 42.3 v 15.1 configuration and as far as I can tell apart from old version of firefox (60.7esr) on leap 42.3 v firefox (68.1.0esr) on leap 15.1 the configurations look similar; although there are a lot of configuration items under about:config in firefox to compare.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,765
    Blog Entries
    3

    Default Re: Netflix nolonger working after upgrade

    Quote Originally Posted by Addanc View Post
    I enabled the packman repos and through Yast performed "Extras->Install All Matching Recommended Packages"; sort of assumed that would install all necessary codec.
    That won't switch them to the packman version.

    You can use the "Repositories" view. Select it with the "View" tab.

    Then click on the packman repo. There should be an option (near top of screen) to "Switch system packages to the versions in this repository".

    Use that. It may lead to some conflicts. Resolve them with the choice to switch a package to packman.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6

    Default Re: Netflix nolonger working after upgrade

    Solution:

    Library info as per "Solution Brief" here; in summary make sure all library consistently sourced from Packman repos.

    In firefox ensure DRM enabled, openH264 and Widevine plug-ins enabled.

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,765
    Blog Entries
    3

    Default Re: Netflix nolonger working after upgrade

    Thanks for reporting back.

    I'm glad you now have it working.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •