Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: KDE 5.17: /usr/bin/xdg-su -c /sbin/yast2 > Permission denied

  1. #1
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,123

    Default KDE 5.17: /usr/bin/xdg-su -c /sbin/yast2 > Permission denied

    YaST fails with message:

    Permission denied.
    Possibly incorrect password, please try again.
    On some systems, you need to be in a special group (often: wheel) to use this program.

    Adding the user to group wheel does not help.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,385

    Default Re: KDE 5.17: /usr/bin/xdg-su -c /sbin/yast2 > Permission denied

    Quote Originally Posted by karlmistelberger View Post
    YaST fails with message:

    Permission denied.
    Possibly incorrect password, please try again.
    On some systems, you need to be in a special group (often: wheel) to use this program.

    Adding the user to group wheel does not help.
    openSUSE systems do not use the security filosophy that uses the wheel group.
    OTOH other operating systems that use the wheel group, do not use YaST.
    Thus I do not undrstand the "On some systems ,,," at all.

    Are you using YaST for the first time? I doubt.
    Do you use it from a strange place? Normaly in a GUI one simply clicks on the YaST icon in the main menu (or panel). The fact that you use /usr/bin/xdg-su points to you starting it from a terminal. But from where? A terminal inside a GUI session? What user in that terrminal session? When it is a normalk user and outside a GUI session, what do you expect to happen?

    In fact, we miss the complete copy/paste of the prompt-command line, the output and the new prompt line. Something that could tell others a lot of things.
    Henk van Velden

  3. #3
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,123

    Default Re: KDE 5.17: /usr/bin/xdg-su -c /sbin/yast2 > Permission denied

    Quote Originally Posted by hcvv View Post
    openSUSE systems do not use the security filosophy that uses the wheel group.
    OTOH other operating systems that use the wheel group, do not use YaST.
    Thus I do not undrstand the "On some systems ,,," at all.

    Are you using YaST for the first time? I doubt.
    Do you use it from a strange place? Normaly in a GUI one simply clicks on the YaST icon in the main menu (or panel). The fact that you use /usr/bin/xdg-su points to you starting it from a terminal. But from where? A terminal inside a GUI session? What user in that terrminal session? When it is a normalk user and outside a GUI session, what do you expect to happen?

    In fact, we miss the complete copy/paste of the prompt-command line, the output and the new prompt line. Something that could tell others a lot of things.
    Actually I click the starter on my desktop which is linked as follows:

    Code:
    karl@erlangen:~> ll Schreibtisch/org.opensuse.YaST.desktop
    lrwxrwxrwx 1 karl users 49 17. Okt 09:09 Schreibtisch/org.opensuse.YaST.desktop -> /usr/share/applications/org.opensuse.YaST.desktop
    karl@erlangen:~>
    Code:
    karl@erlangen:~> cat /usr/share/applications/org.opensuse.YaST.desktop
    [Desktop Entry]
    Type=Application
    Categories=Settings;System;X-SuSE-Core-System;X-SuSE-ControlCenter-System;X-GNOME-SystemSettings;
    Name=YaST
    Icon=yast-control-center
    GenericName=Administrator Settings
    Exec=/usr/bin/xdg-su -c /sbin/yast2
    Encoding=UTF-8
    Comment=Manage system-wide settings
    
    karl@erlangen:~>
    Authentication fails with a window displaying:

    Der Zugriff wird verweigert.
    Möglicherweise wurde das falsche Passwort verwendet. Bitte versuchen Sie es erneut.
    Auf manchen Systemen ist die Zugehörigkeit zu einer speziellen Gruppe (oft: wheel) für das Verwenden dieser Anwendung notwendig.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,385

    Default Re: KDE 5.17: /usr/bin/xdg-su -c /sbin/yast2 > Permission denied

    I am using KDE.
    From an icon in the panel, the Properties say that the location is /home/henk/.local/share/plasma_icons and that the Command is is /usr/bin/xdg-su -c /sbin/yast2.
    Code:
    henk@boven:~/.local/share/plasma_icons> cat YaST\ \(1\).desktop 
    [Desktop Entry]
    Type=Application
    Categories=Settings;System;X-SuSE-Core-System;X-SuSE-ControlCenter-System;X-GNOME-SystemSettings;
    Name=YaST
    Icon=yast
    GenericName=Administrator Settings
    Exec=/usr/bin/xdg-su -c /sbin/yast2
    Encoding=UTF-8
    Comment=Manage system-wide settings
    
    henk@boven:~/.local/share/plasma_icons>
    Which is not the same place as your icon on the Desktop (I do not have that), but the command is the same.
    I never had any problem with starting YaST through that panel icon.

    From the Main KDE menu the item YasST (in System) shows the same command: /usr/bin/xdg-su -c /sbin/yast2

    When I execute that command from a Konsole terminal emulator:
    Code:
    henk@boven:~/.local/share/plasma_icons> /usr/bin/xdg-su -c /sbin/yast2
    henk@boven:~/.local/share/plasma_icons>
    It first shows the window to enter the password and after entering it, it show the YaST main window.

    Thus I guess the command is correct.

    Which again does not bring us much nearer to the cause of your problem.
    May I ask again if this is the first time you start YaST in this way (or at all), or is this something where we have to search for some update or install done lately?
    Henk van Velden

  5. #5
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,123

    Default Re: KDE 5.17: /usr/bin/xdg-su -c /sbin/yast2 > Permission denied

    Quote Originally Posted by hcvv View Post
    I am using KDE.
    From an icon in the panel, the Properties say that the location is /home/henk/.local/share/plasma_icons and that the Command is is /usr/bin/xdg-su -c /sbin/yast2.
    Code:
    henk@boven:~/.local/share/plasma_icons> cat YaST\ \(1\).desktop 
    [Desktop Entry]
    Type=Application
    Categories=Settings;System;X-SuSE-Core-System;X-SuSE-ControlCenter-System;X-GNOME-SystemSettings;
    Name=YaST
    Icon=yast
    GenericName=Administrator Settings
    Exec=/usr/bin/xdg-su -c /sbin/yast2
    Encoding=UTF-8
    Comment=Manage system-wide settings
    
    henk@boven:~/.local/share/plasma_icons>
    Which is not the same place as your icon on the Desktop (I do not have that), but the command is the same.
    I never had any problem with starting YaST through that panel icon.

    From the Main KDE menu the item YasST (in System) shows the same command: /usr/bin/xdg-su -c /sbin/yast2

    When I execute that command from a Konsole terminal emulator:
    Code:
    henk@boven:~/.local/share/plasma_icons> /usr/bin/xdg-su -c /sbin/yast2
    henk@boven:~/.local/share/plasma_icons>
    It first shows the window to enter the password and after entering it, it show the YaST main window.

    Thus I guess the command is correct.

    Which again does not bring us much nearer to the cause of your problem.
    May I ask again if this is the first time you start YaST in this way (or at all), or is this something where we have to search for some update or install done lately?
    It worked for years the same way it works for you. After updating to 20191014 / KDE 5.17 the starter is broken.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,385

    Default Re: KDE 5.17: /usr/bin/xdg-su -c /sbin/yast2 > Permission denied

    Quote Originally Posted by karlmistelberger View Post
    It worked for years the same way it works for you. After updating to 20191014 / KDE 5.17 the starter is broken.
    Can you roll back?

    I assume we will get more people having this in short notice.

    (I am not running TW, so do not count on me).
    Henk van Velden

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,889
    Blog Entries
    3

    Default Re: KDE 5.17: /usr/bin/xdg-su -c /sbin/yast2 > Permission denied

    Quote Originally Posted by karlmistelberger View Post
    YaST fails with message:

    Permission denied.
    Possibly incorrect password, please try again.
    On some systems, you need to be in a special group (often: wheel) to use this program.

    Adding the user to group wheel does not help.
    I just tested here (in a KVM virtual machine). And Yast still works the same way as ever.

    I tried with both a "Full Wayland" session and an X11 session. No problems either way.

    Try opening a root command line, and running "yast2" from there. Does that work?
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    1,123

    Default Re: KDE 5.17: /usr/bin/xdg-su -c /sbin/yast2 > Permission denied

    Quote Originally Posted by nrickert View Post
    I just tested here (in a KVM virtual machine). And Yast still works the same way as ever.

    I tried with both a "Full Wayland" session and an X11 session. No problems either way.

    Try opening a root command line, and running "yast2" from there. Does that work?
    The problem occurs with xdg-su. As I am running a root konsole anyway by typing 'su -' adding 'yast2&' is a handy workaround. I checked out https://bugs.kde.org/buglist.cgi?quicksearch=xdg-su to no avail.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,385

    Default Re: KDE 5.17: /usr/bin/xdg-su -c /sbin/yast2 > Permission denied

    Quote Originally Posted by karlmistelberger View Post
    The problem occurs with xdg-su. As I am running a root konsole anyway by typing 'su -' adding 'yast2&' is a handy workaround.
    That was a good idea for testing indeed.
    Henk van Velden

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,889
    Blog Entries
    3

    Default Re: KDE 5.17: /usr/bin/xdg-su -c /sbin/yast2 > Permission denied

    I do not have pam_kwallet installed. If you have that installed, you might experiment with uninstalling to see if that changes anything. At some time in the past, pam_kwallet did cause problems. That was fixed, but a similar bug might have shown up.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •