Results 1 to 5 of 5

Thread: Cannot Stop Notifications from Displaying

  1. #1

    Default Cannot Stop Notifications from Displaying

    Hello All,

    OpenSuSE Leap 15.0 XFCE

    I am currently running Leap 15.0. We are using the PC as a Wallboard displaying on a TV, and I cannot seem to get the pop-up notification to go away that says You have X Updates Available. This is the notification that displays down by the clock on the taskbar with the Red Icon with the exclamation point inside.

    First, I attempted to disable just the Update Application from Settings > Personal > Notifications, and disabled the Update application under the Applications tab. At the time there was only the update application and nm-applet, so I disabled the update one. However, the pop-up continued to appear.

    When that didn't work, under the Notifications Settings this time I enabled the Do-Not-Disturb option. Now, the Notifications Settings window shows "The notifications service is not running. No notifications will be shown". But, the pop-up continues to show up. I also tried rebooting after enabling do-not-disturb, and that didn't seem to help either.

    Any ideas why this continues to pop-up even though I disabled all notifications?


    Thanks in Advance,
    Matt

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: Cannot Stop Notifications from Displaying

    Maybe it is not what you want, but I have removed (not installed) and blocked PackageKit. That will remove the ability of any applet based on it.

    And you can of course also remove the package that contains the applet. I do not know what it is on XFCE (runninng KDE).
    Henk van Velden

  3. #3

    Default Re: Cannot Stop Notifications from Displaying

    Thanks for the reply Henk.

    It's strange, previously, when I went into the Notifications Settings window, and selected the Applications tab there was 2 Applications listed. nm-applet and another called something like gt/pk-update-something, or something along those lines.

    I now just see the "nm-applet" listed there. So maybe it only displays for Applications currently showing in that section of the taskbar. I'll check again when it pops back up.

    But, I do have the exact same SuSE image running on another PC I use, and if I right-click that update icon and go to About, it says "pk-update-icon 2".

    So you think trying to uninstall that might do the trick?


    -Matt

  4. #4

    Default Re: Cannot Stop Notifications from Displaying

    So I just checked the other PC I have running the same OS and it is called pk-update-icon.

    So I went into Yast Software Manager and I am uninstalling pk-update-icon and pk-update-icon-lang (*dependency). I will comment back tomorrow when the icon notification usually reappears. But, its probably safe to say the notification will stop after removing that.

    Have you seen any bugs about notifications appearing even after you've disabled those notifications?

    Thanks Again,
    Matt

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: Cannot Stop Notifications from Displaying

    I am using KDE as I said, so take that into account.

    But I am pretty sure that when you deinstall the software that shows the update applet (and does what it is supposed to do, you will have no notifications. How would that be still possible ?

    Also, as I do not want the applet and because removing the applet, I also do not need PackageKit (I use YaST and zypper and as native openSUSE tools that is sufficient), I also removed that (with a few dependencies) and blocked them (somewhere they seem to be recommended).
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •