Results 1 to 5 of 5

Thread: Leap 15.1 Zypper identifies File Conflict during routine update

  1. #1

    Default Leap 15.1 Zypper identifies File Conflict during routine update

    Hello All,

    The following output I get during a routine update.

    I waited for 3 weeks, thinking the matter might be resolved, but still getting the same output.

    Please advise:

    File /usr/lib64/python3.6/site-packages/osgeo/__pycache__/osr.cpython-36.pyc
    from install of
    python3-GDAL-2.4.2-lp151.32.1.x86_64 (Geo)
    conflicts with file from package
    python3-GDAL2-2.4.2-lp151.15.1.x86_64 (@System)

    File /usr/lib64/python3.6/site-packages/osgeo/_gdal.cpython-36m-x86_64-linux-gnu.so
    from install of
    python3-GDAL-2.4.2-lp151.32.1.x86_64 (Geo)
    conflicts with file from package
    python3-GDAL2-2.4.2-lp151.15.1.x86_64 (@System)

    File /usr/lib64/python3.6/site-packages/osgeo/_gdal_array.cpython-36m-x86_64-linux-gnu.so
    from install of
    python3-GDAL-2.4.2-lp151.32.1.x86_64 (Geo)
    conflicts with file from package
    python3-GDAL2-2.4.2-lp151.15.1.x86_64 (@System)

    File /usr/lib64/python3.6/site-packages/osgeo/_gdalconst.cpython-36m-x86_64-linux-gnu.so
    from install of
    python3-GDAL-2.4.2-lp151.32.1.x86_64 (Geo)
    conflicts with file from package
    python3-GDAL2-2.4.2-lp151.15.1.x86_64 (@System)

    File /usr/lib64/python3.6/site-packages/osgeo/_gnm.cpython-36m-x86_64-linux-gnu.so
    from install of
    python3-GDAL-2.4.2-lp151.32.1.x86_64 (Geo)
    conflicts with file from package
    python3-GDAL2-2.4.2-lp151.15.1.x86_64 (@System)

    File /usr/lib64/python3.6/site-packages/osgeo/_ogr.cpython-36m-x86_64-linux-gnu.so
    from install of
    python3-GDAL-2.4.2-lp151.32.1.x86_64 (Geo)
    conflicts with file from package
    python3-GDAL2-2.4.2-lp151.15.1.x86_64 (@System)

    File /usr/lib64/python3.6/site-packages/osgeo/_osr.cpython-36m-x86_64-linux-gnu.so
    from install of
    python3-GDAL-2.4.2-lp151.32.1.x86_64 (Geo)
    conflicts with file from package
    python3-GDAL2-2.4.2-lp151.15.1.x86_64 (@System)

    File conflicts happen when two packages attempt to install files with the same name but different contents. If you continue, conflicting files will be replaced losing the previous content.
    Continue? [yes/no] (no): no

    Problem occurred during or after installation or removal of packages:
    Installation has been aborted as directed.
    Please see the above error message for a hint.

  2. #2

    Default Re: Leap 15.1 Zypper identifies File Conflict during routine update

    It looks like you have two repos supplying the same files. If you need files to come from a specific repository, you can run
    Code:
    zypper dup --from [repo name]
    to tell zypper which repo to use for updates in the future. It should ignore updates in the other repo. It will ask you to confirm a vendor change for each package that is upgraded. If you don't want to confirm each package you can use the --allow-vendor-change option with zypper to bypass that.

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,288

    Default Re: Leap 15.1 Zypper identifies File Conflict during routine update

    In case the above hint does not help, post your repos:
    Code:
    zypper lr -d
    Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

    An example is here: Using CODE tags Around your paste.
    Henk van Velden

  4. #4

    Default Re: Leap 15.1 Zypper identifies File Conflict during routine update

    Quote Originally Posted by noehlmann View Post
    File /usr/lib64/python3.6/site-packages/osgeo/__pycache__/osr.cpython-36.pyc
    from install of
    python3-GDAL-2.4.2-lp151.32.1.x86_64 (Geo)
    conflicts with file from package
    python3-GDAL2-2.4.2-lp151.15.1.x86_64 (@System)
    I'd say you shouldn't install python3-GDAL and python3-GDAL2 at the same time.

    Try to uninstall the latter, it's not even available in standard Leap 15.1 AFAICS (maybe the package was renamed at some point).
    You can't blame a madman if you go insane

  5. #5

    Default Re: Leap 15.1 Zypper identifies File Conflict during routine update

    Quote Originally Posted by wolfi323 View Post
    (maybe the package was renamed at some point).
    I has a look: In the Application:Geo repo, gdal has been updated to version 3.x. It also contains a gdal2 package now with the old 2.4 (probably for compatibility reasons).
    But indeed, they cannot be installed at the same time.
    A conflict has been added after the fact:
    https://build.opensuse.org/request/show/734391
    But you seem to still have an older python3-GDAL2 package installed from that repo, that didn't have that conflict yet.

    You'd still need to choose between one or the other though, as they contain the same files (in different versions).
    As zypper wants to install python3-GDAL, that's probably the one that you'd need.
    You can't blame a madman if you go insane

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •