Results 1 to 6 of 6

Thread: kernel headers not found

  1. #1

    Default kernel headers not found

    I'm trying to install vmware workstation and when I try to run it, I get the following error:

    Code:
    Kernel Headers for version 4.12.14-lp151.28.16-default were not found.
    I have installed:

    * kernel-devel
    * kernel-default-devel
    * kernel-syms

    Obviously, I'm missing something...

    Any suggestion?

    Thanks

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: kernel headers not found

    Quote Originally Posted by elfroggio View Post
    Obviously, I'm missing something...
    kernel-source, I'd guess.

    I've been told it shouldn't be necessary, but IME it usually is when compiling stuff.

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,979

    Default AW: kernel headers not found

    Post:
    Code:
    zypper se -si kernel

  4. #4

    Default Re: kernel headers not found

    Quote Originally Posted by brunomcl View Post
    kernel-source, I'd guess.

    I've been told it shouldn't be necessary, but IME it usually is when compiling stuff.
    No, already tried and that didn't work

    Thanks

  5. #5

    Default Re: AW: kernel headers not found

    Quote Originally Posted by Sauerland View Post
    Post:
    Code:
    zypper se -si kernel
    Thanks. I'll try that next week

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,293
    Blog Entries
    2

    Default Re: kernel headers not found

    The suggestion was to determine your installed kernel, you could also have done that running uname.

    But,
    More to the point is that you seem to have installed the correct packages for the "default kernel,"
    The remaining likely possibility is that somehow your kernel and its header packages aren't in sync (Obviously you need the header packages for your specific kernel).
    To re-sync, simply update your system
    Code:
    zypper up
    That has always fixed the problem for me.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •