Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: vncserver closed when I close the ssh terminal

  1. #11

    Default Re: vncserver closed when I close the ssh terminal

    Quote Originally Posted by arvidjaar View Post
    OK, I tested it and as I suspected - LXDE session starts a lot of processes under systemd user instance (and this includes D-Bus). When you exit ssh session, user systemd instance is also stopped which terminates a lot - including D-Bus, which likely brings down most remaining processes.
    In the previous message I just posted the process which appeared after xvnc and then the precess remaining once I closed the ssh session. As you said closing ssh sessions brings down most of them.



    To preserve them you need to enable lingering for systemd user instance:
    Code:
    loginctl enable-linger fperal
    yes, it worked.

    Two questions I'm not sure about:

    I have to include this in a boot scriipt or it is a persistent change?

    Is this the same as using KillExcludeUsers=fperal in /etc/systemd/logind.conf?
    My logind.conf is this




    Code:
    root@tutatis:/home/fperal> cat /etc/systemd/logind.conf
    #  This file is part of systemd.
    #
    #  systemd is free software; you can redistribute it and/or modify it
    #  under the terms of the GNU Lesser General Public License as published by
    #  the Free Software Foundation; either version 2.1 of the License, or
    #  (at your option) any later version.
    #
    # Entries in this file show the compile time defaults.
    # You can change settings by editing this file.
    # Defaults can be restored by simply deleting this file.
    #
    # See logind.conf(5) for details.
    
    [Login]
    #NAutoVTs=6
    #ReserveVT=6
    #KillUserProcesses=no
    #KillOnlyUsers=
    #KillExcludeUsers=root
    #InhibitDelayMaxSec=5
    #HandlePowerKey=poweroff
    #HandleSuspendKey=suspend
    #HandleHibernateKey=hibernate
    #HandleLidSwitch=suspend
    #HandleLidSwitchDocked=ignore
    #PowerKeyIgnoreInhibited=no
    #SuspendKeyIgnoreInhibited=no
    #HibernateKeyIgnoreInhibited=no
    #LidSwitchIgnoreInhibited=yes
    #HoldoffTimeoutSec=30s
    #IdleAction=ignore
    #IdleActionSec=30min
    #RuntimeDirectorySize=10%
    #RemoveIPC=no
    #InhibitorsMax=8192
    #SessionsMax=8192
    #UserTasksMax=33%
    root@tutatis:/home/fperal>

    Everything by default, so willl not be KillUserProcess=no?



    regards

  2. #12
    Join Date
    Sep 2012
    Posts
    5,139

    Default Re: vncserver closed when I close the ssh terminal

    Quote Originally Posted by fperal View Post
    I have to include this in a boot scriipt or it is a persistent change?
    It is persistent.
    Is this the same as using KillExcludeUsers=fperal in /etc/systemd/logind.conf?
    No.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •