Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: unable to start mongodb server

  1. #11

    Default Re: unable to start mongodb server

    Quote Originally Posted by ultra99 View Post
    Also, when I refresh my repos, i get this:

    Code:
    sudo zypper ref
    Repository 'openSUSE:Tumbleweed' is up to date.                                 
    Repository 'server:database' is up to date.                                     
    Repository 'openSUSE:Factory:NonFree' is up to date.                            
    Repository 'Packman Repository' is up to date.                                  
    Repository 'openSUSE-Tumbleweed-Non-Oss' is up to date.                         
    Repository 'openSUSE-Tumbleweed-Oss' is up to date.                             
    Repository 'openSUSE-Tumbleweed-Update' is up to date.                          
    Retrieving repository 'repo_to_install_libboost_for_mongodb' metadata ...[error]
    Repository 'repo_to_install_libboost_for_mongodb' is invalid.
    [repo_to_install_libboost_for_mongodb|http://download.opensuse.org/reposit...nSUSE_Factory/] Valid metadata not found at specified URL
    Please check if the URIs defined for this repository are pointing to a valid repository.
    Skipping repository 'repo_to_install_libboost_for_mongodb' because of the above error.
    Repository 'Databases (openSUSE_Tumbleweed)' is up to date.                     
    Repository 'snappy' is up to date.                                              
    Some of the repositories have not been refreshed because of an error.
    I noticed that the link wasn't complete, so I fixed that. I don't get that error anymore. However, as soon as I reboot, i run:


    Code:
    systemctl status mongodb
    ● mongodb.service - High-performance, schema-free document-oriented database
       Loaded: loaded (/usr/lib/systemd/system/mongodb.service; disabled; vendor pr>
       Active: inactive (dead)
    but then it ends with:

    Code:
    mongodb.service - High-performance, schema-free document-oriented database
       Loaded: loaded (/usr/lib/systemd/system/mongodb.service; disabled; vendor pr>
       Active: failed (Result: exit-code) since Fri 2019-10-11 08:54:23 EDT; 2min 3>

  2. #12
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,299
    Blog Entries
    2

    Default Re: unable to start mongodb server

    Quote Originally Posted by ultra99 View Post
    I noticed that the link wasn't complete, so I fixed that. I don't get that error anymore. However, as soon as I reboot, i run:


    Code:
    systemctl status mongodb
    ● mongodb.service - High-performance, schema-free document-oriented database
       Loaded: loaded (/usr/lib/systemd/system/mongodb.service; disabled; vendor pr>
       Active: inactive (dead)
    but then it ends with:

    Code:
    mongodb.service - High-performance, schema-free document-oriented database
       Loaded: loaded (/usr/lib/systemd/system/mongodb.service; disabled; vendor pr>
       Active: failed (Result: exit-code) since Fri 2019-10-11 08:54:23 EDT; 2min 3>
    By default all newly installed services aren't running by default, you have to start the service with the command I gave, and only then check status.
    Once you've verified the services starts and runs, don't forget to enable so it starts on boot
    Code:
    systemctl enable mongodb.service
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #13

    Default Re: unable to start mongodb server

    Quote Originally Posted by tsu2 View Post
    By default all newly installed services aren't running by default, you have to start the service with the command I gave, and only then check status.
    Once you've verified the services starts and runs, don't forget to enable so it starts on boot
    Code:
    systemctl enable mongodb.service
    TSU
    Yep, it also worked about a reboot. Thanks a ton for your help!!

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •