Results 1 to 10 of 10

Thread: How to make a request for Leap 15.1 update to QT 5.12 lts?

  1. #1

    Wink How to make a request for Leap 15.1 update to QT 5.12 lts?

    opensuse leap 15.1 come with QT 5.9 that is a version too old of QT for the current dev and almost every distro including those that are LTS are using a version greater than or equal to QT 5.10, so how can i make a push to opensuse leap 15.1 update to QT 5.12 lts?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,901
    Blog Entries
    3

    Default Re: How to make a request for Leap 15.1 update to QT 5.12 lts?

    Doing a quick check, I see that Tumbleweed is at QT 5.13.1. But Leap 15.2 Alpha is still at QT 5.9.7.

    There is probably a testing repo you could use for a newer QT. Or you could post a bug report as a feature request.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,059
    Blog Entries
    14

    Default Re: How to make a request for Leap 15.1 update to QT 5.12 lts?

    You would have to add the KDE repos. But it's not coming to Leap 15.1 itself. Maybe as an update through the Update repo. If you want to be sure to run the latest, run Tumbleweed.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: How to make a request for Leap 15.1 update to QT 5.12 lts?

    Thank you for the reply, but i am more interesting on put on the table that leap 15.1 can be updated to QT 5.12, giving a easy way for developers transport the app to opensuse, others distro are ahead because this.

  5. #5

    Default Re: How to make a request for Leap 15.1 update to QT 5.12 lts?

    Quote Originally Posted by nrickert View Post
    Doing a quick check, I see that Tumbleweed is at QT 5.13.1. But Leap 15.2 Alpha is still at QT 5.9.7.

    There is probably a testing repo you could use for a newer QT. Or you could post a bug report as a feature request.
    where can i make that report?

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,901
    Blog Entries
    3

    Default Re: How to make a request for Leap 15.1 update to QT 5.12 lts?

    Quote Originally Posted by walddys View Post
    where can i make that report?
    https://en.opensuse.org/openSUSE:Submitting_bug_reports
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,499
    Blog Entries
    2

    Default Re: How to make a request for Leap 15.1 update to QT 5.12 lts?

    The following command should add the KDE Qt repo, which currently provides Qt 5.13, updated just yesterday

    It helps to know that KDE/Plasma is the biggest promoter of Qt in a DE today, so there will be a KDE repo for that technology, and it can be found on this page
    https://en.opensuse.org/SDB:KDE_repositories

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,402

    Default Re: How to make a request for Leap 15.1 update to QT 5.12 lts?

    Quote Originally Posted by walddys View Post
    Thank you for the reply, but i am more interesting on put on the table that leap 15.1 can be updated to QT 5.12, giving a easy way for developers transport the app to opensuse, others distro are ahead because this.
    That is not the way Leap versioning works. There will normaly be no upgrades to new versions of components of a Leap version. When a newer Leap version is released, it will have the newest version of everything that coul be tested (and passed the testing) of that new Leap version in time.

    This to have a stable OS. Stable not only in the sense that things will not break, but also in the sense that there will be no changes for the users during the lifetime of that Leap version. Typicaly a strong whish for those that use a system for day to day scores, where the same functionality as that of yesterday is very, very important.
    Henk van Velden

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,901
    Blog Entries
    3

    Default Re: How to make a request for Leap 15.1 update to QT 5.12 lts?

    I'll note that, according to an announcement today
    KDE and openSUSE: Plasma 5.17, Qt 5.14 and more
    Leap 15.2 will come with QT5.12 and KDE 5.18.

    I think that's expected to be available around next May. It is currently in alpha testing, but the newer software versions are not yet there in the alpha test release.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  10. #10

    Default Re: How to make a request for Leap 15.1 update to QT 5.12 lts?

    Ok, thank you very much for the advices

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •