Results 1 to 2 of 2

Thread: Thinkpad T490 GeForce MX250 driver problems

Hybrid View

  1. #1
    Join Date
    Nov 2016
    Location
    Dresden
    Posts
    14

    Exclamation Thinkpad T490 GeForce MX250 driver problems

    Hey guys,

    on my Thinkpad T490 with GeForce MX250 I installed the nvidia driver 430.50 via nomodeset 3. Everything worked fine, the driver seems to work:

    Code:
    sudo hwinfo --gfxcard
    31: PCI 3c00.0: 0302 3D controller                              
      [Created at pci.386]
      Unique ID: Hy9f.p2OmpqdkWMC
      Parent ID: 1GTX.ToDZF2VH824
      SysFS ID: /devices/pci0000:00/0000:00:1d.0/0000:3c:00.0
      SysFS BusID: 0000:3c:00.0
      Hardware Class: graphics card
      Model: "nVidia GP108M [GeForce MX250]"
      Vendor: pci 0x10de "nVidia Corporation"
      Device: pci 0x1d13 "GP108M [GeForce MX250]"
      SubVendor: pci 0x17aa "Lenovo"
      SubDevice: pci 0x2278 
      Revision: 0xa1
      Driver: "nvidia"
      Driver Modules: "nvidia"
      Memory Range: 0xdb000000-0xdbffffff (rw,non-prefetchable)
      Memory Range: 0x80000000-0x8fffffff (ro,non-prefetchable)
      Memory Range: 0x90000000-0x91ffffff (ro,non-prefetchable)
      I/O Ports: 0x2000-0x2fff (rw)
      IRQ: 16 (no events)
      Module Alias: "pci:v000010DEd00001D13sv000017AAsd00002278bc03sc02i00"
      Driver Info #0:
        Driver Status: nouveau is not active
        Driver Activation Cmd: "modprobe nouveau"
      Driver Info #1:
        Driver Status: nvidia_drm is active
        Driver Activation Cmd: "modprobe nvidia_drm"
      Driver Info #2:
        Driver Status: nvidia is active
        Driver Activation Cmd: "modprobe nvidia"
      Config Status: cfg=new, avail=yes, need=no, active=unknown
      Attached to: #26 (PCI bridge)
    
    32: PCI 02.0: 0300 VGA compatible controller (VGA)
      [Created at pci.386]
      Unique ID: _Znp._kksIQUorSC
      SysFS ID: /devices/pci0000:00/0000:00:02.0
      SysFS BusID: 0000:00:02.0
      Hardware Class: graphics card
      Model: "Intel UHD Graphics 620 (Whiskey Lake)"
      Vendor: pci 0x8086 "Intel Corporation"
      Device: pci 0x3ea0 "UHD Graphics 620 (Whiskey Lake)"
      SubVendor: pci 0x17aa "Lenovo"
      SubDevice: pci 0x2278 
      Driver: "i915"
      Driver Modules: "i915"
      Memory Range: 0xdc000000-0xdcffffff (rw,non-prefetchable)
      Memory Range: 0x70000000-0x7fffffff (ro,non-prefetchable)
      I/O Ports: 0x3000-0x303f (rw)
      Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
      IRQ: 138 (457 events)
      Module Alias: "pci:v00008086d00003EA0sv000017AAsd00002278bc03sc00i00"
      Driver Info #0:
        Driver Status: i915 is active
        Driver Activation Cmd: "modprobe i915"
      Config Status: cfg=new, avail=yes, need=no, active=unknown
    
    Primary display adapter: #32
    When I run nvidia-settings, I get:

    Code:
    nvidia-settings
    
    ERROR: Unable to load info from any available system
    The same for nvidia-xconfig. My applications do not recognize the nvidia-driver (e.g. blender, UE4 engine). Nouveau is blacklisted.

    Do you have any suggestions on how I can make my driver work? The same procedure worked on my desktop-pc with tumbleweed and GeForce 2060 without problems.

    Thx, reiti

  2. #2
    Join Date
    Nov 2016
    Location
    Dresden
    Posts
    14

    Default Re: Thinkpad T490 GeForce MX250 driver problems

    solved via prime-select nvidia

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •