Results 1 to 7 of 7

Thread: VirtualBox vs. Vagrant: incompatible versions

  1. #1
    Join Date
    Oct 2014
    Location
    Montpezat (France)
    Posts
    38

    Default VirtualBox vs. Vagrant: incompatible versions

    Hi,

    I'm running VirtualBox 6.0 on my workstation. I just installed Vagrant to manage virtual machines easier. Unfortunately it doesn't seem to work. I get an error message informing me that the version of Vagrant shipping with OpenSUSE Leap 15.1 only supports VirtualBox 4.0 to 5.2.

    What now? Any suggestions?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,387
    Blog Entries
    2

    Default Re: VirtualBox vs. Vagrant: incompatible versions

    1. Submit a "feature request" for new Vagrant packages at https://bugzilla.opensuse.org

    2. Vagrant is a collection of scripts. I'm sure if you download directly from their website at the following page, you'll get the latest

    https://www.vagrantup.com/downloads.html

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Oct 2014
    Location
    Montpezat (France)
    Posts
    38

    Default Re: VirtualBox vs. Vagrant: incompatible versions

    Quote Originally Posted by tsu2 View Post
    1. Submit a "feature request" for new Vagrant packages at https://bugzilla.opensuse.org

    2. Vagrant is a collection of scripts. I'm sure if you download directly from their website at the following page, you'll get the latest

    https://www.vagrantup.com/downloads.html

    TSU
    I just found a third-party repo for a recent version of Vagrant that works perfectly.

    Problem solved.

    Cheers.

  4. #4

    Default Re: VirtualBox vs. Vagrant: incompatible versions

    Quote Originally Posted by microlinux View Post
    I just found a third-party repo for a recent version of Vagrant that works perfectly.

    Problem solved.

    Cheers.
    Could you post the third party repo?

    Thanks.
    Cheers.

  5. #5

    Default Re: VirtualBox vs. Vagrant: incompatible versions

    Quote Originally Posted by tsu2 View Post
    2. Vagrant is a collection of scripts. I'm sure if you download directly from their website at the following page, you'll get the latest

    https://www.vagrantup.com/downloads.html

    TSU
    on this site you link here, all vagrant downloads are all meant to be used with other linux distributions. Or is there one, that you could recoment for use on leap 15.1?

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,387
    Blog Entries
    2

    Default Re: VirtualBox vs. Vagrant: incompatible versions

    Quote Originally Posted by seb234 View Post
    on this site you link here, all vagrant downloads are all meant to be used with other linux distributions. Or is there one, that you could recoment for use on leap 15.1?
    Yes, the one for just "Linux"

    None of the distro=specific versions, not necessary or wanted.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7

    Thumbs up Re: VirtualBox vs. Vagrant: incompatible versions

    thanks a lot for your hint!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •