Results 1 to 7 of 7

Thread: Dolby Surround 4.0 via HDMI output not working

  1. #1

    Default Dolby Surround 4.0 via HDMI output not working

    Hello guys,

    I have an AMD Ryzen 5 2400G processor and use the iGPU
    The motherboard has a HDMI and a Display Port output.
    I've connected the HDMI output to a receiver (Pioneer) and that is connected to the TV and 4 speakers (two in front, two in behind).
    I'd like to make use of all four speakers, but Pulse audio/pavucontrol tells me that just stereo is available and 5.1, 7.1 surround is only available for HDMI2, which isn't even a connection on my mainboard, but I guess it refers to the DP output.

    Still, I'd like to use the entire speaker configuration, which works with VLC when telling it to use ALSA and then it works.
    But every other program does not.

    I found out that I have to configure ALSA to be used instead of PulseAudio, but I haven't found a way that actually works, I just almost lost my audio and I don't want to break it completely.
    I've already searched the Internet and this forum, but didn't find a solution yet.
    So I hope, you can help me.

    Thanks in advance!

    Sincerely,
    Tobi_Peter

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,395
    Blog Entries
    1

    Default Re: Dolby Surround 4.0 via HDMI output not working

    Quote Originally Posted by Tobi_Peter View Post
    Hello guys,

    I have an AMD Ryzen 5 2400G processor and use the iGPU
    The motherboard has a HDMI and a Display Port output.
    I've connected the HDMI output to a receiver (Pioneer) and that is connected to the TV and 4 speakers (two in front, two in behind).
    I'd like to make use of all four speakers, but Pulse audio/pavucontrol tells me that just stereo is available and 5.1, 7.1 surround is only available for HDMI2, which isn't even a connection on my mainboard, but I guess it refers to the DP output.
    Can you show us the output from
    Code:
    pacmd list-cards
    Still, I'd like to use the entire speaker configuration, which works with VLC when telling it to use ALSA and then it works.
    But every other program does not.

    I found out that I have to configure ALSA to be used instead of PulseAudio, but I haven't found a way that actually works, I just almost lost my audio and I don't want to break it completely.
    It is possible to disable PulseAudio with
    Code:
    sudo setup-pulseaudio --disable
    but depending on your desktop environment that may effectively break audio in doing so. Applications that are ok with ALSA will still work though I guess.
    openSUSE Leap 15.0; KDE Plasma 5

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,395
    Blog Entries
    1

    Default Re: Dolby Surround 4.0 via HDMI output not working

    Some pertinent information about PA and disabling PA in desktop environments...and various implications of doing so...
    https://en.opensuse.org/SDBulseaudio
    openSUSE Leap 15.0; KDE Plasma 5

  4. #4

    Default Re: Dolby Surround 4.0 via HDMI output not working

    Quote Originally Posted by deano_ferrari View Post
    Can you show us the output from
    Code:
    pacmd list-cards


    It is possible to disable PulseAudio with
    Code:
    sudo setup-pulseaudio --disable
    but depending on your desktop environment that may effectively break audio in doing so. Applications that are ok with ALSA will still work though I guess.
    First of all, thanks for your help.

    Here's the output: https://pastebin.com/cHshA3rd

    Well, I'd like to use other applications that use Pulse, so that's not an option for me, but thanks.


    And I've done some additional research on my own and found a "fix" that breaks something else/ I have something else to break to make surround sound work:

    The PC I'm talking about is connected to an AV receiver and that's connected to the TV.
    The problem is that while booting the PC can't fetch the EDID file of the TV, so it sets the lowest available resolution.
    So far no problem.
    BUT the TV can't display it normally in that mode, but in the "TV mode", where every border is cut by a little bit and after booting, I have to set the TV manually back to "normal mode" to use the PC normally.

    I fixed that issue by forcing a custom edid file for the output (see here, last post).

    Now, I found out that the audio problem is a "driver problem" and I have to enable "amdgpu.dc=1" in kernel parameters (see here, that's the German wiki, this description is not available in the English one, but I've translated it here).

    When i do that, nothing changes.
    EXCEPT I remove the "drm_kms_helper.edid_firmware=HDMI-A-1:edid/edid.bin" option from the kernel parameters, then it works.
    But then, the resolution is not set properly again.
    When you want to see my grub config, just tell me.

    So... I have to break one thing, to fix the other one.

    How can I make both work? O.o
    And why does surround sound not work when forcing an edid file? (dunno, maybe someone knows why )
    Can I maybe force the edid file just for boot up?

    Thanks in advance!
    And have a nice day.

  5. #5

    Default Re: Dolby Surround 4.0 via HDMI output not working

    Quote Originally Posted by deano_ferrari View Post
    Some pertinent information about PA and disabling PA in desktop environments...and various implications of doing so...
    https://en.opensuse.org/SDBulseaudio
    Thanks, I don't think that's a thing for me.

    Could you maybe have a look at my previous post?
    Maybe you know what to do?

    Thank you.

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: Dolby Surround 4.0 via HDMI output not working

    If EDID is not working you need to set resolution in a /etc/X11/xorg.xorg.conf.d file to match what the output device wants.

    look at man xrandr to see what the system thinks is connected

  7. #7

    Default Re: Dolby Surround 4.0 via HDMI output not working

    Quote Originally Posted by gogalthorp View Post
    If EDID is not working you need to set resolution in a /etc/X11/xorg.xorg.conf.d file to match what the output device wants.

    look at man xrandr to see what the system thinks is connected
    Well, I fixed it myself.
    The problem was the forced EDID file, since it was extracted by my TV and it told my PC that just stereo audio is available and therefore no surround sound was shown.
    I made it available though by creating a new EDID file with lightworks device info something, enabled 7.1 surround sound, forced that one and now everything works as expected.

    Thank you all for your help.

    Have a nice day!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •